Package Details: l2tp-ipsec-vpn 1.0.9-3

Git Clone URL: https://aur.archlinux.org/l2tp-ipsec-vpn.git (read-only)
Package Base: l2tp-ipsec-vpn
Description: A GUI to manage L2TP over IPsec virtual private network connections.
Upstream URL: https://launchpad.net/l2tp-ipsec-vpn
Licenses: GPL
Submitter: mlq
Maintainer: mlq
Last Packager: mlq
Votes: 6
Popularity: 0.000856
First Submitted: 2013-08-07 22:32
Last Updated: 2015-06-15 18:17

Latest Comments

rmlopes commented on 2017-06-30 14:33

I am having a problem compiling pkcs11:

src/pkcs11/SmartCardInfo.cpp: In static member function ‘static QString SmartCardInfo::BNOneLine(const BIGNUM*)’:
src/pkcs11/SmartCardInfo.cpp:105:26: error: too few arguments to function ‘void CRYPTO_free(void*, const char*, int)’
::CRYPTO_free(pcHex);
^
In file included from /usr/include/openssl/bn.h:33:0,
from src/pkcs11/SmartCardInfo.cpp:27:
/usr/include/openssl/crypto.h:277:6: note: declared here
void CRYPTO_free(void *ptr, const char *file, int line);
^~~~~~~~~~~
make[1]: *** [nbproject/qt-Release.mk:565: build/Release/SmartCardInfo.o] Error 1


Anyone has a workaround? Should this be updated to depend and link to pkcs11 packages instead?

Red54 commented on 2013-11-18 14:30

add qt4.patch:

https://git.oschina.net/Red54/aur-red54/tree/master/l2tp-ipsec-vpn

https://git.oschina.net/Red54/aur-red54/blob/master/l2tp-ipsec-vpn-1.0.9-3.src.tar.gz

Anonymous comment on 2013-08-18 09:47

fixed now. Out of curiosity, what lines did you change?

Anonymous comment on 2013-08-18 01:20

I get an error right after extract of l2tp-ipsec-vpn, right as it starts to make

it says nbproject/qt-Release.mk no such file or directory.

and then make fails

I checked in the l2tp-ipsec-vpn_1.0.9.tar.gz and nbproject folder is there, however qt-Release.mk is not. Only qt-Release.pro.

What do you think?