Package Details: labplot-kf5 2.4.0-3

Git Clone URL: https://aur.archlinux.org/labplot-kf5.git (read-only)
Package Base: labplot-kf5
Description: A free software data analysis and visualization application, for two and three-dimensional graphical presentation of data sets and functions.
Upstream URL: http://labplot.sourceforge.net/
Licenses: GPL
Submitter: b00rt00s
Maintainer: b00rt00s
Last Packager: b00rt00s
Votes: 6
Popularity: 0.003657
First Submitted: 2015-10-31 21:19
Last Updated: 2017-08-22 11:35

Latest Comments

vicp74 commented on 2017-09-21 21:34

Thank you for this package!
I think you can remove 'kdebase-runtime' from the deps and forget about Qt4. I tested the following modifications in the PKGBUILD using a clean chroot and it worked:

depends=('gsl' 'fftw' 'netcdf' 'cfitsio' 'cantor' 'kdelibs4support')
makedepends=('cmake' 'extra-cmake-modules' 'kdesignerplugin' 'kdoctools')

Note that I added 'cantor' and it depends on 'knewstuff'.

You can also remove update-{desktop,mime}-database from labplot-kf5.install and use hooks instead.

mSSM commented on 2017-08-15 23:26

knewstuff from extra should be added to the makedepends (maybe also depends) list.

abriasffxi commented on 2016-11-13 04:10

need to add kdesignerplugin as well

creeper123123321 commented on 2016-10-24 21:05

please add kdelibs4support as dependency

htower commented on 2016-10-06 15:21

Last version doesn't run from KDE's menu or krunner, but starts successful from terminal. My "fix" is edit /usr/share/applications/labplot2.desktop :

Exec=labplot2 -caption %c %i %f

replace with

Exec=labplot2

sirocco commented on 2016-08-27 05:26

Build falls without kdesignerplugin and kdelibs4support

b00rt00s commented on 2016-03-29 18:10

I will update package to 2.2.0 just after I will resolve some compiling issues.

b00rt00s commented on 2016-02-24 10:47

I've added it to makedepends, however I don't really know if it's needed for runtime.

excalibur1234 commented on 2016-02-24 09:18

the build failed for me.
after i installed kdoctools, it succeeded.

please add kdoctools to the dependency list.

XavierCLL commented on 2015-11-04 04:26

Hi, here is the PKGBUILD adjusted: http://pastebin.com/2tdUj5KS