Package Details: laptop-mode-tools 1.72.2-4

Git Clone URL: https://aur.archlinux.org/laptop-mode-tools.git (read-only)
Package Base: laptop-mode-tools
Description: Power Saving tool for Linux
Upstream URL: https://github.com/rickysarraf/laptop-mode-tools/
Licenses: GPL
Submitter: stativ
Maintainer: dbermond
Last Packager: dbermond
Votes: 165
Popularity: 1.309529
First Submitted: 2014-01-25 11:30
Last Updated: 2018-12-03 15:22

Dependencies (9)

Required by (0)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

rarvolt commented on 2015-04-06 09:32

@aaditya's PKGBUILD not works. lmt-gui_1.65.tar.gz - 404

kaptoxic commented on 2015-04-04 18:27

GUI works nicely. Thanks!

lybin commented on 2015-04-04 13:03

Updated. To work LMT GUI need to install optional package: python2-pyside.

aaditya commented on 2014-08-20 16:52

Hi, I created a PKGBUILD for the Gui:
https://gist.github.com/aadityabagga/0c17be09ee4b62485e67

Earlier I had tried to create a split package for LMT and the Gui, but had not succeeded at it; maybe I will give it a go later.

Note that I havent actually tested this PKGBUILD though.

To run it you could try in a terminal:
lmt-gui

Or if that does not work:
sudo python2 /usr/bin/lmt-gui

aaditya commented on 2014-08-20 16:49

Hi, I created a PKGBUILD for the Gui:
https://gist.github.com/aadityabagga/0c17be09ee4b62485e67

Earlier I had tried to create a split package for LMT and the Gui, but had not succeeded at it; maybe I will give it a go later.

Note that I havent actually tested this PKGBUILD though.

kaptoxic commented on 2014-08-20 15:07

Do you think it is possible to make a new (separate) package just for the GUI? I agree that it is not a good idea to include the GUI within this package...

aaditya commented on 2014-08-14 15:09

@kaptoxic,

There is a GUI in the source, but it was not being installed by the package.

However to use the GUI I had to install python2-pyside from the AUR, which took some time to build along with its dependencies (15-20 min), and was a big package as well (40+ Mb).

So if you want to use the GUI you can build and install the dependencies, and copy LMT.py from the gui folder in the source to your system, and run as sudo python2 LMT.py

aaditya commented on 2014-08-14 14:01

The usb-autosuspend module was dropped by upstream and is now handled by the runtime-pm module. [1]

It has been removed from this package as well.

[1]: https://github.com/rickysarraf/laptop-mode-tools/commit/ad323f37b22ef0088dd687e0af040afe309e2dcb

aaditya commented on 2014-08-14 14:01

I dont think there is a GUI (at least not in this package).

aaditya commented on 2014-08-14 13:55

The usb-autosuspend module was dropped by upstream and is now handled by the runtime-pm module. [1]

It has been removed from this package as well.

[1]: https://github.com/rickysarraf/laptop-mode-tools/commit/ad323f37b22ef0088dd687e0af040afe309e2dcb