Package Details: lastpass-pocket 4.1.20-1

Git Clone URL: https://aur.archlinux.org/lastpass-pocket.git (read-only)
Package Base: lastpass-pocket
Description: Backup and offline access for LastPass
Upstream URL: https://lastpass.com
Licenses: custom:LastPass
Submitter: Det
Maintainer: ava1ar
Last Packager: ava1ar
Votes: 63
Popularity: 0.005328
First Submitted: 2013-05-27 23:27
Last Updated: 2016-11-09 04:44

Latest Comments

linux4678 commented on 2017-02-02 17:59

hello this package only shows 7 of my entries and i have over 100. i have tried this on ubuntu 16.04 as well same problem. anyone else have this problem?

Soulo.toochi commented on 2017-01-19 00:29

app crashes on me i cant figure out why but when i hit login it crashes

vhbsouza commented on 2016-11-10 17:51

When I tried to open, it shows:

lastpass: /usr/lib/libcrypto.so.1.0.0: no version information available (required by lastpass)
lastpass: /usr/lib/libssl.so.1.0.0: no version information available (required by lastpass)
[1] 7021 illegal hardware instruction (core dumped) lastpass

txtsd commented on 2016-11-08 07:09

It tries to build openssl when libressl (2.5.0) is installed.

==> Downloading lastpass-pocket PKGBUILD from AUR...
x .SRCINFO
x PKGBUILD
x lastpass.desktop
x lastpass.png

lastpass-pocket 4.1.20-1 (2016-08-29 03:12)
( Unsupported package: Potentially dangerous ! )
==> lastpass-pocket dependencies:
- ca-certificates (already installed)
- libldap (already installed)
- libidn (already installed)
- gtk2 (already installed)
- libpng12 (already installed)
- openssl>=1.0.0 (package found)
- librtmp0 (package found)


==> Continue building lastpass-pocket ? [Y/n]
==> -----------------------------------------
==>
==> Building and installing package
==> Install or build missing dependencies for lastpass-pocket:
resolving dependencies...
looking for conflicting packages...
:: openssl and libressl are in conflict. Remove libressl? [y/N]
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: openssl and libressl are in conflict
==> Restart building lastpass-pocket ? [y/N]
==> ----------------------------------------
==>

ava1ar commented on 2016-10-16 17:09

sergey.orloff
This is just a warning - software works as expected. Do you have any issues with it?

sergey.orloff commented on 2016-10-16 17:06

lastpass: /usr/lib/libcrypto.so.1.0.0: no version information available (required by lastpass)

MKody commented on 2016-08-21 20:54

sha1sum doesn't look like the right one for pocket_x64_4.0.0.tar.bz2 (at least).
I've got 893ec51711f1030ed575b895fef145982124496d

ava1ar commented on 2016-07-24 18:10

kubrick, thanks! Addressed your comments.

kubrick commented on 2016-07-24 07:54

Hello, the sed hack is horrible and not necessary any more (version 4 is built against openssl 1.0) and the rtmpdump dependency should be replaced with librtmp0.

ava1ar commented on 2016-01-08 01:55

peterhoeg, thanks, applied!

peterhoeg commented on 2016-01-07 02:25

It's better to use a versioned file when downloading so that things don't break when people are using a central store for the downloads and upgrade to a new version.

Quick patch here: https://gist.github.com/6cf044419266a7299d86

ava1ar commented on 2016-01-06 16:34

Updated. FadeMind, thanks for help!

FadeMind commented on 2016-01-05 19:26

Updated PKGBUILD:
https://pastebin.com/raw/Q4mYPJX4

package 3.2.16 need 'rtmpdump' depend and additional change :
sed -i -e 's/librtmp.so.0/librtmp.so.1/g'

spapanik21 commented on 2015-10-21 07:17

The checksums are wrong in the PKGBUILD. Could you please update them?

widowild commented on 2015-10-02 10:24

Hello,

$ sha1sum ./pocket*
97bae5c0895f7002dec2b3017f081aff34fe489a ./pocket.tar.bz2
37dd50684f72ec5d1fd5e528c87cc7e43cccf679 ./pocket_x64.tar.bz2

ava1ar commented on 2014-07-31 04:28

Adopted. openssl098 added to the dependencies, since package build with this version.

ava1ar commented on 2014-07-11 04:50

Current version is 3.1.40

ianonavy commented on 2014-07-08 06:17

MD5 out of date again.

cdown commented on 2014-04-14 10:03

I have adopted the package (see https://mailman.archlinux.org/pipermail/aur-general/2014-April/027948.html) and will fix it shortly.

hanckmann commented on 2014-04-04 13:08

I have added an updated PKGBUILD:
http://pastebin.com/GW1FB8PZ

I hope this will help you updating this package to the new version.

tuftedocelot commented on 2014-03-22 13:23

Anyone getting these error messages?:
lastpass: /usr/lib/libssl.so.1.0.0: no version information available (required by lastpass)
lastpass: /usr/lib/libcrypto.so.1.0.0: no version information available (required by lastpass)

ansch commented on 2014-03-19 03:02

Hi there, is the package abandoned? The MD5 check fails on pocket_x64.tar.bz2

fluteyoshi commented on 2013-09-05 16:50

Updated PKGBUILD for version 2.0.32, updated PNG to new LastPass icon.

xyproto commented on 2013-06-01 20:34

Hi, after a request on the mailing list, I'm planning to rename this package to lastpass-pocket. Please adopt the lastpass-pocket package if you wish to continue to maintain it. Thanks.

orschiro commented on 2013-03-07 05:02

I support Kyrias idea. Please be consistent with the actual program and rename it to lastpass-pocket.

kyrias commented on 2013-03-01 11:54

This package should be renamed. If anything, lastpass-universal deserves the lastpass name.

Sylar68 commented on 2012-12-16 17:53

Update to 2.0.2. And why x64 URL isn't https://download.lastpass.com/pocket_x64.tar.bz2 ?

ava1ar commented on 2012-10-10 03:47

Why this was flagged as out-of-date? I don't see update on web site. Unflagging...

michalmiddleton commented on 2012-08-22 00:54

Works great but still misses the libpng12 dependency. :)

Speaking of libpng12, that one misses libtool in dependencies.

wting commented on 2012-06-23 09:17

LastPass has been updated upstream. PKGBUILD needs to update checksums, and pocket_x64 is no longer packed by upx.

ava1ar commented on 2012-05-25 02:43

kwirkie,

yes, but this is not a problem, since libpng12 is available in aur and doesn't contains security issues, like old openssl. A lot of legacy apps require libpng12 (I have google-talkplugin and sublime-text). So, just add it to the dependencies.

kwirkie commented on 2012-05-24 18:34

Thanks, ava1ar. Works a treat, but it still requires 'libpng12', so it needs adding to the dependencies.

ava1ar commented on 2012-05-23 02:41

kwirkie,

it is building perfectly, the only change required is removing UPX stuff, since files are not packed with UPX in version 1.90. Here is working PKGBUILD without outdated dependencies. This is working PKGBUILD: http://pastebin.com/rQ1Hy618

kwirkie commented on 2012-05-19 18:15

I was having issues building version 1.90.0 with techlive's fix (upx was raising an error). Therefore I built with 'openssl098' as before. Also, when trying to use lastpass, it complained it was missing libpng12.so.0, as provided by 'libpng12'.

I also changed the source in the PKGBUILD to reference sources as listed on https://lastpass.com/releases/ , as the links contain the version number, stopping the PKGBUILD being borked between updates.

Built 1.90.0 with the following PKGBUILD: http://pastebin.com/kF9rQ8p6 (md5sums should be correct for i686 and x86_64)

All working fine, tested on x86_64

Thanks :)

wanderxjtu commented on 2012-03-12 09:31

the binary name in the pocket_x64.tar.bz2 is pocket_x64. So the name in this PKGBUILD is not right. Also the source and md5sums in x86_64 part are not matching.

techlive commented on 2012-03-11 02:36

I have sent you a nemail which I also add a desktop file for it.

jomasti commented on 2012-03-11 02:34

Alright, I've updated with your changes. Thanks for your help.

techlive commented on 2012-03-10 20:47

I have encountered the same problem that @rAX and @drelyn86 reported before.

* SSL certificate problem, verify that the CA cert is OK. Details:
error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
* Closing connection #0
Linux HTTP(S) Post failed
Code: 0 Error String: Peer certificate cannot be authenticated with known CA certificates

And I objdumped the binary file, did some debuging, it seems the problem is openssl098 somehow could not use the CApath flag specified while compiling.

Then I replaced the all the 0.9.8 version of the libssl and libcrypto with version 1.0.0, and suprisingly it worked.

So, here is a dirty workaround, may let us get rid of this problem and openssl098 until the new version of lastpass pocket come out.

http://pastebin.com/aQvFwz46

xduugu commented on 2012-03-08 14:32

Could you please change the openssl-0.9.8 dependency from openssl-compatibility[1] to openssl098[2], since the former uses a build from 2010 which contains security issues. Thanks.

[1] https://aur.archlinux.org/packages.php?ID=36308
[2] https://aur.archlinux.org/packages.php?ID=40574

gosella commented on 2012-01-20 22:31

There are new files available to download. These are the MD5:

2ef5d1ca2e4b5c5121a24158e2c9a7d8 pocket.tar.bz2
c30d0baa915a848a13dbb45680836c09 pocket_x64.tar.bz2

The version reported by the program is still 1.80.0 (but the year has been updated to 2012).

By the way, the url published at the website are 'https://download.lastpass.com/...' instead of 'https://rodan.lastpass.com/...' (although both seams to work).

mseiwald commented on 2011-06-01 16:20

I get exactly the same messages on my system and it works fine. This is definetly an issue with certificate verification.

0rAX0 commented on 2011-06-01 14:38

lastpass: /usr/lib/liblber-2.4.so.2: no version information available (required by lastpass)
lastpass: /usr/lib/libldap_r-2.4.so.2: no version information available (required by lastpass)
lastpass: /usr/lib/libcrypto.so.0.9.8: no version information available (required by lastpass)
lastpass: /usr/lib/libssl.so.0.9.8: no version information available (required by lastpass)

what about these? Well, not actually missing, but there's something wrong with them.

mseiwald commented on 2011-06-01 13:10

rAX: There are no libs missing. If a required lib is missing, lastpass does not start at all.

0rAX0 commented on 2011-06-01 09:06

What about the missing libs? I think they're affecting the program somehow!

0rAX0 commented on 2011-06-01 08:59

What about the missing libs? I think they're affecting the program somehow!

mseiwald commented on 2011-05-31 20:52

Update:

I tried this on a fresh 32 bit Arch VM and get the same error as rAX and T13one.

On my 64 bit host system it says:

CAfile: /etc/ssl/certs/ca-certificates.crt
CApath: none

and can successfully verfiy the certificate. My guess is that this has something to do with openssl-compatibility because with the latest openssl it works with -CApath: /etc/ssl/certs on 64 _and_ 32 bit systems.

So, I don't have a solution. Maybe someone else can investigate.

As a side effect I cleaned up the deps. (libkrb53 ist no longer needed)

mseiwald commented on 2011-05-31 15:36

Updated.

@rAX:
Please do:

$ openssl s_client -connect rodan.lastpass.com:443 -CAfile /etc/ssl/certs/AddTrust_External_Root.pem

You should see "Verify return code: 0 (ok)" at the bottom of the output. The certificate is part of ca-certificates which is a dependency in my PKGBUILD. Maybe you have to do a 'update-ca-certificates --fresh' as root. (ca-certificates does this in post-install). Otherwise I have no idea why i doesn't work for you...

0rAX0 commented on 2011-05-31 15:01

Also,

lastpass: /usr/lib/liblber-2.4.so.2: no version information available (required by lastpass)
lastpass: /usr/lib/libldap_r-2.4.so.2: no version information available (required by lastpass)
lastpass: /usr/lib/libcrypto.so.0.9.8: no version information available (required by lastpass)
lastpass: /usr/lib/libssl.so.0.9.8: no version information available (required by lastpass)

(lastpass:7757): Gtk-CRITICAL **: IA__gtk_widget_set_size_request: assertion `height >= -1' failed
Handling POST
* About to connect() to rodan.lastpass.com port 443 (#0)
* Trying 38.127.167.2... * connected
* Connected to rodan.lastpass.com (38.127.167.2) port 443 (#0)
* successfully set certificate verify locations:
* CAfile: none
CApath: /etc/ssl/certs
* SSL certificate problem, verify that the CA cert is OK. Details:
error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
* Closing connection #0
Linux HTTP(S) Post failed
Code: 0 Error String: Peer certificate cannot be authenticated with known CA certificates
Handling POST
* About to connect() to rodan.lastpass.com port 443 (#0)
* Trying 38.127.167.2... * connected
* Connected to rodan.lastpass.com (38.127.167.2) port 443 (#0)
* successfully set certificate verify locations:
* CAfile: none
CApath: /etc/ssl/certs
* SSL certificate problem, verify that the CA cert is OK. Details:
error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
* Closing connection #0
Linux HTTP(S) Post failed
Code: 0 Error String: Peer certificate cannot be authenticated with known CA certificates

0rAX0 commented on 2011-05-31 14:58

the new md5sum: 5c8bc5fc5b4db901241be8516aef8bff

mseiwald commented on 2011-03-30 12:19

Updated to 1.73.

@T13one
Sorry, but I cannot reproduce that here.

drelyn86 commented on 2011-03-30 11:07

This is what I keep getting when I try to login...

Handling POST
* About to connect() to rodan.lastpass.com port 443 (#0)
* Trying 71.126.154.2... * connected
* Connected to rodan.lastpass.com (71.126.154.2) port 443 (#0)
* successfully set certificate verify locations:
* CAfile: none
CApath: /etc/ssl/certs
* SSL certificate problem, verify that the CA cert is OK. Details:
error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
* Closing connection #0
Linux HTTP(S) Post failed
Code: 0 Error String: Peer certificate cannot be authenticated with known CA certificates

mseiwald commented on 2011-03-17 10:50

Corrected.

ngoonee commented on 2011-03-12 05:19

Why does ca-certificates appear twice in depends?

mseiwald commented on 2011-02-16 07:40

There has been an update.

https://lastpass.com/upgrade.php?fromwebsite=1&releasenotes=1

I also changed the dependency to openssl-compatibilty.

Thanks for reporting.

Anonymous comment on 2011-02-16 04:00

the x64 md5sum is wrong.

mr_hangman commented on 2011-01-10 16:12

Thanks for the quick reply.
I already have ca-certificates installed but the same problem still persists.

mseiwald commented on 2011-01-10 15:36

I guess it also needs the ca-certificates package then.

I'll add those to the dependecies.

mr_hangman commented on 2011-01-10 13:17

Yes, I'm running 32 bit. The package libkrb53 fixes the lib problem but now when I run it, the program cannot connect to the internet.

We could not connect to the Internet.
Please check your Internet settings and try again.
Error: frameopen(2)

Here is the output log http://pastebin.com/KfsHifJV.
Looks like it's a certificate problem but I don't know how to fix it.

mseiwald commented on 2011-01-09 17:00

I don't have this file on my system but it works for me. That's strange. I have a x86_64 system, are you running 32 bit? Does it work if you install mit-krb5 or libkrb53 from AUR?

It's a bit difficult to get the dependancies right for this one because the lastpass binary ist statically linked and so ldd doesn't tell me it's dependecies. Still it needs lots of libraries...

mr_hangman commented on 2011-01-09 11:10

Thanks for the update. But when I run it says

lastpass: error while loading shared libraries: libgssapi_krb5.so.2: cannot open shared object file: No such file or directory

Does it need other dependencies?

mseiwald commented on 2011-01-06 10:49

Updated.

Anonymous comment on 2011-01-06 07:00

Needs libidn added to dependencies.