Package Details: latex-beamer 3_36-1

Git Clone URL: https://aur.archlinux.org/latex-beamer.git (read-only)
Package Base: latex-beamer
Description: Beamer is a LaTeX class for creating slides for presentations.
Upstream URL: http://bitbucket.org/rivanvx/beamer/wiki/Home
Licenses: GPL
Submitter: wonder
Maintainer: maandree
Last Packager: maandree
Votes: 71
Popularity: 2.291751
First Submitted: 2010-11-16 18:25
Last Updated: 2015-06-11 14:40

Latest Comments

maandree commented on 2016-06-22 17:48

oslik, I cannot find any reference to "wrapfig" in the beamer source repository, and my presentations work fine without it. Why do you think it should be a dependency?

oslik commented on 2016-06-22 14:00

Please add latex-wrapfig to deps

XavierCLL commented on 2015-03-19 15:07

please update to v3.36 see https://bitbucket.org/rivanvx/beamer/downloads -> tags

lainme commented on 2012-12-12 04:52

There is still problems in beamer.cls. The compilation gives the following message

/usr/share/texmf-dist/tex/latex/beamer/base/beamer.cls:15: Paragraph ended before \beamer@parseid was complete.

It seems that "\ProvidesPackageRCS $Header$" in this file should be expanded or the following two lines be commented out

\ProvidesClassRCS $Header$
[development version \beamer@version\space A class for typesetting presentations]

maandree commented on 2012-12-08 22:18

I've included you patch now.

Anonymous comment on 2012-12-08 22:06

My patch is still relevant in 3_24.

Without it, I get:

Runaway argument?
Header$ \pgfrcs@marshal [\pgf@rcsdate \space \pgf@rcsadditional \space \ETC.
! Paragraph ended before \pgf@parseid was complete.
<to be read again>
\par
l.11

? X
No pages of output.




With it, I get slides. Please include it.

msoloi commented on 2012-12-04 01:06

Here is what happens in lainme's case: http://tex.stackexchange.com/questions/36755/beamer-error-on-basic-file-when-upgrading-now-cant-get-any-beamer-version-to-wo

ferda commented on 2012-10-15 00:12

Sorry for the delay, I wasn’t near a computer in the last week.
I updated the package, couldn’t reproduce lainme’s problem, though, so I didn’t include tam1138’s patch.

Anonymous comment on 2012-10-05 22:19

Here's a new PKGBUILD for 3_22. I added a fix for lainme's problem, too. (The short story is that "$Header$" is supposed to be replaced by mercurial, but they haven't correctly removed that for releases yet, it seems. They added a perl script to comment out the problematic lines [1], but it seems to have disappeared from the repo. And sed is a better solution anyway.)



pkgname=latex-beamer
pkgver=3_22
pkgrel=1
pkgdesc='Beamer is a LaTeX class for creating slides for presentations.'
arch=('any')
url='http://bitbucket.org/rivanvx/beamer/wiki/Home'
license=('GPL')
install='latex-beamer.install'
depends=('texlive-core')
source=("https://bitbucket.org/rivanvx/beamer/get/version-${pkgver//_/-}.tar.bz2")

package() {
cd rivanvx-beamer-*

find . -name "*.sty" \
| xargs sed -i -e '/\ProvidesPackageRCS \$Header\$/ s/^/%/'

install -d ${pkgdir}/usr/share/texmf-dist/tex/latex/beamer

cp -r * ${pkgdir}/usr/share/texmf-dist/tex/latex/beamer
}
md5sums=('838b333e11d6588c83aa83a74d55f525')

lainme commented on 2012-07-08 13:26

Since the keyword expansion problem described here: https://bitbucket.org/rivanvx/beamer/issue/10/problem-with-classrcs-and-packagercs-from

the compilation always gives message

paragraph ended before xxx was complete

All comments