Package Details: launcher-curseforge-bin 2.1.2-1

Git Clone URL: https://aur.archlinux.org/launcher-curseforge-bin.git (read-only, click to copy)
Package Base: launcher-curseforge-bin
Description: Integrates the Curseforge Modpack installation button to any MultiMC based launcher
Upstream URL: https://github.com/ShayBox/launcher-curseforge
Keywords: curseforge multimc polymc prismlauncher
Licenses: MIT
Submitter: shaybox
Maintainer: shaybox
Last Packager: shaybox
Votes: 5
Popularity: 0.006879
First Submitted: 2022-12-11 22:57 (UTC)
Last Updated: 2023-08-31 09:27 (UTC)

Latest Comments

shaybox commented on 2023-07-15 09:41 (UTC)

I forgot to update the AUR package, but this works again

shaybox commented on 2022-01-15 14:53 (UTC)

@rookiefkq didn't see that, fixed now

rookiefkq commented on 2022-01-15 10:04 (UTC)

Hi, I understand, however the package is broken for 1.3.1 anyways, the hashsum should be "acf1c53f38cda8e3357546ab4cc1fbd9cc166a2b4a917d4e5b8badd6b17810f1" instead of "718c5101a91c330e8bd3796fb5df969c01714aaf802cf72bdfe2b19b11b26e48"

HalJordan commented on 2022-01-11 10:22 (UTC)

Okay. Yeah, did my due diligence. WOW! I can't really give my opinions on them without likely being banned from here.

While the app itself has ran fine for me as far as I can tell, it was a bit of a pita every so often on updates.

For the lazier than I thought I was, MultiMC are actively anti-user, and anti-freedom, putting up roadblocks however they can to prevent any kind of distribution package requiring as much as they can that you install straight from git/their site. Time to start migrating my instances over, or a good restart. Good think I prefer early game...

HalJordan commented on 2022-01-11 10:09 (UTC)

@shaybox Why do you not support them?

shaybox commented on 2022-01-09 20:56 (UTC) (edited on 2022-08-29 22:43 (UTC) by shaybox)

This is a PSA, MultiMC-Curseforge has switched to PolyMC-Curseforge
I do not support the MultiMC developers anymore and I would suggest you look into PolyMC as well
This package will remain on version 1.3.1 indefinitely, if this package should break I will not be updating it, someone may fork MultiMC-Curseforge before the commit and continue this, but I would suggest PolyMC.

EDIT:
MultiMC-Curseforge (and PolyMC-Curseforge) do not work anymore as Curseforge has changed their API.
If you would like to fork and take over both feel free, just ask for the package(s)

gameslayer commented on 2020-10-29 05:03 (UTC)

Does this require multimc-git or just multimc5? I have multimc5 installed but I get this message

[corey@Corey-PC ~]$ multimc-twitch %u open %u: no such file or directory [corey@Corey-PC ~]$ multimc-twitch Nothing provided

shaybox commented on 2020-09-14 17:57 (UTC)

1.1.4 is a windows only change to automatically ask for administrator

shaybox commented on 2020-04-11 00:26 (UTC)

@FleurC multimc hasn't released an update with the required import flag this package needs, so until then you'll have to manually install multimc-git.

MultiMC removed the twitch options entirely, they relied on a shim server that was unstable and slow to route all the traffic through instead of directly calling the twitch api on every clients machine, which lead to millions of requests being sent through a single address (even if the shim had caching), it seems they added a new list option in the development branch that does this, despite their statement on never using the twitch api in MultiMC again, thus this project was made, I believe they re-added it despite their statement because of this project.

FleurC commented on 2020-04-09 03:09 (UTC)

Edit should be made to dependencies, change multimc to multimc-git. It is noted in the only issue on the github that the multimc-git should be installed as to make multimc-twitch work properly, and, from personal tests using both the git and multimc5, to properly add the twitch button back to multimc