Package Details: lazpaint-qt4 6.4.1-4

Git Clone URL: https://aur.archlinux.org/lazpaint-qt4.git (read-only)
Package Base: lazpaint-qt4
Description: Image editor, like PaintBrush or Paint.Net, written in Lazarus (Free Pascal).
Upstream URL: http://sourceforge.net/projects/lazpaint/
Licenses: GPL3, LGPL
Conflicts: lazpaint-gtk2
Provides: lazpaint
Submitter: dobo
Maintainer: dobo
Last Packager: dobo
Votes: 2
Popularity: 0.180108
First Submitted: 2013-08-21 10:14
Last Updated: 2016-11-29 19:22

Latest Comments

fightcookie commented on 2017-03-01 04:20

Can confirm @DragonX256, please replace in all lazpaint packages!
But if you use this
https://github.com/bgrabitmap/bgracontrols/archive/v4.3.1.2.zip
as the url instead, since that's the latest version AND change the version variable at the top from 4.3.2 to 4.3.1.2 the build still fails with:

(3104) Compiling bclabel.pas
/tmp/makepkg/lazpaint-qt4/src/bgracontrols-4.3.1.2/bclabel.pas(70,54) Hint: (5024) Parameter "Data" not used
/tmp/makepkg/lazpaint-qt4/src/bgracontrols-4.3.1.2/bclabel.pas(71,33) Hint: (5024) Parameter "Sender" not used
/tmp/makepkg/lazpaint-qt4/src/bgracontrols-4.3.1.2/bclabel.pas(71,55) Hint: (5024) Parameter "AData" not used
/tmp/makepkg/lazpaint-qt4/src/bgracontrols-4.3.1.2/bclabel.pas(74,12) Hint: (5024) Parameter "WithThemeSpace" not used
/tmp/makepkg/lazpaint-qt4/src/bgracontrols-4.3.1.2/bclabel.pas(101,32) Hint: (5024) Parameter "Reader" not used
(3104) Compiling bclistbox.pas
(3104) Compiling bgravirtualscreen.pas
/tmp/makepkg/lazpaint-qt4/src/bgracontrols-4.3.1.2/bgravirtualscreen.pas(246,47) Warning: (4045) Comparison might be always true due to range of constant and expression
/tmp/makepkg/lazpaint-qt4/src/bgracontrols-4.3.1.2/bgravirtualscreen.pas(253,47) Warning: (4045) Comparison might be always true due to range of constant and expression
/tmp/makepkg/lazpaint-qt4/src/bgracontrols-4.3.1.2/bclistbox.pas(23,24) Hint: (5024) Parameter "Sender" not used
/tmp/makepkg/lazpaint-qt4/src/bgracontrols-4.3.1.2/bclistbox.pas(149,1) Error: (9021) resource compiler "windres" not found, switching to external mode
/tmp/makepkg/lazpaint-qt4/src/bgracontrols-4.3.1.2/bclistbox.pas(149,1) Fatal: (10026) There were 1 errors compiling module, stopping
Fatal: (1018) Compilation aborted
Error: /usr/bin/ppcx64 returned an error exitcode
Error: (lazarus) Compile package bgracontrols 4.3.1.2: stopped with exit code 256
ERROR: bgracontrols 4.3.1.2 compilation failed
==> ERROR: A failure occurred in build().
Aborting...
:: failed to build lazpaint-qt4 package(s)

fightcookie commented on 2017-03-01 03:36

please change the source URL and the upstream URL to the TLS encrypted https version on the package lazpaint-qt4! Thanks :)

DragonX256 commented on 2017-01-14 10:37

Please update all lazpaint packages. makepkg can't download bgracontrols v4.3.2.zip. Latest version is 4.3.1.2

i336 commented on 2016-05-12 11:54

I'm getting:

/tmp/pacaurtmp-i336/lazpaint-qt4/src/bgrabitmap8.7/part3d.inc(496,1) Fatal: Internal error 2012090607

Not sure what to make of this - the one FPC bugtracker thread I found (http://bugs.freepascal.org/view.php?id=23916) said that it had been resolved (?).

Maybe this is relevant: http://forum.lazarus.freepascal.org/index.php?topic=30987.0

ozky commented on 2015-11-12 14:59

Need update bgrabitmap8.7.zip to pkgbuild it fails to build again.

dobo commented on 2015-05-05 20:39

Ok, I've backported changes from latest SVN. Updated version should be working now.

dobo commented on 2015-05-05 18:06

I haven't updated qt4 version because compiling with bgrbitmap 8.5.1 causes following error:
bgraqtbitmap.pas(68,23) Error: Identifier not found "TBGRAPtrBitmap"
bgraqtbitmap.pas(68,23) Error: Error in type definition
bgraqtbitmap.pas(70,25) Error: Identifier not found "TBGRAPtrBitmap"
bgraqtbitmap.pas(71,8) Error: Illegal qualifier
bgraqtbitmap.pas(72,27) Error: Incompatible type for arg no. 1: Got "<erroneous type>", expected "TBGRALCLBitmap"
bgraqtbitmap.pas(59,25) Hint: Found declaration: TBGRAQtBitmap.SlowDrawTransparent(TBGRALCLBitmap,TCanvas,TRect);
bgraqtbitmap.pas(73,8) Error: Illegal qualifier
bgraqtbitmap.pas(146,4) Warning: User defined: QT: recheck this
bgraqtbitmap.pas(170) Fatal: There were 6 errors compiling module, stopping

I've reported bug:
http://sourceforge.net/p/lazpaint/bugs/21/

dobo commented on 2015-05-05 17:57

I haven't updated qt4 version because compiling with bgrbitmap 8.5.1 causes following error:
bgraqtbitmap.pas(68,23) Error: Identifier not found "TBGRAPtrBitmap"
bgraqtbitmap.pas(68,23) Error: Error in type definition
bgraqtbitmap.pas(70,25) Error: Identifier not found "TBGRAPtrBitmap"
bgraqtbitmap.pas(71,8) Error: Illegal qualifier
bgraqtbitmap.pas(72,27) Error: Incompatible type for arg no. 1: Got "<erroneous type>", expected "TBGRALCLBitmap"
bgraqtbitmap.pas(59,25) Hint: Found declaration: TBGRAQtBitmap.SlowDrawTransparent(TBGRALCLBitmap,TCanvas,TRect);
bgraqtbitmap.pas(73,8) Error: Illegal qualifier
bgraqtbitmap.pas(146,4) Warning: User defined: QT: recheck this
bgraqtbitmap.pas(170) Fatal: There were 6 errors compiling module, stopping