Package Details: ldoce5viewer 2013.04.24-2

Git Clone URL: https://aur.archlinux.org/ldoce5viewer.git (read-only)
Package Base: ldoce5viewer
Description: Fast, free viewer for the Longman Dictionary of Contemporary English 5th Edition
Upstream URL: http://hakidame.net/ldoce5viewer/
Keywords: Dictionary
Licenses: GPL3
Conflicts: ldoce5viewer-git, ldoce5viewer-pyqt5-git
Submitter: promike
Maintainer: promike
Last Packager: promike
Votes: 1
Popularity: 0.000000
First Submitted: 2017-01-04 18:46
Last Updated: 2017-02-28 21:42

Pinned Comments

promike commented on 2018-03-19 11:00

This viewer of LDOCE5 no longer works as expected. It's been a while since the upstream has been updated. Installing this PKGBUILD is NOT recommended! Consider using another version of LDOCE5 Viewer ( https://github.com/purboo/ldoce5viewer-pyqt5 is strongly recommended ) or an entirely different dictionary (e.g.: GoldenDict)

Latest Comments

1 2 Next › Last »

promike commented on 2018-03-19 11:00

This viewer of LDOCE5 no longer works as expected. It's been a while since the upstream has been updated. Installing this PKGBUILD is NOT recommended! Consider using another version of LDOCE5 Viewer ( https://github.com/purboo/ldoce5viewer-pyqt5 is strongly recommended ) or an entirely different dictionary (e.g.: GoldenDict)

promike commented on 2017-02-28 17:50

@purboo
Good job purboo!
I'll evaluate your PKGBUILD there ;)

purboo commented on 2017-02-28 13:25

I have ported it to PyQt5 for retina (HiDPI) support:

https://aur.archlinux.org/packages/ldoce5viewer-pyqt5-git/

Hope it helps :)

mgundogdu1 commented on 2017-02-27 15:12

I have a set good dictionary files for Goldendict it greats also but I m using LDOCE5 as writing aid offline and it has more advantages over Goldendict. And Ldoce5 also so helpful English learners point of its extras.
It works my on Ubuntu 16.04.2 but I use Manjaro as my main workstation.
Thanks I m gonna try dynamos package.

promike commented on 2017-02-27 14:08

@mgundogdu1

I'm sorry...
Webkit is not maintained and therefore it has been dropped...

Have you tried dynamo's ldoce5viewer-git?
https://aur.archlinux.org/packages/ldoce5viewer-git/
I haven't tried it yet, I don't know if it's also affected. It uses another source.

LDOCE5 works great with Goldendict. It might be worth checking it out. I tried it and it worked, I just prefer LDOCE5 Viewer.
https://www.archlinux.org/packages/community/x86_64/goldendict/

mgundogdu1 commented on 2017-02-27 13:04

@promike Thank for your great interest and help. It wont work :( It seems I should wait for a while. Ubuntu also dropped qtwebkit in their repositories I assume devs going to help soon this bug :D

Best Regards....

promike commented on 2017-02-27 11:38

@mgundogdu1

I'm sorry to hear that you LDOCE5 Viewer won't work. :(
I haven't tried it on Manjaro but for me on Arch, it still works with that version ( https://ptpb.pw/lNxo ) of pyqt4-common. Try updating your system once again, however, it's possible that it won't work at all.

Here's a little update script (I tried to minimize user intervention) and hopefully typo free:

#!/bin/bash
sudo pacman -Syyuu --noconfirm && cd /tmp
#uncomment your AUR helper, I assume you have one
#cower -d ldoce5viewer ; cd ldoce5viewer; makepkg -sri ; cd ..
#pacaur -u ; pacaur -y ldoce5viewer
#yaourt -Syua --noconfirm && yaourt ldoce5viewer --noconfirm
mkdir pyqt; cd pyqt; wget -O PKGBUILD https://ptpb.pw/lNxo && makepkg -sri && ldoce5viewer

Updating LDOCE5Viewer code itself would be the real solution, but the upper script leads me to a working LDOCE5 Viewer (on 27th February - this might be important, if someone watches this in the future)

mgundogdu1 commented on 2017-02-27 10:50

@promike is right. Just one solution can be work. Downgrade pyqt-common to at least 4.12.1. But this is need to compile just pyqt-common also other packages work with that :D I make an issue in Github. I hope the developer change to dependency packages.
BTW: I compiled many packages related wit qtwebkit. But it seems no way to get work this application. I m using it know on Wine (It works great just it needs to install extra codecs to make sound work)
An another issue is Gstreamer because of they are also dropped from main repository.

promike commented on 2017-02-27 10:16

@oberon2007

Take a quick look at my last comment. Haven't you done it yet?! ;)
You MUST compile pyqt4-common (even though it's in extra repository, it won't work with that version). Qtwebkit bindings have been dropped.

So go back to my last comment: promike commented on 2017-02-23 14:59

PS: for the lazy people:
$ cd /tmp ; wget -O PKGBUILD https://ptpb.pw/lNxo ; makepkg -sri

oberon2007 commented on 2017-02-27 04:40

pyqt4-common is in extra repo. Not need to compile it yourself, @promike ! ;)