Package Details: leagueoflegends-git 0.13.r10.g2c5d6ef-1

Git Clone URL: https://aur.archlinux.org/leagueoflegends-git.git (read-only)
Package Base: leagueoflegends-git
Description: League Of Legends: Install/Run wrapper
Upstream URL: https://github.com/Nefelim4ag/League-Of-Legends
Licenses: GPL3
Conflicts: leagueoflegends
Submitter: Nefelim4ag
Maintainer: Nefelim4ag
Last Packager: Nefelim4ag
Votes: 16
Popularity: 1.654851
First Submitted: 2016-11-08 01:49
Last Updated: 2017-04-14 13:28

Latest Comments

Someoneasdf commented on 2017-08-22 18:10

The game seems to be working overall (tried a custom game) but I had some in-game bugs. Minimap icons and champion icons seemed to be missing. Does anybody have a fix/the same issue?

I changed Wine to "Windows XP" and ucommeted GC_DONT_GC=1 in /etc/leagueoflegends.conf

ScarFace commented on 2017-05-27 10:58

I got the same problem running the game after the beta update(bugsplat, and something like this in the logs
cat .local/share/leagueoflegends/LOL/Logs/LeagueClient\ Logs/2017-05-27T11-* | grep -i 'error'
000002.268| ERROR| Plugin Manager| Failed to serve /sanitizer/assets/0.filter.csv
000002.269| ERROR| Plugin Manager| Failed to serve /sanitizer/assets/0.filter.country.gb.csv
000002.270| ERROR| Plugin Manager| Failed to serve /sanitizer/assets/0.filter.language.en.csv
etc..)
to solve it I just run it via this command
$ leagueoflegends client
which runs the beta directly, hope this'll help

MrFastDie commented on 2017-05-08 15:59

Update - I made these changes and now league is running - but I got a bugsplat window every time - but its running

winetricks
- vcrun 2013
- vcrun 2015
winecfg -> libraries
- api-ms-win-crt-heap-l1-1-0
- api-ms-win-crt-locale-l1-1-0
- api-ms-win-crt-math-l1-1-0
- api-ms-win-crt-runtime-l1-1-0
- api-ms-win-crt-stdio-l1-1-0
- api-ms-win-crt-math-l1-1-0.dll
- ucrtbase
- vcruntime140
- msvcp140
change wine settings
- winxp

vim .local/share/leagueoflegends/LOL/Config/game.cfg
[General]
x3d_platform=1

MrFastDie commented on 2017-05-08 15:13

Same for me

said commented on 2017-05-07 07:53

Hi, this doesn't work anymore for me after the mandatory client update

egonaraujo commented on 2017-04-21 14:55

Hello all,

I'm having two problems right now
1) before some library check, I always removed the lib32-mesa-libgl to open the launcher, and reinstalled that to run the game (directx error if I didn't). Now, I fixed my libraries but the DirectX error keeps popping up when the game should start ( Login OK, champ select OK, opening game DirectX ERROR) any idea?
P.S. xf86-video-intel installed

2) I keep receiving certificate errors when LoL is trying to open the store, one possible fix is to disable certificate authentication on IE, is there a way to open IE in the same wine/wineprefix ?

Thank you

rebootl commented on 2017-03-08 22:19

@hdny Thanks! Though I don't have optimus changing to windows xp did the trick.
Launching normally.
(I have two systems, one w/ nvidia and the other w/ intel, it worked on both..)
Maybe it should be a default..?
Now it's stuck at applying patches, but that's another problem.

hdny commented on 2017-03-08 01:07

@reboottl,
With Optimus Card you just need to change the winecfg launch mode in 'windows xp' :
# leagueoflegends winecfg
Choose 'windows xp'
and launch the game with :
# optirun leagueoflegends
And here we go !

rebootl commented on 2017-03-07 22:00

Heyy, I only get a black launcher screen, on two systems (nvidia and intel). I have 32-bit graphics drivers installed.. any idea ?

Nefelim4ag commented on 2017-02-10 15:38

@trckry, fixed

All comments