Package Details: leagueoflegends-git 0.13.r25.g0b05e62-1

Git Clone URL: https://aur.archlinux.org/leagueoflegends-git.git (read-only)
Package Base: leagueoflegends-git
Description: League Of Legends: Install/Run wrapper
Upstream URL: https://github.com/Nefelim4ag/League-Of-Legends
Keywords: LoL
Licenses: GPL3
Conflicts: leagueoflegends
Submitter: Nefelim4ag
Maintainer: kyechou
Last Packager: kyechou
Votes: 22
Popularity: 1.247658
First Submitted: 2016-11-08 01:49
Last Updated: 2018-12-18 16:39

Latest Comments

1 2 3 4 5 Next › Last »

SpectralMemories commented on 2019-02-13 00:14

Nice work!

chilledfrogs commented on 2018-12-18 16:06

@kyechou, it seems that none are so far :) I'm asking a friend of mine to do a clean install of Arch (or an Arch-based distro) in a VM to see if I happen to have any dependencies that make it work on my system without me realizing it, I'll keep you posted

kyechou commented on 2018-12-17 15:00

Hi @chilledfrogs, both wine and wine-staging work for me too. Please let me know if any dependencies are missing.

chilledfrogs commented on 2018-12-17 09:25

Just a little update: I noticed that with the latest version of wine-staging to date as well as making sure all the packages listed on https://www.reddit.com/r/leagueoflinux/comments/a6ommg/i_tried_everything_but_still_lol_donsnt_work_help/ (except wine, which is of course conflicting with wine-staging) are installed, the game actually seems to launch fine (admittedly I only tried the tutorial, but still, seems like progress unless I'm missing something). More research should be done on this...

kyechou commented on 2018-12-03 02:18

@Nefelim4ag Right, in fact, the new changes that I submitted are also partly based on the Lutris script. I just thought that it would be nice to have it managed by pacman.

Nefelim4ag commented on 2018-11-30 22:34

@keychou, currently (IIRC), it's better for use Lutris for LoL. Sorry, but i stop play and stop supporting that actively.

kyechou commented on 2018-11-30 22:33

Hi, the client won't start if lib32-libpulse is not installed, so maybe it should be a necessary dependency.

kyechou commented on 2018-11-30 22:19

Hi, package lib32-openal is needed for installing the league client. Otherwise it would abort the installation with the error message:

There has been an error.
Error running X:\CLIENT/Prerequisites/Dx9/dxsetup.exe /silent: child killed: unknown signal

b1tl0rd commented on 2018-10-13 13:47

League of Legends no longer runs on linux as of the June 2018 patch

https://www.reddit.com/r/linux_gaming/comments/8rjode/league_of_legends_to_end_all_forms_of_linux/

Nefelim4ag commented on 2018-08-14 09:48

https://github.com/Nefelim4ag/League-Of-Legends/commit/243a74d3e9a3ba3df43a7c8231866fc0560fe862

Currently only installer works, welcome to any PR