Package Details: leagueoflegends 2:2016_05_13-1

Git Clone URL: https://aur.archlinux.org/leagueoflegends.git (read-only)
Package Base: leagueoflegends
Description: A competitive online game set in an imaginative world (Riot Games)
Upstream URL: https://leagueoflegends.com
Submitter: LeRieur
Maintainer: LeRieur
Last Packager: LeRieur
Votes: 13
Popularity: 0.022073
First Submitted: 2016-04-29 19:43
Last Updated: 2016-08-21 17:28

Latest Comments

TheUnnamedDude commented on 2016-11-26 12:41

Yes, but you might need to use a installation path based on the C: drive in wine.

I got it to work by setting the wine's reported windows version to windows 7, running a wine reboot and then launching it, I only had to install the vcrun2015 libraries.

I've created a PlayOnLinux script that uses this installation approach and have the instructions for installing the beta client in the readme https://github.com/TheUnnamedDude/pol_league_of_legends

LeRieur commented on 2016-11-25 16:29

Someone managed to make the new client work?

I've tried to install it with a fresh install and with the new version: 2016_11_10. Start the old launcher to install the new one.
Install vcrun2015 with winetricks in addition.
Run LeagueClient.exe with --no-sandbox.

But I'm blocked with this error:
"err:module:import_dll Library BugSplat.dll (which is needed by L"Z:\\home\\user\\.leagueoflegends\\LeagueClient.exe") not found"

Nefelim4ag commented on 2016-11-08 01:54

https://aur.archlinux.org/packages/leagueoflegends-git/

I've try do it another way, thanks

MrFastDie commented on 2016-10-20 13:43

Hey guys, todays patch killed my Leagueoflegends.
It forces to open on the wrong display and my mouse will not be catched by the game. Tested all modes (fullscreen, borderless, windows).

chuckdaniels commented on 2016-10-19 11:52

Just leave the comments, you can post the solution when you find it if the package is needed to be changed. I suggest you to try wine-staging if nothing works.

jeekiii commented on 2016-10-19 11:50

> Edit: I think you should create a post in the Arch Forums (AUR section), so we can discuss this without polluting the comments section.

I'll probably do that after meddling around a bit more. Should I delete my current comments in order to cleanup the thread?

I'll check the rest of your recommendations, thank you.

chuckdaniels commented on 2016-10-19 11:11

Are you having problems making the package or starting the game? Did you check if the user is in the *games* group? Did you check who owns the directory where the game is installed?

Edit: I think you should create a post in the Arch Forums (AUR section), so we can discuss this without polluting the comments section.

jeekiii commented on 2016-10-19 10:52

I'm aware, I just wanted to justify why I executed it as root: because in the worst case scenario I could re-install since my install is fresh anyway.

wine --version gives "wine-1.9.21"

Would I lose my current install if I cleaned the directory? It takes more than 3 hours to download the league update due to my shitty internet (and 2/3 of the time it just crashes, so I'd rather not have to restart)

Since it's working properly when I have privileges, i guess it's a case of the leagueoflegends install trying to access a port or something, and failing because it needs privileges, which prevents it from connecting to the server.

chuckdaniels commented on 2016-10-19 09:02

jeekii, reinstalling Arch linux is not the solution to fix a package. Which wine version are you using? Have you tried to clear wine directory?

jeekiii commented on 2016-10-19 08:36

Hi, I've a bug where I can only make the game run as root. If I don't use sudo it gives a RADS error (could not connect to http server).

I know running wine as root is heavily advised against, but I have no problem reinstalling arch linux if I run into troubles, but I'd still like to avoid having to do that.

Any idea where it can come from? Where can I get more in depht error logs? There is nothing interesting appearing when I run it from a terminal.

I'm a beginnner, so I apologize if my question is out of place or if I missed an answer somewhere despite my research.

I don't know if it's necessary with your package, but I already tried disabling tcp timestamps.

Edit I believe I've found a fix:

open your /etc/hosts and add
23.74.24.114 l3cdn.riotgames.com l3cdn.riotgames.com
somewhere.

I actually installed leagueoflegends-git and tested it from there, I experienced the same problem and this fixed it for their setup, so I guess it should work here too.

All comments