Package Details: leanify-git 0.4.3.r58.ga39681d-1

Git Clone URL: https://aur.archlinux.org/leanify-git.git (read-only, click to copy)
Package Base: leanify-git
Description: A lightweight lossless file minifier/optimizer.
Upstream URL: https://github.com/JayXon/Leanify
Licenses: MIT
Conflicts: leanify
Submitter: aksr
Maintainer: andersmmg
Last Packager: andersmmg
Votes: 2
Popularity: 0.24
First Submitted: 2016-08-11 06:21 (UTC)
Last Updated: 2022-02-14 00:32 (UTC)

Dependencies (1)

Required by (0)

Sources (1)

Latest Comments

ed_o commented on 2023-05-30 13:37 (UTC) (edited on 2023-05-30 13:38 (UTC) by ed_o)

Unfortunately the package will not build any more. This is the error message which shows up:

Cloning into 'leanify-git'...
done.
==> Starting pkgver()...
==> Updated version: leanify-git 0.4.3.r196.g7847668-1
==> Sources are ready.
==> Making package: leanify-git 0.4.3.r196.g7847668-1 (Tue 30 May 2023 14:35:33 BST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Starting pkgver()...
==> Starting build()...
g++ -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -fexceptions         -Wp,-D_FORTIFY_SOURCE=2 -Wformat -Werror=format-security         -fstack-clash-protection -fcf-protection -Wp,-D_GLIBCXX_ASSERTIONS -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -fexceptions         -Wp,-D_FORTIFY_SOURCE=2 -Wformat -Werror=format-security         -fstack-clash-protection -fcf-protection -Wall -Werror -O3 -flto -Wextra -Wno-unused-parameter -std=c++17 -fno-rtti -I./lib  -c -o leanify.o leanify.cpp
In file included from leanify.cpp:1:
leanify.h:12:23: error: ‘uint8_t’ was not declared in this scope
   12 | size_t ZlibRecompress(uint8_t* src, size_t src_len, size_t size_leanified = 0);
      |                       ^~~~~~~
leanify.h:6:1: note: ‘uint8_t’ is defined in header ‘<cstdint>’; did you forget to ‘#include <cstdint>’?
    5 | #include <string>
  +++ |+#include <cstdint>
    6 | 
leanify.h:12:32: error: ‘src’ was not declared in this scope
   12 | size_t ZlibRecompress(uint8_t* src, size_t src_len, size_t size_leanified = 0);
      |                                ^~~
leanify.h:12:44: error: expected primary-expression before ‘src_len’
   12 | size_t ZlibRecompress(uint8_t* src, size_t src_len, size_t size_leanified = 0);
      |                                            ^~~~~~~
leanify.h:12:60: error: expected primary-expression before ‘size_leanified’
   12 | size_t ZlibRecompress(uint8_t* src, size_t src_len, size_t size_leanified = 0);
      |                                                            ^~~~~~~~~~~~~~
leanify.h:12:78: error: expression list treated as compound expression in initializer [-fpermissive]
   12 | size_t ZlibRecompress(uint8_t* src, size_t src_len, size_t size_leanified = 0);
      |                                                                              ^
leanify.cpp:145:82: error: ‘size_t ZlibRecompress(uint8_t*, size_t, size_t)’ redeclared as different kind of entity
  145 | size_t ZlibRecompress(uint8_t* src, size_t src_len, size_t size_leanified /*= 0*/) {
      |                                                                                  ^
leanify.h:12:8: note: previous declaration ‘size_t ZlibRecompress’
   12 | size_t ZlibRecompress(uint8_t* src, size_t src_len, size_t size_leanified = 0);
      |        ^~~~~~~~~~~~~~
make: *** [<builtin>: leanify.o] Error 1
==> ERROR: A failure occurred in build().
    Aborting...
 -> error making: leanify-git-exit status 4
 -> Failed to install the following packages. Manual intervention is required:
leanify-git - exit status 4

churro commented on 2021-10-26 01:47 (UTC)

In order for this to build, you need to remove the "depends" line from the PKGBUILD.

serene-arc commented on 2021-06-27 04:18 (UTC)

Hi, this no longer compiles at all due to a PKGBUILD error