Package Details: leanote 2.6.2-1

Git Clone URL: https://aur.archlinux.org/leanote.git (read-only, click to copy)
Package Base: leanote
Description: Knowledge, Blog, Sharing, Cooperation.
Upstream URL: https://leanote.com/
Licenses: GPL3
Conflicts: leanote
Provides: leanote
Submitter: ykelvis
Maintainer: None
Last Packager: silver_remal
Votes: 6
Popularity: 0.009648
First Submitted: 2017-01-13 14:31
Last Updated: 2018-12-07 10:41

Required by (0)

Sources (4)

Latest Comments

1 2 Next › Last »

alexz commented on 2020-01-26 21:52

@silver_remal

No worries. By any chance, what are you using for notes ?

silver_remal commented on 2019-12-17 12:27

@alexz

Sorry for not caring about this package for a long time. I'm no longer using Leanote, and busy with other real-life packaging issues now. Would you like to maintain it?

alexz commented on 2019-12-17 04:18

@skyblue

Same thing. Either leanote upgrades electron, or leanote packages his own electron or, similar in how code uses electron6, it can use a specific version of electron.

more:

$ /opt/leanote/Leanote 

(Leanote:81332): Pango-ERROR **: 23:13:34.005: Harfbuzz version too old (1.2.1)

Trace/breakpoint trap (core dumped)

when:

$ pacman -Ss Harfbuzz
extra/harfbuzz 2.6.4-2 [installed]
    OpenType text shaping engine
extra/harfbuzz-icu 2.6.4-2 [installed]
    OpenType text shaping engine (ICU integration)

skyblue commented on 2019-10-22 01:07

The app won't run for me. I get the following error:

(Leanote:19783): Pango-ERROR **: 21:02:55.954: Harfbuzz version too old (1.2.1)

/usr/bin/leanote: line 1: 19783 Trace/breakpoint trap (core dumped) /usr/bin/env bash -c "/opt/leanote/Leanote"

The app must be packaged with its own version of harfbuzz, because I have harfbuzz 2.6.2-1 installed.

Update: I opened an issue on github, as the source directly from github also resulted in this error.

1919715071 commented on 2019-08-14 03:02

最新版系统,启动提示这个 ➜ applications leanote Failed to get crash dump id. Report Id: <html> <head> <title>your-domain.com /usr/bin/leanote:行 1: 4114 段错误 (核心已转储)/usr/bin/env bash -c "/opt/leanote/Leanote"

silver_remal commented on 2018-09-12 06:38

Updated to 2.6.1 now.

puzhou commented on 2017-12-08 10:13

please update this package!

matcherany commented on 2017-03-26 17:32

笔记不能保存的话修改下leanote文件权限
sudo chmod -R 755 /opt/leanote

levinit commented on 2017-02-13 12:02

thanks very much.
can you upgrade it?
now 2.4 is available.

yangmame commented on 2017-01-25 02:21

thanks!!