Package Details: ledger-live-git 2.83.0.r0.gde0a6f2-1

Git Clone URL: https://aur.archlinux.org/ledger-live-git.git (read-only, click to copy)
Package Base: ledger-live-git
Description: Maintain your Ledger devices (git-main)
Upstream URL: https://github.com/LedgerHQ/ledger-live
Keywords: bitcoin cryptocurrency wallet
Licenses: MIT
Conflicts: ledger-live
Provides: ledger-live
Submitter: phnx47
Maintainer: phnx47
Last Packager: phnx47
Votes: 2
Popularity: 0.000006
First Submitted: 2021-04-25 10:16 (UTC)
Last Updated: 2024-07-01 07:36 (UTC)

Dependencies (7)

Required by (2)

Sources (2)

Pinned Comments

phnx47 commented on 2024-05-30 11:51 (UTC)

To be able to build the package, you need to downgrade pnpm to v8.

Latest Comments

phnx47 commented on 2024-05-30 11:51 (UTC)

To be able to build the package, you need to downgrade pnpm to v8.

dabro commented on 2021-11-10 20:25 (UTC) (edited on 2021-11-10 20:31 (UTC) by dabro)

Why does this install ledger-live-bin? Below Output was captured whilst the command below was still running (compiling):

~ >>> pacman -Qs ledger
local/ledger-live-bin 2.33.0-1
    Ledger Hardware Wallet management software and udev rules

Anyhow, build fails. Any ideas?

~ >>> yay -Sa ledger-live
:: There are 3 providers available for ledger-live:
:: Repository AUR
    1) ledger-live 2) ledger-live-bin 3) ledger-live-git

Enter a number (default=1): 3
:: Checking for conflicts...
:: Checking for inner conflicts...
 ->
Package conflicts found:
 -> Installing ledger-live-git will remove: ledger-live-bin, ledger-live-bin (ledger-live)
 -> Conflicting packages will have to be confirmed manually
[Aur:1]  ledger-live-git-2.29.0.r1.g1446fb88e-1

  1 ledger-live-git                          (Build Files Exist)
==> Packages to cleanBuild?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> N
:: PKGBUILD up to date, Skipping (1/0): ledger-live-git
  1 ledger-live-git                          (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> N
:: (1/1) Parsing SRCINFO: ledger-live-git
==> Making package: ledger-live-git 2.29.0.r1.g1446fb88e-1 (ons 10 nov 2021 21:28:23)
==> Retrieving sources...
  -> Updating ledger-live-git git repo...
Fetching origin
  -> Found ledger-live-desktop.desktop
==> Validating source files with sha512sums...
    ledger-live-git ... Skipped
    ledger-live-desktop.desktop ... Passed
==> Making package: ledger-live-git 2.29.0.r1.g1446fb88e-1 (ons 10 nov 2021 21:28:25)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Updating ledger-live-git git repo...
Fetching origin
  -> Found ledger-live-desktop.desktop
==> Validating source files with sha512sums...
    ledger-live-git ... Skipped
    ledger-live-desktop.desktop ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Creating working copy of ledger-live-git git repo...
Cloning into 'ledger-live-git'...
done.
Switched to a new branch 'makepkg'
==> Starting prepare()...
yarn install v1.22.15
[1/5] Validating package.json...
[2/5] Resolving packages...
[3/5] Fetching packages...
info fsevents@2.3.2: The platform "linux" is incompatible with this module.
info "fsevents@2.3.2" is an optional dependency and failed compatibility check. Excluding it from installation.
info fsevents@1.2.13: The platform "linux" is incompatible with this module.
info "fsevents@1.2.13" is an optional dependency and failed compatibility check. Excluding it from installation.
[4/5] Linking dependencies...
warning " > @hot-loader/react-dom@17.0.1" has incorrect peer dependency "react@17.0.1".
warning " > @polkadot/react-identicon@0.86.1" has unmet peer dependency "@polkadot/keyring@*".
warning " > @polkadot/react-identicon@0.86.1" has unmet peer dependency "@polkadot/util@*".
warning " > @polkadot/react-identicon@0.86.1" has unmet peer dependency "@polkadot/util-crypto@*".
warning " > @polkadot/react-identicon@0.86.1" has unmet peer dependency "react-is@*".
warning "@polkadot/react-identicon > @polkadot/ui-settings@0.86.1" has unmet peer dependency "@polkadot/networks@*".
warning " > styled-components@5.3.1" has unmet peer dependency "react-is@>= 16.8.0".
warning " > react-key-handler@1.2.0-beta.3" has incorrect peer dependency "react@^16.2.0-0".
warning " > react-lottie@1.2.3" has incorrect peer dependency "react@^0.14.7 || ^15.0.0 || ^16.0.0".
warning " > react-markdown@4.3.1" has incorrect peer dependency "react@^15.0.0 || ^16.0.0".
warning "react-markdown > html-to-react@1.4.3" has incorrect peer dependency "react@^16.0".
warning " > react-motion@0.5.2" has incorrect peer dependency "react@^0.14.9 || ^15.3.0 || ^16.0.0".
warning "react-router-dom > react-router > mini-create-react-context@0.4.0" has incorrect peer dependency "react@^0.14.0 || ^15.0.0 || ^16.0.0".
warning "@storybook/addon-actions > @storybook/api > @reach/router@1.3.4" has incorrect peer dependency "react@15.x || 16.x || 16.4.0-alpha.0911da3".
warning "@storybook/addon-actions > @storybook/api > @reach/router@1.3.4" has incorrect peer dependency "react-dom@15.x || 16.x || 16.4.0-alpha.0911da3".
warning "@storybook/addon-actions > @storybook/api > @reach/router > create-react-context@0.3.0" has incorrect peer dependency "react@^0.14.0 || ^15.0.0 || ^16.0.0".
warning "@storybook/addon-essentials > @storybook/addon-measure@2.0.0" has unmet peer dependency "@storybook/components@^6.3.0".
warning "@storybook/addon-essentials > @storybook/addon-measure@2.0.0" has unmet peer dependency "@storybook/core-events@^6.3.0".
warning "@storybook/addon-essentials > @storybook/addon-measure@2.0.0" has unmet peer dependency "@storybook/theming@^6.3.0".
warning "@storybook/react > @storybook/react-docgen-typescript-plugin@1.0.2-canary.253f8c1.0" has unmet peer dependency "typescript@>= 3.x".
warning "@storybook/react > @storybook/react-docgen-typescript-plugin > react-docgen-typescript@2.0.0" has unmet peer dependency "typescript@>= 4.3.x".
warning "eslint-plugin-jest > @typescript-eslint/experimental-utils > @typescript-eslint/typescript-estree > tsutils@3.17.1" has unmet peer dependency "typescript@>=2.8.0 || >= 3.2.0-dev || >= 3.3.0-dev || >= 3.4.0-dev || >= 3.5.0-dev || >= 3.6.0-dev || >= 3.6.0-beta || >= 3.7.0-dev || >= 3.7.0-beta".
warning Workspaces can only be enabled in private projects.
warning Workspaces can only be enabled in private projects.
[5/5] Building fresh packages...
warning Ignored scripts due to flag.
Done in 11.74s.
==> Starting pkgver()...
==> Updated version: ledger-live-git 2.34.4.r2.gcb9d2ce47-1
==> Sources are ready.
==> Making package: ledger-live-git 2.34.4.r2.gcb9d2ce47-1 (ons 10 nov 2021 21:28:39)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Starting pkgver()...
==> Sources are ready.
 -> ledger-live-git-2.34.4.r2.gcb9d2ce47-1 already made -- skipping build
 -> Found git repo: github.com/LedgerHQ/ledger-live-desktop
loading packages...
resolving dependencies...
looking for conflicting packages...
:: ledger-live-git and ledger-live-bin are in conflict. Remove ledger-live-bin? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'ledger-udev' required by ledger-live-git
 -> exit status 1

karb94 commented on 2021-06-01 22:57 (UTC)

I think git (make) dependency is missing.