Package Details: legit-git 0.r324.0eb31ef-1

Git Clone URL: https://aur.archlinux.org/legit-git.git (read-only)
Package Base: legit-git
Description: Sexy Git CLI, Inspired by GitHub for Mac™.
Upstream URL: https://github.com/kennethreitz/legit
Licenses: BSD
Submitter: badboy
Maintainer: None
Last Packager: badboy
Votes: 10
Popularity: 0.000000
First Submitted: 2012-03-28 12:36
Last Updated: 2016-07-14 20:31

Required by (0)

Sources (1)

Latest Comments

badboy commented on 2017-09-17 22:48

Thanks for the notice, ngld.

However I decided to disown this package from here on.

* I don't use legit anymore
* The versions of dependencies available in the repos don't match the (exact) requirements of upstream legit, so either it needs to be patched or updated upstream

ngld commented on 2017-09-17 11:34

python2-git has been renamed to python2-pygit2. Please update the dependencies.

legit also runs on Python 3 so it would be nice if you could update the PKGBUILD to use that instead of Python 2.

txtsd commented on 2016-12-28 13:04

@badboy Oh. I thought it was python2 built from source. My bad.

badboy commented on 2016-12-27 18:34

@txtsd: Because legit uses the Python git wrapper.

txtsd commented on 2016-12-27 04:09

Why does this need python2-git?

badboy commented on 2016-07-14 20:31

@ilpianista done

ilpianista commented on 2016-07-14 20:16

There's no python2-gitpython package, please use python2-git instead!

badboy commented on 2014-07-15 07:44

@py_crash: Works for me. What command did you try to execute?

py_crash commented on 2014-07-15 02:23

@badboy... yeah.. it's broken:
Traceback (most recent call last):
File "/usr/bin/legit", line 5, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2876, in <module>
working_set = WorkingSet._build_master()
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 449, in _build_master
ws.require(__requires__)
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 745, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 639, in resolve
raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: gitpython==0.3.2.RC1

badboy commented on 2014-04-09 16:47

I updated the PKGBUILD, but I think legit is broken right now as it needs yet another module, which I could not get to build correctly. Sorry.

All comments