Package Details: lemonbar-git v1.4.r0.g2e8ac2c-1

Git Clone URL: https://aur.archlinux.org/lemonbar-git.git (read-only, click to copy)
Package Base: lemonbar-git
Description: A featherweight, lemon-scented, bar based on xcb.
Upstream URL: https://github.com/LemonBoy/bar
Licenses: MIT
Conflicts: lemonbar-sm-git, lemonbar-ucs4-git, lemonbar-xft-git
Provides: lemonbar
Submitter: haliax
Maintainer: wilssonmartee
Last Packager: wilssonmartee
Votes: 75
Popularity: 0.007309
First Submitted: 2015-04-09 15:25 (UTC)
Last Updated: 2020-12-07 03:27 (UTC)

Required by (7)

Sources (1)

Latest Comments

willemw commented on 2021-07-27 13:19 (UTC)

'lemonbar' in conflicts is missing.

macmv commented on 2019-12-09 06:11 (UTC)

Why is this marked as out of date? The wiki page still suggests we install this, even though it hasn't been updated in two years.

skypher commented on 2019-08-13 02:32 (UTC)

needs pod2man in makedeps

pzl commented on 2015-09-12 19:31 (UTC)

small problem in pkgver(), was leading to wrong version string when installing. Here's the diff to fix: https://gist.github.com/pzl/b416ac5ef6b8feb5adb3

ljrk commented on 2015-05-22 07:51 (UTC)

Why no "replaces bar-aint-recursive-git"?

Svenstaro commented on 2015-05-21 23:39 (UTC)

Merging into lemonbar-git.

Svenstaro commented on 2015-05-21 23:38 (UTC)

Merging into lemonbar-git.

krisztianfekete commented on 2015-05-06 13:20 (UTC)

I am using community/fish and my PATH is at default (too simple?): echo $PATH /usr/bin I have run into the same build error as reported in https://github.com/LemonBoy/bar/issues/89 ... ==> Updated version: bar-aint-recursive 1.1.4.ga9f285f-1 ... ==> Starting package()... pod2man --section=1 --center="lemonbar Manual" --name "lemonbar" --release="lemonbar a9f285f" README.pod > lemonbar.1 /bin/sh: pod2man: command not found Makefile:25: recipe for target 'doc' failed make: *** [doc] Error 127 ==> ERROR: A failure occurred in package(). Aborting... I was able to build the package by appending /usr/bin/core-perl to the PATH then makepkg. @ajs124: would it be possible to set the PATH in the PKGBUILD file?

klaus commented on 2015-04-22 21:24 (UTC)

provides=('bar-aint-recursive' 'lemonbar') -- is this line correct? Seems weird to list the old name as provided.

jamietanna commented on 2015-03-22 02:40 (UTC)

Project binaries have been renamed to `lemonbar`, compared to `bar` previously.

haawda commented on 2014-11-18 12:59 (UTC)

see http://hastebin.com/ojedokupuf for a pacman 4.1 compliant PKGBUILD

ledti commented on 2014-06-14 23:45 (UTC)

Updated and orphaned.

ledti commented on 2014-03-28 14:31 (UTC)

bar now uses command-line switches rather than a config.h file. see: 'man bar' The main binary is still renamed to 'bar-aint-recursive' to avoid a conflict with a community package.

bru commented on 2013-09-27 12:37 (UTC)

For those who have trouble with terminus not available, please look at this paragraph on the wiki: https://wiki.archlinux.org/index.php/Fonts#Pacman Namely you have to do that: $ xset +fp /usr/share/fonts/local $ xset fp rehash If you get an error, first navigate to that dir and do `mkfontdir`. To add this dir to your font path every time X is launched, you should put the 2 lines in your .xinitrc. Have a nice day.

Neuromatic commented on 2013-06-12 17:13 (UTC)

I have this Problem with bar and terminus-font, too. Terminus-font is installed.

commented on 2013-05-26 23:58 (UTC)

You need to install the terminus font to use the default font. Install it by typing: pacman -S terminus-font and try again.

commented on 2013-05-14 05:13 (UTC)

I'm probably wrong somewhere, this is the result I got: (1/1) installation de bar-aint-recursive [######################] 100% ┌─[manu@actualis][07:08][~] └»»bar Could not load font -*-terminus-medium-r-normal-*-12-*-*-*-c-*-*-1 ┌─[manu@actualis][07:08][~] └»»sudo bar Could not load font -*-terminus-medium-r-normal-*-12-*-*-*-c-*-*-1

commented on 2013-02-27 15:36 (UTC)

Thanks Simon -- the PKGBUILD has been updated.

simon04 commented on 2013-02-21 14:24 (UTC)

Building this package fails. As a fix, remove "clean" target from make in line 40. ==> Starting package()... rm -rf ./*.o test -d /tmp/packerbuild-1000/bar-aint-recursive/bar-aint-recursive/pkg/usr/bin || mkdir -p /tmp/packerbuild-1000/bar-aint-recursive/bar-aint-recursive/pkg/usr/bin rm -rf ./bar install -m755 bar /tmp/packerbuild-1000/bar-aint-recursive/bar-aint-recursive/pkg/usr/bin/bar install: cannot stat ‘bar’: No such file or directory make: *** [install] Error 1