Package Details: lhapdf 6.1.6-2

Git Clone URL: (read-only)
Package Base: lhapdf
Description: A particle physics tool for evaluating PDFs from discretised data files.
Upstream URL:
Licenses: GPL3
Submitter: None
Maintainer: fsiegert
Last Packager: fsiegert
Votes: 4
Popularity: 0.196750
First Submitted: 2008-04-09 09:39
Last Updated: 2017-02-24 13:01

Dependencies (4)

Required by (7)

Sources (2)

Latest Comments

JP-Ellis commented on 2017-02-27 06:33

Indeed this patch is really in two parts (which I tried to keep distinct).

I agree that building and installing with python2 after having first built with python3 is a little... inelegant to say the least. An alternative would be to have a complicated patch and copying various files over, but that seemed even worse.

From the little testing I did, it all seemed to work fine, so hopefully no serious bug is introduced.

fsiegert commented on 2017-02-23 16:48

Thanks, there are two parts to your patch as far as I can tell:

1) Building and installing with python2 after first having built with python3
It seems like a bit of a fiddly solution to me... are we sure that the second build/install doesn't overwrite anything from the first one which would be necessary for using it with python3? I'll probably give it a try...

2) You add a patch that I had submitted upstream a while ago[0]. I forgot about committing this to the Arch package, because it is not needed if /afs or /cvmfs are available (which was the case on my test machine). I will add that in a second.


JP-Ellis commented on 2017-02-13 10:00

Sorry, I removed the PKGBUILD after a couple of months as I heard nothing back.

It would be good if this could install the python libraries for both python2 and python3 when both are installed. I made a patch that adds optional support for python2.7 (without removing python3 support). This is useful for MadGraph as MadGraph does not support python3.

You can install the patch with:

wget -O - | git am

I'm not sure whether that is the best way to install it, but it seems to work fine for me.

EDIT: There was a bug in the first version of the patch. I've updated it now and it seems to be working better.

fsiegert commented on 2016-12-05 16:07

I cannot reproduce your problem, for me the package builds fine. I also can't access the updated PKGBUILD anymore. Could you check again?


JP-Ellis commented on 2016-09-30 06:38

I'm getting errors due to `urllib2` not being part of Python 3. Here's an updated PKGBUILD that ensures Python 2 is used:

aminsub commented on 2015-03-20 08:47

Hi Frank,

Thank you for your help but I found an other problem, I can't use the news version of LHAPDF. Then I will use only the last version.

Thank you!

fsiegert commented on 2015-03-20 08:34

Hi Amine,

this page here (the Arch User Repository) is a repository of user-contributed software packages.

You can find detailed information on how to make use of it in the Archlinux Wiki:

Hope that helps,

aminsub commented on 2015-03-20 08:29

Hi Frank,

It's the first time when I access to ArchLInux, Which is the correct package which I can use ?
emacs-pkgbuild-mode 0.11-2
pkgbuild-introspection 6-1


fsiegert commented on 2015-03-19 20:53

Hi Amine,

your error is indicating that you don't have boost installed (it is a build dependency for LHAPDF).

Why are you not simply using the PKGBUILD provided here to install this in your Archlinux system?


aminsub commented on 2015-03-19 17:59

Hi everyone,

I'm working now at JETPHOX model and I want to install the new version of PDF(LHAPDF-6.1.5). The last version was (5.8.8).

I use this this script for to downoald news version of PDF:

pdfsets=(CT10nlo MSTW2008nlo68cl NNPDF23_nlo_as_0119 cteq66 MMHT2014nlo68cl)

tar xzvf lhapdf-${version}.tar.gz

cd LHAPDF-${version}
./configure --prefix=${curDir}/${version} --enable-pdfsets=ct10,cteq,mstw,nnpdf --with-max-num-pdfsets=1 --enable-low-memory
make install

mkdir -p /users/../elkhalii/PDFsets
cd ..
for set in "${pdfsets[@]}"; do
./lhapdf-getdata $set.LHgrid --dest=/users/../elkhalii/PDFsets

And i get this error :

checking for Boost headers version >= 1.41.0... no
configure: error: cannot find Boost headers version >= 1.41.0

make: *** No targets specified and no makefile found. Stop.
make: *** No rule to make target `install'. Stop.

Getting sets from
Installing sets to /users/../elkhalii/PDFsets
No sets match the arguments given
Getting sets from
Installing sets to /users/elkhalii/PDFsets
No sets match the arguments given
Getting sets from
Installing sets to /users/elkhalii/PDFsets
No sets match the arguments given
Getting sets from
Installing sets to /users/elkhalii/PDFsets
No sets match the arguments given
Getting sets from
Installing sets to /users/elkhalii/PDFsets
No sets match the arguments given

Can you help me please !!!
Thank you!!


All comments