Package Details: lib32-amdgpu-pro-opencl 17.10.401251-2

Git Clone URL: https://aur.archlinux.org/amdgpu-pro-installer.git (read-only)
Package Base: amdgpu-pro-installer
Description: The AMDGPU Pro OpenCL implementation
Upstream URL: http://www.amd.com
Licenses: custom:AMD
Provides: lib32-opencl-driver
Submitter: LEW21
Maintainer: Corngood
Last Packager: Corngood
Votes: 63
Popularity: 3.594040
First Submitted: 2016-03-28 22:44
Last Updated: 2017-04-08 22:36

Pinned Comments

Corngood commented on 2016-07-02 18:27

This is a generated PKGBUILD. The full source is available at:
https://github.com/corngood/archlinux-amdgpu

Feel free to post issues and send PRs.

*** xorg-server 1.18 required
You will need to downgrade xorg-server to 1.18 for this package to install, due to a video driver ABI change in 1.19.

*** linux 4.8 or 4.9 required
This has been tested with 4.8 and 4.9 kernels. It's not likely to work on 4.10 at the moment.

*** mesa-noglvnd is required
https://aur.archlinux.org/packages/mesa-noglvnd/
The mesa package in Arch now includes the glvnd libGL, which conflicts with the AMDGPU-PRO libGL. You'll need to replace mesa with mesa-noglvnd.

Latest Comments

Rosen commented on 2017-12-17 11:30

@ozmartian are you sure?

==> Making package: amdgpu-pro-installer 17.40.483984-1 (нд дек 17 11:29:43 GMT 2017) ==> Checking runtime dependencies... ==> Checking buildtime dependencies... ==> Installing missing dependencies... [sudo] password for rosen: <br> error: target not found: lib32-libomxil-bellagio error: target not found: lib32-mesa-noglvnd-nogbm error: target not found: lib32-ncurses5-compat-libs error: target not found: mesa-noglvnd-nogbm error: target not found: ncurses5-compat-libs ==> ERROR: 'pacman' failed to install missing dependencies.

ozmartian commented on 2017-12-14 03:41

you can grab the archlinuxcn PKGBUILD from GitHub via:

https://github.com/archlinuxcn/repo/tree/master/amdgpu-pro-installer

$ makepkg -is (to build pkg and install + check dependencies)

znmeb commented on 2017-12-04 23:05

This software doesn't even work on Ubuntu 16.04.3 LTS, which AMD supposedly supports!! See http://support.amd.com/en-us/kb-articles/Pages/AMDGPU-PRO-Driver-Compatibility-Advisory-with-Ubuntu-16.04.2-and-16.04.3.aspx

I couldn't even make it work on 16.04.2. I've pretty much given up on AMD.

Svenstaro commented on 2017-12-04 23:00

@Corngood, are you still maintaining this? Otherwise, I'll orphan this package in a bit.

Rosen commented on 2017-11-23 20:34

archlinuxcn do not have such a driver!

Unboxious commented on 2017-11-15 04:23

@heavysink

It still doesn't seem to be working for me, so I ended up downloading the individual files from the github page. I'm getting errors such as, "/etc/xdg/gstomx.conf exists in both 'amdgpu-pro-gst-omx' and 'lib32-amdgpu-pro-gst-omx'". There are 4 other files which conflict on the 32-bit and 64-bit versions. Would it help if I listed those, or is that enough info?

heavysink commented on 2017-11-07 16:17

@Reize

Oh gosh I forgot to put amdgpu pro into the configuration file in ArchlinuxCN. Doing it now.

My bad.

Raize commented on 2017-11-06 20:29

The 17.40 amdgpu-pro packages in ArchlinuxCN repo no longer seem to exist?

Can someone please make a 17.40 package. I've spent a whole weekend trying but it's just beyond me.

Renfield commented on 2017-11-02 11:07

There should not be a problem installing the libraries in /opt/amdgpu-pro/lib/x86_64-linux-gnu/, because it is listed in /etc/ld.so.conf.d/amdgpu-pro.conf. Despite this, I do see a problem with qdirstat being unable to compile, not finding libGL.

I think, though, that this conversation should probably be moved to a GitHub issue against archlinuxcn, as we are not talking about this specific package.

riddicc commented on 2017-11-02 06:38

@heavysink:
all the libraries were in /opt/amdgpu-pro/lib,
but my box expected them in /usr/lib/... and usr/lib/xorg/modules/...
maybe i forgot to install something?

All comments