Package Details: lib32-ffmpeg 2:7.0-1

Git Clone URL: https://aur.archlinux.org/lib32-ffmpeg.git (read-only, click to copy)
Package Base: lib32-ffmpeg
Description: Complete solution to record, convert and stream audio and video (32 bit)
Upstream URL: http://ffmpeg.org
Licenses: GPL-3.0-only
Conflicts: lib32-libffmpeg
Provides: libavcodec.so, libavdevice.so, libavfilter.so, libavformat.so, libavutil.so, libpostproc.so, libswresample.so, libswscale.so
Replaces: lib32-libffmpeg
Submitter: lano1106
Maintainer: oxalin
Last Packager: oxalin
Votes: 37
Popularity: 0.148251
First Submitted: 2013-05-18 04:43 (UTC)
Last Updated: 2024-05-26 02:47 (UTC)

Dependencies (68)

Required by (281)

Sources (2)

Pinned Comments

oxalin commented on 2024-04-09 22:05 (UTC)

For those wondering: I intentionally keep this package as close to the native package as possible, to the extent of the available dependencies. FFMPEG package sees a lot of modifications through time and I prefer to follow the changes applied to the native PKGBUILD as much as possible. The more it goes, the more flags are added and the more often we need to cherrypick commits (until a new release comes in).

This means I'll keep the dependencies around even if there is no obvious usecase for them.

Also, since openjpeg2 is still used with the native package, I'll also keep it around. Last thing I read about the JPEG2000 internal decoder was that it was faster, but that it was still introducing errors in the rendering. This probably explains why it is still enable in the native package. I look at it once in a while and things may have evolved since, but a quick checkup didn't bring up any tangible answer.

Now, if someone would like to take the ownership of this package, I would be more than pleased to hand it over. The same goes for any related packages that I maintain mostly for FFMPEG. lib32-libffmpeg and lib32-ffmpeg could be merged back together to simplify its maintenance.

Let me know if this is something you're interested in.

oxalin commented on 2018-02-25 07:37 (UTC) (edited on 2020-05-25 15:55 (UTC) by oxalin)

About GPG, it is up to you to import the missing public key. If you receive an error about it, this is ffmpeg's project public key. Something like the following should do the trick: gpg --recv-keys B4322F04D67658D8

Latest Comments

1 2 3 4 5 6 .. 21 Next › Last »

oxalin commented on 2024-07-01 04:19 (UTC)

The x265 error is caused by a mismatch between the native package, which contains the header files, and the lib32 package which doesn't and is outdated. Once the lib32 package will be updated (or if you do it manually), things will get in line and work.

HisDudeness commented on 2024-06-25 07:28 (UTC)

@jaska Yes, also installing the package manually allows you to change the version. You must download the snapshot in the AUR page, extract the package, edit the PKGBUILD with the editor of your choice and then, in the extracted package's folder, do makepkg -s to download sources and build them and, if the process ends succesfully, do sudo pacman -U on the resulting pkg.tar.zst package. Current version seems to be 3.6-1.

Jaska commented on 2024-06-24 18:28 (UTC) (edited on 2024-06-24 22:04 (UTC) by Jaska)

@zepar How did you manually upgrade the version? The current version in the AUR is 3.5-2.

EDIT: It turns out that with aur sync you can just edit version number in PKGBUILD-file and it works

Jaska commented on 2024-06-24 01:31 (UTC)

I also get the ERROR: x265 not found using pkg-config -error

NeWolf commented on 2024-06-23 19:52 (UTC)

I get the same error when trying to build.

zepar commented on 2024-06-23 08:15 (UTC) (edited on 2024-06-24 03:46 (UTC) by zepar)

Fails to build


==> Starting build()...
ERROR: x265 not found using pkg-config

If you think configure made a mistake, make sure you are using the latest
version from Git.  If the latest version fails, report the problem to the
ffmpeg-user@ffmpeg.org mailing list or IRC #ffmpeg on irc.libera.chat.
Include the log file "ffbuild/config.log" produced by configure as this will help
solve the problem.
==> ERROR: A failure occurred in build().
    Aborting...
 -> error making: lib32-ffmpeg-exit status 4

Edit: fixed by updating lib32-x265 to version 3.6

thaewrapt commented on 2024-05-26 23:38 (UTC) (edited on 2024-05-26 23:44 (UTC) by thaewrapt)

Those -git packages also use a versioning scheme from upstream not Arch packaging (without epoch 2:), so it probably fails the check because of that.

thaewrapt commented on 2024-05-26 23:35 (UTC)

2:7.0 is a current version, 2:7.1 is in the development (that's why -git package has it). Right now 2:7.0 is in testing, hopefully it would be out of it soon.

TrueSalt commented on 2024-05-26 23:05 (UTC) (edited on 2024-05-26 23:08 (UTC) by TrueSalt)

Currently it is failing to build, saying I don't meet the current deps ffmpeg>=2:7.0, but I have ffmpeg-amd-full-git, which is version 2:7.1. I even tried with just the regular ffmpeg-git which is also 2:7.1.

The official ffmpeg package is still on 2:6.1, so the only way to meet the required deps is to use one of the git packages, but that seems to not work for whatever reason.

oxalin commented on 2024-05-26 02:35 (UTC)

The CFLAGS workaround is needed. I'll push the update soon.