Package Details: lib32-gconf 3.2.6-1

Git Clone URL: https://aur.archlinux.org/lib32-gconf.git (read-only)
Package Base: lib32-gconf
Description: A configuration database system
Upstream URL: http://www.gnome.org
Licenses: LGPL
Submitter: None
Maintainer: alucryd
Last Packager: alucryd
Votes: 255
Popularity: 16.742440
First Submitted: 2008-03-08 14:27
Last Updated: 2015-07-09 08:21

Latest Comments

Jonathas commented on 2015-07-30 19:49

polkit is not building.
Here it is lib32-gconf without the gtk, polkit and ldap dependencies: http://pastebin.com/70XqShLL

carstene1ns commented on 2014-01-02 22:27

From ftp server: "LATEST-IS-3.2.6 2013-01-22 03:48", so I removed the out-of-date flag.
If you get build errors, say so in the comments.

carstene1ns commented on 2013-12-26 11:56

From ftp server: "LATEST-IS-3.2.6 2013-01-22 03:48", so I removed the out-of-date flag.
If you get build errors, say so in the comments or contact me.

rafaelff commented on 2013-05-02 18:10

Don't think so. GNOME is not using gconf much nowadays and you can see that just a couple of packages depends on this lib32-gconf. So I don't expect a TU moving this to [multilib] that soon...

Anonymous comment on 2013-05-02 18:06

This should really go to multilib! Can someone arrange that here? :)

timosa commented on 2011-10-04 05:11

Thanks for your answer. Reinstalling lib32-gconf solved the issue.

rafaelff commented on 2011-10-02 13:44

">=" means "greater than or equal to", not "=" (equal). lib32-gconf requires >= 2.32.4... shouldn't be a problem.
The dependency problem here, as far as I can tell, is lib32-gtk3, which I'm already taking care of. I'll solve this as soon as possible.

timosa commented on 2011-10-02 11:53

Trying to update my x86_64 based system but get broken dependency error about lib32-gconf which requires gconf=2.32.4-1.

rafaelff commented on 2011-08-20 22:15

Updated to 2.32.4, now building from source code.

@torto: Thanks for your contribution, including the dependency lib32-polkit.

rafaelff commented on 2011-08-20 22:14

@torto

Maybe not the mess you think. All "-multilib" packages are both normal 64 bit and lib32 for 64 bits systems. They are just patched to work. Currently, python is not available for multilib. I tried to build lib32-python, but gave up after a few months. I'll leave it for the dev team.

torto commented on 2011-08-20 17:03

I believe it may be required for some language bindings.. I don't think it's useful for lib32
Having simultaneous 32 and 64 bit binaries of gobject-instrospection and python (required to build gobject) would be a mess!

rafaelff commented on 2011-08-20 11:20

Yes, it works for me. But what are the consequences of disabling introspection? I was never able to understand. Is it bad to disable? If not, then it is fine for me.

torto commented on 2011-08-20 10:51

Have you tried disabling introspection?
This builds fine for me..
http://pastebin.com/U4DegK25

rafaelff commented on 2011-06-16 23:21

Updated to 2.32.4

c0nd0r commented on 2011-06-16 22:00

pgkver=2.32.4
md5sums=('cf348251df5892cf2aedf2946fae6d9e')

revel commented on 2011-05-01 16:45

pkgver=2.32.3
md5sums=('e026b3440899f70fb5f981352d53a1b1')

rafaelff commented on 2011-02-11 17:04

Adopted and solved path to /usr/lib32

However, I'm having a hard time to compile this package. My guess is that I need a lib32 of gobject-introspection, if I failed to compile as well.
Any contribution is welcome.

netspider commented on 2010-12-25 17:35

Hi. This package seems to install libs to /opt/lib32/usr/lib, however it is not included in LD_LIBRARY_PATH. I think /usr/lib32 should be used instead like is done in multilib and it is the path added by lib32-glibc. Same affects your other packages. I am aware of a workaround by adding the path /opt/lib32/usr/lib to my /etc/ld.so.conf.d/lib32-glibc.conf but it does not fix the root cause.

anpieber commented on 2010-04-06 21:16

package updated to version 2.28.1; tar.gz changed to tar.xz; md5sum: 9a16ed7c7c4c81125667121b90f79e04