Package Details: lib32-glibc-linux4 2.38-1

Git Clone URL: https://aur.archlinux.org/glibc-linux4.git (read-only, click to copy)
Package Base: glibc-linux4
Description: GNU C Library (linux 4.x compat, 32-bit)
Upstream URL: https://www.gnu.org/software/libc/
Licenses: GPL, LGPL
Conflicts: lib32-glibc
Provides: lib32-glibc
Submitter: xantares
Maintainer: Heptazhou
Last Packager: Heptazhou
Votes: 8
Popularity: 0.000000
First Submitted: 2021-02-09 18:52 (UTC)
Last Updated: 2023-09-01 19:28 (UTC)

Dependencies (5)

Required by (537)

Sources (7)

Latest Comments

count0 commented on 2023-08-31 07:48 (UTC)

I flagged this out-of-date before reading the pinned comment. Sorry for that!

I'm currently needing a linux3 version of glibc, and just changing --enable-kernel=3.10.0 had been working so far. Would a glibc-linux3 package make sense at all?

Heptazhou commented on 2023-08-22 02:03 (UTC) (edited on 2023-08-22 02:05 (UTC) by Heptazhou)

The normal glibc v2.38 works perfectly fine with WSL 1, which is on Linux v4.4.0. There is no need to update & use glibc-linux4 at the moment AFAIK.

If you do need glibc-linux4 v2.38 as normal glibc will not work for you, please be sure to provide the details when you flag this package.

Riyyi commented on 2023-07-29 18:11 (UTC)

sha256sum for locale.gen.txt is now: 2a7dd6c906b6c54a68f48a21898664a32fdb136cbd9ff7bfd48f01d1aaa649ae

wangqr commented on 2022-08-12 13:53 (UTC)

For those who use this in container on old hosts, line 52 in PKGBUILD (glibc-linux4.patch) needs to be uncommented, and clone3 syscalls needs to be removed as well

felixonmars commented on 2021-03-09 18:26 (UTC)

Unfortunately I still need this for systemd-nspawn on old hosts.

jonathon commented on 2021-03-09 02:16 (UTC)

Good news, with containerd.io=1.4.4 they seem to have resolved the glibc=2.33 issue. \o/

xantares commented on 2021-02-10 09:24 (UTC)

done

jonathon commented on 2021-02-10 01:43 (UTC) (edited on 2021-02-11 12:45 (UTC) by jonathon)

Confirming, provides=("glibc=$pkgver") helps.

felixonmars commented on 2021-02-09 22:15 (UTC) (edited on 2021-02-09 22:16 (UTC) by felixonmars)

Perhaps provides array should include version as well:

:: glibc-linux4 and glibc are in conflict. Remove glibc? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing glibc breaks dependency 'glibc>=2.27' required by gcc-libs