Package Details: lib32-glxosd-git r32.9f216b2-1

Git Clone URL: https://aur.archlinux.org/lib32-glxosd-git.git (read-only)
Package Base: lib32-glxosd-git
Description: An OSD for OpenGL applications running under the X Window System. This allows you to monitor your framerate and hardware temperature in games on Linux! 32bit version.
Upstream URL: https://github.com/nickguletskii/GLXOSD
Licenses: GPL
Conflicts: lib32-glxosd
Provides: lib32-glxosd
Submitter: lubosz
Maintainer: lubosz
Last Packager: lubosz
Votes: 2
Popularity: 0.000000
First Submitted: 2015-03-18 00:36
Last Updated: 2015-06-22 20:58

Latest Comments

fsck_bieber commented on 2017-09-10 07:10

Thank you.
the pkgbuild works, but your gitlab link is not anymore.

Phitherek commented on 2017-01-28 22:58

Working PKGBUILD: https://gist.github.com/Phitherek/cb5d7ab05520914e4e37d0ca7ac840ba

It is based on my own fixes to upstream. It does not conflict with the original package. You can invoke the binary using glxosd32 instead of glxosd.

You can also download working version of the package for the latest version in the time of writing this comment here: https://gitlab.com/Phitherek_/arch-packages/tree/master

FallenSnow commented on 2016-04-21 01:46

Doesn't build :(

First I get
```
/tmp/yaourt-tmp-ayrton/aur-lib32-glxosd-git/./PKGBUILD: line 23: cd: /tmp/yaourt-tmp-ayrton/aur-lib32-glxosd-git/src/glxosd: No such file or directory
==> ERROR: pkgver is not allowed to be empty.
==> ERROR: pkgver() generated an invalid version:
==> ERROR: Makepkg was unable to build lib32-glxosd-git.
```

Once hard coding the location I get
```
CMake Error at src/cmake_install.cmake:40 (file):
file INSTALL cannot find
"/tmp/yaourt-tmp-ayrton/aur-lib32-glxosd-git/src/GLXOSD/src/freetype-gl-glxosd/freetype-gl/shaders".
Call Stack (most recent call first):
cmake_install.cmake:53 (include)

Makefile:61: recipe for target 'install' failed
make: *** [install] Error 1
==> ERROR: A failure occurred in package().
```