Package Details: lib32-gnome-vfs 2.24.4-11

Git Clone URL: https://aur.archlinux.org/lib32-gnome-vfs.git (read-only, click to copy)
Package Base: lib32-gnome-vfs
Description: The GNOME Virtual File System (32 bit)
Upstream URL: http://www.gnome.org
Licenses: LGPL
Submitter: None
Maintainer: mordervomubel
Last Packager: mordervomubel
Votes: 19
Popularity: 0.000000
First Submitted: 2008-09-02 16:43
Last Updated: 2015-06-26 19:29

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

seanl commented on 2013-05-03 04:01

Hmm, not building at the moment. I get the following error when trying to build with yaourt: https://gist.github.com/seanlynch/5507130

rafaelff commented on 2013-02-06 04:26

Automake 1.13 incompatibility fixed in 2.24.4-7.

Thanks for your contributions, guys!

Anonymous comment on 2013-02-05 13:37

I think it's also needed to add 'autoreconf -i' in the PKGBUILD before automake. With that it will generate the test-driver file which is missing.

Anonymous comment on 2013-01-31 09:20

'AM_CONFIG_HEADER' in ./configure.in needs to be changed to 'AC_CONFIG_HEADERS'. '${srcdir}/auto-test' in ./test/Makefile.am needs to be changed to 'auto-test'

rafaelff commented on 2013-01-25 06:24

gnome-vfs requires a patch for automake 1.13. I've been trying to patch it, but no good news so far. Any contribution on this topic is welcome.

Anonymous comment on 2013-01-24 22:36

of course it makes total sense for a x.Y.z update to make backwards incompatible changes... talk about semantic versioning!

Anonymous comment on 2013-01-24 22:34

yes, this one's kaputt. something to do with automake it seems, cf.
https://github.com/chenxiaolong/Unity-for-Arch/issues/76

wtribe commented on 2013-01-10 20:22

I got the following error when trying to install with yaourt.

$ yaourt -S lib32-gnome-vfs

==> Downloading lib32-gnome-vfs PKGBUILD from AUR...
x gcrypt-config.patch
x gnutls-config.patch
x PKGBUILD
Comment by c.stadegaart (2011-12-04 18:38)
I get a make error:

<snip>
</snip>
libgcrypt, installation went OK.

lib32-gnome-vfs 2.24.4-6 (Tue Sep 2 09:43:38 PDT 2008)
( Unsupported package: Potentially dangerous ! )
==> Edit PKGBUILD ? [Y/n] ("A" to abort)
==> ------------------------------------
==> n

==> lib32-gnome-vfs dependencies:
- lib32-bzip2 (already installed)
- lib32-avahi (already installed)
- lib32-smbclient (already installed)
- lib32-gconf (already installed)
- lib32-krb5 (already installed)
- lib32-gnutls (already installed)
- lib32-libgcrypt (already installed)
- gnome-vfs (already installed)
- intltool (already installed)
- gtk-doc (already installed)
- gnome-common (already installed)
- lib32-dbus-glib (already installed)
- gnome-mime-data (already installed)
- lib32-keyutils (already installed)


==> Continue building lib32-gnome-vfs ? [Y/n]
==> -----------------------------------------
==>
==> Building and installing package
==> Making package: lib32-gnome-vfs 2.24.4-6 (Thu Jan 10 12:19:35 PST 2013)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving Sources...
-> Downloading gnome-vfs-2.24.4.tar.bz2...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 384 100 384 0 0 495 0 --:--:-- --:--:-- --:--:-- 1864
100 1846k 100 1846k 0 0 458k 0 0:00:04 0:00:04 --:--:-- 653k
-> Found gnutls-config.patch
-> Found gcrypt-config.patch
==> Validating source files with sha256sums...
gnome-vfs-2.24.4.tar.bz2 ... Passed
gnutls-config.patch ... Passed
gcrypt-config.patch ... Passed
==> Extracting Sources...
-> Extracting gnome-vfs-2.24.4.tar.bz2 with bsdtar
==> Starting build()...
patching file configure.in
Hunk #1 succeeded at 668 (offset -18 lines).
patching file configure.in
libtoolize: putting auxiliary files in `.'.
libtoolize: linking file `./ltmain.sh'
libtoolize: You should add the contents of the following files to `aclocal.m4':
libtoolize: `/usr/share/aclocal/libtool.m4'
libtoolize: `/usr/share/aclocal/ltoptions.m4'
libtoolize: `/usr/share/aclocal/ltversion.m4'
libtoolize: `/usr/share/aclocal/lt~obsolete.m4'
libtoolize: Consider adding `AC_CONFIG_MACRO_DIR([m4])' to configure.in and
libtoolize: rerunning libtoolize, to keep the correct libtool macros in-tree.
libtoolize: Consider adding `-I m4' to ACLOCAL_AMFLAGS in Makefile.am.
aclocal: warning: autoconf input should be named 'configure.ac', not 'configure.in'
configure.in:36: error: 'AM_CONFIG_HEADER': this macro is obsolete.
You should use the 'AC_CONFIG_HEADERS' macro instead.
/usr/share/aclocal-1.13/obsolete-err.m4:12: AM_CONFIG_HEADER is expanded from...
configure.in:36: the top level
autom4te: /usr/bin/m4 failed with exit status: 1
aclocal: error: echo failed with exit status: 1
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build lib32-gnome-vfs.
==> Restart building lib32-gnome-vfs ? [y/N]
==> ----------------------------------------
==>
$

Thanks for your efforts on this.

Anonymous comment on 2011-12-06 22:46

@jesephgbr: After manually installing lib32-smbclient, lib32-gconf and lib32-libgcrypt, installation went OK.

rafaelff commented on 2011-12-05 17:45

@cstadegaart: you've got some missing dependencies, but the rest is up-to-date. Can you try installing missing deps and then installing this package again?