Package Details: lib32-gnome-vfs 2.24.4-11

Git Clone URL: https://aur.archlinux.org/lib32-gnome-vfs.git (read-only, click to copy)
Package Base: lib32-gnome-vfs
Description: The GNOME Virtual File System (32 bit)
Upstream URL: http://www.gnome.org
Licenses: LGPL
Submitter: None
Maintainer: mordervomubel
Last Packager: mordervomubel
Votes: 19
Popularity: 0.000000
First Submitted: 2008-09-02 16:43
Last Updated: 2015-06-26 19:29

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

Anonymous comment on 2011-12-05 17:25

Please note that smbclient, gconf and libgcrypt install when invoking yaourt -S lib32-gnome-vfs

Output:
lib32-bzip2 1.0.6-1
lib32-avahi 0.6.30-6
error: package "lib32-smbclient" not found
error: package "lib32-gconf" not found
lib32-krb5 1.9.1-1
lib32-gnutls 3.0.8-1
error: package "lib32-libgcrypt" not found
gnome-vfs 2.24.4-6
intltool 0.41.1-2
gtk-doc 1.18-1
gnome-common 2.34.0-1
lib32-dbus-glib 0.98-1
gnome-mime-data 2.18.0-5
lib32-keyutils 1.5.2-1

rafaelff commented on 2011-12-05 03:13

@cstadegaart: The compilation works for me. Can you run the following command and post the output here?

pacman -Q lib32-bzip2 lib32-avahi lib32-smbclient lib32-gconf lib32-krb5 lib32-gnutls lib32-libgcrypt gnome-vfs intltool gtk-doc gnome-common lib32-dbus-glib gnome-mime-data lib32-keyutils

Anonymous comment on 2011-12-04 18:38

I get a make error:

/bin/sh ../libtool --tag=CC --mode=link gcc -m32 -std=gnu99 -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 -Wl,-O1,--sort-common,--as-needed,-z,relro,--hash-style=gnu -o gnome-vfs-daemon dbus-utils.o vfs-daemon.o daemon-connection.o -pthread -lgmodule-2.0 -lgconf-2 -lxml2 -ldbus-glib-1 -ldbus-1 -lpthread -lgobject-2.0 -lgthread-2.0 -lrt -lglib-2.0 -lgnutls -lavahi-glib -lglib-2.0 -lavahi-common -lavahi-client -lresolv -pthread -lhal-storage -lhal -ldbus-glib-1 -ldbus-1 -lpthread -lgobject-2.0 -lgthread-2.0 -lrt -lglib-2.0 ../libgnomevfs/libgnomevfsdaemon-2.la ../libgnomevfs/libgnomevfs-2.la -lutil
libtool: link: gcc -m32 -std=gnu99 -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2 -Wl,-O1 -Wl,--sort-common -Wl,--as-needed -Wl,-z -Wl,relro -Wl,--hash-style=gnu -o .libs/gnome-vfs-daemon dbus-utils.o vfs-daemon.o daemon-connection.o -pthread -pthread ../libgnomevfs/.libs/libgnomevfsdaemon-2.a -lhal-storage -lhal /tmp/yaourt-tmp-christian/aur-lib32-gnome-vfs/src/gnome-vfs-2.24.4/libgnomevfs/.libs/libgnomevfs-2.so ../libgnomevfs/.libs/libgnomevfs-2.so -lgmodule-2.0 -lgconf-2 -lxml2 -ldbus-glib-1 -ldbus-1 -lpthread -lgobject-2.0 -lgthread-2.0 -lrt -lgnutls -lavahi-glib -lglib-2.0 -lavahi-common -lavahi-client -lresolv -lutil -pthread
/tmp/yaourt-tmp-christian/aur-lib32-gnome-vfs/src/gnome-vfs-2.24.4/libgnomevfs/.libs/libgnomevfs-2.so: undefined reference to `gcry_control'
collect2: ld returned 1 exit status

rafaelff commented on 2011-06-18 15:32

Dependencies fixed.

Anonymous comment on 2011-06-18 13:15

Hello, lib32-heimdal and lib32-libkrb53 got both replaced by lib32-krb5. Please switch.

rafaelff commented on 2011-05-18 15:10

lib32-keyutils fixed in 1.4-2 - There should be no problem anymore.

rafaelff commented on 2011-05-18 01:56

The reason for that is that lib32-keyutils package is installing libs in /opt/lib32/usr/lib, while the current standard for lib32 packages is /usr/lib32.
You can: edit the PKGBUILD using mine at http://pastebin.com/njJn1eZG or can wait until the maintainer solve this issue. In the meanwhile, I'll keep bugging him :)

timosa commented on 2011-05-17 06:22

Compiling fails with an error message:

/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-unknown-linux-gnu/4.6.0/../../../libkeyutils.so when searching for -lkeyutils
/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-unknown-linux-gnu/4.6.0/../../../libkeyutils.a when searching for -lkeyutils
/usr/bin/ld: skipping incompatible /usr/lib/libkeyutils.so when searching for -lkeyutils
/usr/bin/ld: skipping incompatible /usr/lib/libkeyutils.a when searching for -lkeyutils
/usr/bin/ld: cannot find -lkeyutils
collect2: ld returned 1 exit status

rafaelff commented on 2011-05-16 04:08

Building from source now.

rafaelff commented on 2011-02-20 04:04

Adopted and fix libs to /usr/lib32. However, I'm having time to compile from source.