Package Details: lib32-gst-plugins-bad 1.18.3-1

Git Clone URL: https://aur.archlinux.org/lib32-gst-plugins-bad.git (read-only, click to copy)
Package Base: lib32-gst-plugins-bad
Description: Multimedia graph framework - bad plugins (32-bit)
Upstream URL: https://gstreamer.freedesktop.org/
Licenses: LGPL
Submitter: orumin
Maintainer: rodrigo21
Last Packager: rodrigo21
Votes: 14
Popularity: 0.90
First Submitted: 2016-06-11 18:11
Last Updated: 2021-01-30 05:04

Dependencies (79)

Required by (0)

Sources (1)

Latest Comments

1 2 3 4 5 6 ... Next › Last »

rodrigo21 commented on 2020-11-26 07:20

I'm waiting for the repo packages to be updated. It's flagged out of date since September.

@DDoSolitary

When I update the package to 1.18 I will check again the dependencies. Thanks for the reports.

DDoSolitary commented on 2020-11-26 06:24

@Lakso This package is built against headers from the gstreamer package, which has been updated to v1.18, but the lib32-gstreamer and lib32-gst-plugins-* packages are still on v1.16. So the plugins built for newer gstreamer can't be loaded by the old lib32-gstreamer. You need to install an older version of gstreamer to build this package, for example https://archive.archlinux.org/packages/g/gstreamer/gstreamer-1.16.2-2-x86_64.pkg.tar.zst

DDoSolitary commented on 2020-11-26 06:09

May I know why you disabled the dtls plugin? I can build it without issues.

DDoSolitary commented on 2020-11-26 05:26

According to the official gst-plugins-bad package, lib32-libmpeg2 is not needed and lib32-bluez-libs should be in makedepends. I've checked the built package and didn't find any dependency on their so library files.

Lakso commented on 2020-09-29 15:27

  ==> ERROR: A failure occurred in check().
    Aborting...
error making: lib32-gst-plugins-bad  

here's the logfile if it's useful

Alkaris commented on 2020-08-16 15:25

How do you fix dependency for Neon?

Dependency neon found: NO found 0.31.2 but need: '<= 0.30.99' ; matched: '>= 0.27'

ERROR: Invalid version of dependency, need 'neon' ['<= 0.30.99'] found '0.31.2'

Why does this package require an older version when a newer version exists? is there way to tell it to use the new one instead of the old one? What needs to be edited in the PKGBUILD to do that?

hdnvjwhewqmcieuc commented on 2020-06-01 11:06

How am I supposed to deal with the tests libs_insertbin and elements_line21 failing? Is this happening because lib32-libkate has problems (server hosting it has been down for a month) and I tried the solutions in the comments?

JavanAsher commented on 2020-05-26 23:25

@rodrigo21 lib32-openexr rebuilt just fine. lib32-gst-plugins-bad shows the exact same error.

rodrigo21 commented on 2020-05-26 23:06

@JavanAsher, It seems to be a problem with lib32-openexr.

Try rebuilding lib32-openexr first and sees if it compiles.

JavanAsher commented on 2020-05-26 21:24

Package failed to build, if possible, would like some help. https://pastebin.com/Bautp2Gk