Package Details: lib32-gst-plugins-bad 1.12.1-4

Git Clone URL: (read-only)
Package Base: lib32-gst-plugins-bad
Description: GStreamer Multimedia Framework Bad Plugins (32-bit)
Upstream URL:
Licenses: LGPL
Submitter: orumin
Maintainer: orumin
Last Packager: orumin
Votes: 7
Popularity: 0.437403
First Submitted: 2016-06-11 18:11
Last Updated: 2017-09-29 17:02

Latest Comments

DarkShadow44 commented on 2018-01-22 23:09

Also has issues with new libsrtp. Downgraded to libsrtp 1:1.5.4-2 and openjpeg 2.2.0-1 and it built fine.

DarkShadow44 commented on 2018-01-22 22:58

Doesn't build anymore, see

zaplo commented on 2017-12-13 19:46

  • imagemagick, lib32-imagemagick (6.9.9-26 doesn't 404)
  • llde's openjpeg workaround for 2.3
  • lib32-opencv (compile --without-qt4)

at least these were needed, not sure if this package is outdated or build files themselves.

yannleretaille commented on 2017-11-17 12:39

needs new openjpeg fix as lib32-openjpeg is now on 2.3. Could also be bumped to 1.12.3, but there only have been doc updates it seems:

0e4ef622 commented on 2017-11-17 03:32

Actually, the package compiled without lib32-opencv for me.

0e4ef622 commented on 2017-11-17 00:44

Also, lib32-opencv fails to build since it apparently needs a 32 bit version of tesseract and leptonica. You can get lib32-smbclient to build if you go through all of its outdated dependencies and update the version numbers.

KozRoss commented on 2017-10-27 22:42

This currently won't build due to lib32-smbclient not building.

DarkShadow44 commented on 2017-10-11 17:16

Now that openjpeg 2.3 is in the repos, could you update the workaround?

DarkShadow44 commented on 2017-10-01 15:03

I get "ModuleNotFoundError: No module named 'codegen'"

llde commented on 2017-08-26 12:25

Also this requires to have openpeg 2.1 or 2.0 installed. If you have openjpeg 2.2 you have to apply this patch:

diff -ur gst-plugins-bad/ext/openjpeg/gstopenjpeg.h gst-plugins-bad-new/ext/openjpeg/gstopenjpeg.h
--- gst-plugins-bad/ext/openjpeg/gstopenjpeg.h 2017-08-24 00:43:21.020318808 +0200
+++ gst-plugins-bad-new/ext/openjpeg/gstopenjpeg.h 2017-08-24 16:04:26.893479824 +0200
@@ -39,7 +39,7 @@
#include <stdio.h>
# ifdef HAVE_OPENJPEG_2_1
-# include <openjpeg-2.1/openjpeg.h>
+# include <openjpeg-2.2/openjpeg.h>
# else
# include <openjpeg-2.0/openjpeg.h>
# endif

All comments