Package Details: lib32-gst-rtsp-server-git 1.24.0+r705+g81de6b7738-1

Git Clone URL: https://aur.archlinux.org/lib32-gstreamer-git.git (read-only, click to copy)
Package Base: lib32-gstreamer-git
Description: Multimedia graph framework (32-bit) - rtsp server
Upstream URL: https://gstreamer.freedesktop.org/
Licenses: LGPL
Conflicts: lib32-gst-rtsp-server
Provides: lib32-gst-rtsp-server
Submitter: SKV
Maintainer: SKV
Last Packager: SKV
Votes: 1
Popularity: 0.002140
First Submitted: 2022-05-22 04:56 (UTC)
Last Updated: 2024-06-08 10:11 (UTC)

Latest Comments

1 2 3 4 5 6 Next › Last »

FabioLolix commented on 2024-05-22 08:14 (UTC)

Install the base-devel package which is a prerequisite for using AUR

TrueSalt commented on 2024-05-22 07:41 (UTC) (edited on 2024-05-22 07:42 (UTC) by TrueSalt)

currently getting this error when trying to build it.

==> ERROR: Cannot find the debugedit binary required for including source files in debug packages.

SKV commented on 2024-03-19 17:05 (UTC)

@bluegreensea, Thanks, if you want to keep webrtc, you can try install lib32-libnice first, then rebuild this package. But to simplify this package, I'll take your advice and disable webrtc feature until another want it enable.

For lib32-gst-vaapi requires lib32-libva>=2.21, I will update later. Some users will have difficulty building lib32-libva>=2.21 because it's not available in aur.

bluegreensea commented on 2024-03-19 09:41 (UTC) (edited on 2024-03-27 20:47 (UTC) by bluegreensea)

I can build after changing these without lib32-libnice (lib32-libva on multilib repo is not updated yet, so need to build it by own)

--- a/PKGBUILD   2024-03-19 17:20:56.578958443 +0800
+++ b/PKGBUILD  2024-03-19 17:20:51.430997872 +0800
@@ -48,7 +48,7 @@
   lib32-libfdk-aac lib32-fluidsynth lib32-libgme lib32-liblrdf lib32-ladspa lib32-libde265 lib32-lilv lib32-lv2
   lib32-libmpcdec lib32-neon lib32-openal lib32-libdvdnav lib32-rtmpdump lib32-sbc lib32-soundtouch
   lib32-libsrtp lib32-zvbi lib32-wildmidi
-  lib32-nettle lib32-libxml2 lib32-json-glib lib32-libva lib32-libxkbcommon-x11
+  lib32-nettle lib32-libxml2 lib32-json-glib "lib32-libva>=2.21.0" lib32-libxkbcommon-x11

   # gst-plugins-ugly
   lib32-a52dec lib32-opencore-amr lib32-libcdio lib32-libdvdread lib32-libmpeg2 lib32-x264
@@ -84,6 +84,7 @@
     -D gpl=enabled
     -D gst-examples=disabled
     -D libnice=disabled
+    -D webrtc=disabled
     -D orc=enabled # fix
     -D orc-source="system" # fix
     -D vaapi=enabled
@@ -578,7 +578,7 @@

 package_lib32-gst-plugin-va-git() {
   pkgdesc+=" - va plugin"
-  depends=("lib32-gst-plugins-bad-libs-git=$pkgver" lib32-libva)
+  depends=("lib32-gst-plugins-bad-libs-git=$pkgver" "lib32-libva>=2.21.0")
   provides=("lib32-gst-plugin-va=$pkgver")
   conflicts=("lib32-gst-plugin-va")

@@ -642,7 +642,7 @@

 package_lib32-gstreamer-vaapi-git() {
   pkgdesc+=" - vaapi plugin"
-  depends=("lib32-gst-plugins-bad-libs-git=$pkgver" lib32-libva lib32-libxrandr)
+  depends=("lib32-gst-plugins-bad-libs-git=$pkgver" "lib32-libva>=2.21.0" lib32-libxrandr)
   provides=("lib32-gstreamer-vaapi=$pkgver")
   conflicts=("lib32-gstreamer-vaapi")
 

btd1337 commented on 2024-03-19 04:11 (UTC) (edited on 2024-03-19 04:15 (UTC) by btd1337)

FAILED: subprojects/gst-plugins-bad/gst-libs/gst/va/libgstva-1.0.so.0.2500.0
gcc -m32  -o subprojects/gst-plugins-bad/gst-libs/gst/va/libgstva-1.0.so.0.2500.0 subprojects/gst-plugins-bad/gst-libs/gst/va/libgstva-1.0.so.0.2500.0.p/meson-generated_.._va-enumtypes.c.o subprojects/gst-plugins-bad/gst-libs/gst/va/libgstva-1.0.so.0.2500.0.p/gstvaallocator.c.o subprojects/gst-plugins-bad/gst-libs/gst/va/libgstva-1.0.so.0.2500.0.p/gstvadisplay.c.o subprojects/gst-plugins-bad/gst-libs/gst/va/libgstva-1.0.so.0.2500.0.p/gstvadisplay_wrapped.c.o subprojects/gst-plugins-bad/gst-libs/gst/va/libgstva-1.0.so.0.2500.0.p/gstvapool.c.o subprojects/gst-plugins-bad/gst-libs/gst/va/libgstva-1.0.so.0.2500.0.p/gstvautils.c.o subprojects/gst-plugins-bad/gst-libs/gst/va/libgstva-1.0.so.0.2500.0.p/gstvadisplay_drm.c.o subprojects/gst-plugins-bad/gst-libs/gst/va/libgstva-1.0.so.0.2500.0.p/gstvasurfacecopy.c.o subprojects/gst-plugins-bad/gst-libs/gst/va/libgstva-1.0.so.0.2500.0.p/gstvavideoformat.c.o subprojects/gst-plugins-bad/gst-libs/gst/va/libgstva-1.0.so.0.2500.0.p/vasurfaceimage.c.o -Wl,--as-needed -Wl,--no-undefined -shared -fPIC -Wl,-soname,libgstva-1.0.so.0 -Wl,-Bsymbolic-functions -Wl,-z,nodelete -Wl,-O1 -Wl,--sort-common -Wl,--as-needed -Wl,-z,relro -Wl,-z,now -Wl,-z,pack-relative-relocs -flto=auto -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -fexceptions -Wp,-D_FORTIFY_SOURCE=3 -Wformat -Werror=format-security -fstack-clash-protection -fcf-protection -fno-omit-frame-pointer -mno-omit-leaf-frame-pointer -g -ffile-prefix-map=/home/helder/.cache/paru/clone/lib32-gstreamer-git/src=/usr/src/debug/lib32-gstreamer-git -flto=auto '-Wl,-rpath,$ORIGIN/../../../../gstreamer/gst:$ORIGIN/../../../../gstreamer/libs/gst/base:$ORIGIN/../../../../gst-plugins-base/gst-libs/gst/video:$ORIGIN/../../../../gst-plugins-base/gst-libs/gst/allocators' -Wl,-rpath-link,/home/helder/.cache/paru/clone/lib32-gstreamer-git/src/build/subprojects/gstreamer/gst -Wl,-rpath-link,/home/helder/.cache/paru/clone/lib32-gstreamer-git/src/build/subprojects/gstreamer/libs/gst/base -Wl,-rpath-link,/home/helder/.cache/paru/clone/lib32-gstreamer-git/src/build/subprojects/gst-plugins-base/gst-libs/gst/video -Wl,-rpath-link,/home/helder/.cache/paru/clone/lib32-gstreamer-git/src/build/subprojects/gst-plugins-base/gst-libs/gst/allocators -Wl,--start-group subprojects/gstreamer/gst/libgstreamer-1.0.so.0.2500.0subprojects/gstreamer/libs/gst/base/libgstbase-1.0.so.0.2500.0 subprojects/gst-plugins-base/gst-libs/gst/video/libgstvideo-1.0.so.0.2500.0 subprojects/gst-plugins-base/gst-libs/gst/allocators/libgstallocators-1.0.so.0.2500.0 /usr/lib32/libglib-2.0.so /usr/lib32/libgobject-2.0.so /usr/lib32/libgmodule-2.0.so -pthread -lm /usr/lib32/liborc-0.4.so /usr/lib32/libva.so /usr/lib32/libva-drm.so /usr/lib32/libdrm.so -Wl,--end-group
/usr/bin/ld: /tmp/ccYZvNqE.ltrans0.ltrans.o: na função "va_map_buffer":
/usr/src/debug/lib32-gstreamer-git/build/../gstreamer/subprojects/gst-plugins-bad/gst-libs/gst/va/vasurfaceimage.c:304:(.text+0x8b74): undefined reference to `vaMapBuffer2'
collect2: error: ld returned 1 exit status
[2446/3927] Linking target subprojects/gst-plugins-bad/gst-libs/gst/codecs/libgstcodecs-1.0.so.0.2500.0
ninja: build stopped: subcommand failed.
Executing subproject gst-plugins-bad

gst-plugins-bad| Project name: gst-plugins-bad
gst-plugins-bad| Project version: 1.25.0.1
gst-plugins-bad| C compiler for the host machine: gcc -m32 (gcc 13.2.1 "gcc (GCC) 13.2.1 20230801")
gst-plugins-bad| C linker for the host machine: gcc -m32 ld.bfd 2.42.0
gst-plugins-bad| C++ compiler for the host machine: g++ -m32 (gcc 13.2.1 "g++ (GCC) 13.2.1 20230801")
gst-plugins-bad| C++ linker for the host machine: g++ -m32 ld.bfd 2.42.0
gst-plugins-bad| Compiler for C++ supports arguments -Wno-non-virtual-dtor: YES
gst-plugins-bad| Compiler for C supports link arguments -Wl,-Bsymbolic-functions: YES (cached)
gst-plugins-bad| Compiler for C supports link arguments -Wl,-z,nodelete: YES (cached)
gst-plugins-bad| Compiler for C++ supports link arguments -Wl,-z,nodelete: YES (cached)
gst-plugins-bad| Compiler for C supports arguments -fvisibility=hidden: YES (cached)
gst-plugins-bad| Compiler for C supports arguments -fno-strict-aliasing: YES (cached)
gst-plugins-bad| Compiler for C++ supports arguments -fno-strict-aliasing: YES (cached)
gst-plugins-bad| Message: Disabling deprecated GLib API
gst-plugins-bad| Has header "dlfcn.h" : YES (cached)
gst-plugins-bad| Has header "fcntl.h" : YES (cached)
gst-plugins-bad| Has header "inttypes.h" : YES (cached)
gst-plugins-bad| Has header "memory.h" : YES (cached)
gst-plugins-bad| Has header "netinet/in.h" : YES (cached)
gst-plugins-bad| Has header "netinet/ip.h" : YES
gst-plugins-bad| Has header "netinet/tcp.h" : YES (cached)
gst-plugins-bad| Has header "pthread.h" : YES
gst-plugins-bad| Has header "stdint.h" : YES (cached)
gst-plugins-bad| Has header "stdlib.h" : YES (cached)
gst-plugins-bad| Has header "strings.h" : YES (cached)
gst-plugins-bad| Has header "string.h" : YES (cached)
gst-plugins-bad| Has header "sys/param.h" : YES (cached)
gst-plugins-bad| Has header "sys/socket.h" : YES (cached)
gst-plugins-bad| Has header "sys/stat.h" : YES (cached)
gst-plugins-bad| Has header "sys/time.h" : YES (cached)
gst-plugins-bad| Has header "sys/types.h" : YES (cached)
gst-plugins-bad| Has header "sys/utsname.h" : YES (cached)
gst-plugins-bad| Has header "unistd.h" : YES (cached)
gst-plugins-bad| Has header "windows.h" : NO
gst-plugins-bad| Has header "winsock2.h" : NO (cached)
gst-plugins-bad| Has header "ws2tcpip.h" : NO
gst-plugins-bad| Checking for function "dcgettext" : YES
gst-plugins-bad| Checking for function "getpagesize" : YES (cached)
gst-plugins-bad| Checking for function "gmtime_r" : YES (cached)
gst-plugins-bad| Checking for function "memfd_create" : YES (cached)
gst-plugins-bad| Checking for function "mmap" : YES
gst-plugins-bad| Checking for function "pipe2" : YES
gst-plugins-bad| Checking for function "getrusage" : YES
gst-plugins-bad| Checking for size of "char" : 1 (cached)
gst-plugins-bad| Checking for size of "int" : 4 (cached)
gst-plugins-bad| Checking for size of "long" : 4 (cached)
gst-plugins-bad| Checking for size of "short" : 2 (cached)
gst-plugins-bad| Checking for size of "void*" : 4 (cached)
gst-plugins-bad| Compiler for C supports arguments -Wmissing-prototypes: YES (cached)
gst-plugins-bad| Compiler for C supports arguments -Wold-style-definition: YES (cached)
gst-plugins-bad| Compiler for C++ supports arguments -Wformat-nonliteral: YES (cached)
gst-plugins-bad| Compiler for C supports arguments -Wmissing-declarations: YES (cached)
gst-plugins-bad| Compiler for C++ supports arguments -Wmissing-declarations: YES (cached)
gst-plugins-bad| Compiler for C supports arguments -Wredundant-decls: YES (cached)
gst-plugins-bad| Compiler for C++ supports arguments -Wredundant-decls: YES (cached)
gst-plugins-bad| Compiler for C supports arguments -Wwrite-strings: YES (cached)
gst-plugins-bad| Compiler for C++ supports arguments -Wwrite-strings: YES (cached)
gst-plugins-bad| Compiler for C supports arguments -Wformat: YES (cached)
gst-plugins-bad| Compiler for C++ supports arguments -Wformat: YES (cached)
gst-plugins-bad| Compiler for C supports arguments -Wformat-security: YES (cached)
gst-plugins-bad| Compiler for C++ supports arguments -Wformat-security: YES (cached)
gst-plugins-bad| Compiler for C supports arguments -Winit-self: YES (cached)
gst-plugins-bad| Compiler for C++ supports arguments -Winit-self: YES (cached)
gst-plugins-bad| Compiler for C supports arguments -Wmissing-include-dirs: YES (cached)
gst-plugins-bad| Compiler for C++ supports arguments -Wmissing-include-dirs: YES (cached)
gst-plugins-bad| Compiler for C supports arguments -Waddress: YES (cached)
gst-plugins-bad| Compiler for C++ supports arguments -Waddress: YES (cached)
gst-plugins-bad| Compiler for C supports arguments -Wno-multichar: YES (cached)
gst-plugins-bad| Compiler for C++ supports arguments -Wno-multichar: YES (cached)
gst-plugins-bad| Compiler for C supports arguments -Wvla: YES (cached)
gst-plugins-bad| Compiler for C++ supports arguments -Wvla: YES (cached)
gst-plugins-bad| Compiler for C supports arguments -Wpointer-arith: YES (cached)
gst-plugins-bad| Compiler for C++ supports arguments -Wpointer-arith: YES (cached)
gst-plugins-bad| Dependency gstreamer-1.0 found: YES 1.25.0.1 (overridden)
gst-plugins-bad| Dependency gstreamer-base-1.0 found: YES 1.25.0.1 (overridden)
gst-plugins-bad| Dependency gstreamer-net-1.0 found: YES 1.25.0.1 (overridden)
gst-plugins-bad| Dependency gstreamer-controller-1.0 found: YES 1.25.0.1 (overridden)
gst-plugins-bad| Dependency gstreamer-pbutils-1.0 found: YES 1.25.0.1 (overridden)
gst-plugins-bad| Dependency gstreamer-allocators-1.0 found: YES 1.25.0.1 (overridden)
gst-plugins-bad| Dependency gstreamer-app-1.0 found: YES 1.25.0.1 (overridden)
gst-plugins-bad| Dependency gstreamer-audio-1.0 found: YES 1.25.0.1 (overridden)
gst-plugins-bad| Dependency gstreamer-fft-1.0 found: YES 1.25.0.1 (overridden)
gst-plugins-bad| Dependency gstreamer-riff-1.0 found: YES 1.25.0.1 (overridden)
gst-plugins-bad| Dependency gstreamer-rtp-1.0 found: YES 1.25.0.1 (overridden)
gst-plugins-bad| Dependency gstreamer-rtsp-1.0 found: YES 1.25.0.1 (overridden)
gst-plugins-bad| Dependency gstreamer-sdp-1.0 found: YES 1.25.0.1 (overridden)
gst-plugins-bad| Dependency gstreamer-tag-1.0 found: YES 1.25.0.1 (overridden)
gst-plugins-bad| Dependency gstreamer-video-1.0 found: YES 1.25.0.1 (overridden)
gst-plugins-bad| Dependency gstreamer-check-1.0 found: YES 1.25.0.1 (overridden)
gst-plugins-bad| Dependency gstreamer-gl-1.0 found: YES 1.25.0.1 (overridden)
gst-plugins-bad| Dependency gstreamer-gl-prototypes-1.0 found: YES 1.25.0.1 (overridden)
gst-plugins-bad| Message: GStreamer OpenGL window systems: egl surfaceless wayland x11 gbm
gst-plugins-bad| Message: GStreamer OpenGL platforms: egl glx
gst-plugins-bad| Message: GStreamer OpenGL apis: gles2 gl
gst-plugins-bad| Dependency gstreamer-gl-x11-1.0 found: YES 1.25.0.1 (overridden)
gst-plugins-bad| Dependency gstreamer-gl-wayland-1.0 found: YES 1.25.0.1 (overridden)
gst-plugins-bad| Dependency gstreamer-gl-egl-1.0 found: YES 1.25.0.1 (overridden)
gst-plugins-bad| Library m found: YES
gst-plugins-bad| Dependency gio-2.0 found: YES 2.78.4 (cached)
gst-plugins-bad| Dependency gmodule-no-export-2.0 found: YES 2.78.4 (cached)
gst-plugins-bad| Dependency x11 found: YES 1.8.7 (cached)
gst-plugins-bad| Dependency orc-0.4 found: YES 0.4.38 (cached)
gst-plugins-bad| Program orcc found: YES (/usr/bin/orcc)
gst-plugins-bad| Message: GStreamer debug system is enabled
gst-plugins-bad| Program python3 found: YES (/usr/bin/python)
gst-plugins-bad| Program g-ir-scanner skipped: feature introspection disabled
gst-plugins-bad| Dependency glib-2.0 found: YES 2.78.4 (cached)
gst-plugins-bad| Program /usr/bin/glib-mkenums found: YES (/usr/bin/glib-mkenums)
gst-plugins-bad| Dependency glib-2.0 found: YES 2.78.4 (cached)
gst-plugins-bad| Program /usr/bin/glib-mkenums found: YES (/usr/bin/glib-mkenums)
gst-plugins-bad| Dependency glib-2.0 found: YES 2.78.4 (cached)
gst-plugins-bad| Program /usr/bin/glib-mkenums found: YES (/usr/bin/glib-mkenums)
gst-plugins-bad| Dependency glib-2.0 found: YES 2.78.4 (cached)
gst-plugins-bad| Program /usr/bin/glib-mkenums found: YES (/usr/bin/glib-mkenums)
gst-plugins-bad| Dependency glib-2.0 found: YES 2.78.4 (cached)
gst-plugins-bad| Program /usr/bin/glib-mkenums found: YES (/usr/bin/glib-mkenums)
gst-plugins-bad| Dependency glib-2.0 found: YES 2.78.4 (cached)
gst-plugins-bad| Program /usr/bin/glib-mkenums found: YES (/usr/bin/glib-mkenums)
gst-plugins-bad| Dependency glib-2.0 found: YES 2.78.4 (cached)
gst-plugins-bad| Program /usr/bin/glib-mkenums found: YES (/usr/bin/glib-mkenums)
gst-plugins-bad| Dependency glib-2.0 found: YES 2.78.4 (cached)
gst-plugins-bad| Program /usr/bin/glib-mkenums found: YES (/usr/bin/glib-mkenums)
gst-plugins-bad| Dependency glib-2.0 found: YES 2.78.4 (cached)
gst-plugins-bad| Program /usr/bin/glib-mkenums found: YES (/usr/bin/glib-mkenums)
gst-plugins-bad| Dependency glib-2.0 found: YES 2.78.4 (cached)
gst-plugins-bad| Program /usr/bin/glib-mkenums found: YES (/usr/bin/glib-mkenums)
gst-plugins-bad| Run-time dependency libva found: YES 1.20.0
gst-plugins-bad| Run-time dependency libva-drm found: YES 1.20.0
gst-plugins-bad| Dependency libdrm found: YES 2.4.120 (cached)
gst-plugins-bad| Dependency glib-2.0 found: YES 2.78.4 (cached)
gst-plugins-bad| Program /usr/bin/glib-mkenums found: YES (/usr/bin/glib-mkenums)
gst-plugins-bad| Dependency glib-2.0 found: YES 2.78.4 (cached)
gst-plugins-bad| Program /usr/bin/glib-mkenums found: YES (/usr/bin/glib-mkenums)
gst-plugins-bad| Run-time dependency vulkan found: YES 1.3.279
gst-plugins-bad| Has header "vulkan/vulkan_core.h" : YES
gst-plugins-bad| Run-time dependency xcb found: YES 1.16.1
gst-plugins-bad| Run-time dependency xkbcommon found: YES 1.6.0
gst-plugins-bad| Run-time dependency xkbcommon-x11 found: YES 1.6.0
gst-plugins-bad| Has header "vulkan/vulkan_xcb.h" with dependency vulkan: YES
gst-plugins-bad| Dependency wayland-client found: YES 1.22.0 (cached)
gst-plugins-bad| Dependency wayland-protocols found: YES 1.33 (cached)
gst-plugins-bad| Program wayland-scanner found: YES (/usr/bin/wayland-scanner)
gst-plugins-bad| Has header "vulkan/vulkan_wayland.h" with dependency vulkan: YES
gst-plugins-bad| Program glslc found: YES (/usr/bin/glslc)
gst-plugins-bad| Configuring gstvkconfig.h using configuration
gst-plugins-bad| Program glib-mkenums found: YES (/usr/bin/glib-mkenums)
gst-plugins-bad| Program vulkan_mkenum.py found: YES (/usr/bin/python /home/helder/.cache/paru/clone/lib32-gstreamer-git/src/gstreamer/subprojects/gst-plugins-bad/gst-libs/gst/vulkan/vulkan_mkenum.py)
gst-plugins-bad| Dependency wayland-client found: YES 1.22.0 (cached)
gst-plugins-bad| Dependency libdrm found: YES 2.4.120 (cached)
gst-plugins-bad| Dependency wayland-protocols found: YES 1.33 (cached)
gst-plugins-bad| Program wayland-scanner found: YES (/usr/bin/wayland-scanner)
gst-plugins-bad| Dependency glib-2.0 found: YES 2.78.4 (cached)
gst-plugins-bad| Program /usr/bin/glib-mkenums found: YES (/usr/bin/glib-mkenums)
gst-plugins-bad| Dependency glib-2.0 found: YES 2.78.4 (cached)
gst-plugins-bad| Program /usr/bin/glib-mkenums found: YES (/usr/bin/glib-mkenums)
gst-plugins-bad| Run-time dependency nice found: YES 0.1.21
gst-plugins-bad| Compiler for C supports arguments -Wno-unknown-pragmas: YES
gst-plugins-bad| Run-time dependency ltc found: NO (tried pkgconfig and cmake)
gst-plugins-bad| Dependency gstreamer-allocators-1.0 found: YES 1.25.0.1 (overridden)
gst-plugins-bad| Dependency gio-unix-2.0 found: YES 2.78.4 (cached)
gst-plugins-bad| Run-time dependency bluez found: YES 5.71
gst-plugins-bad| Dependency gio-unix-2.0 found: YES 2.78.4 (cached)
gst-plugins-bad| Dependency gio-2.0 found: YES 2.78.4 (cached)
gst-plugins-bad| Program /usr/bin/gdbus-codegen found: YES (/usr/bin/gdbus-codegen)
gst-plugins-bad| Library dl found: YES
gst-plugins-bad| Dependency threads found: YES unknown (cached)
gst-plugins-bad| Message: Building decklink plugin
gst-plugins-bad| Has header "linux/fb.h" : YES
gst-plugins-bad| Dependency libdrm found: YES 2.4.120 (cached)
gst-plugins-bad| Dependency libdrm found: YES 2.4.120 (cached)
gst-plugins-bad| Library m found: YES
gst-plugins-bad| Library ml_audio skipped: feature magicleap disabled
gst-plugins-bad| Library lumin_rt_core_1_7 skipped: feature magicleap disabled
gst-plugins-bad| Library lumin_rt_app_1_7 skipped: feature magicleap disabled
gst-plugins-bad| Has header "nvbufsurface.h" : NO
gst-plugins-bad| Has header "/opt/nvidia/deepstream/deepstream/sources/includes/nvbufsurface.h" : NO
gst-plugins-bad| Dependency gio-unix-2.0 found: YES 2.78.4 (cached)
gst-plugins-bad| Compiler for C supports arguments -Wno-deprecated-declarations: YES (cached)
gst-plugins-bad| Library rt found: YES
gst-plugins-bad| Has header "sys/socket.h" : YES (cached)
gst-plugins-bad| Dependency gudev-1.0 found: YES 238 (cached)
gst-plugins-bad| Run-time dependency libusb-1.0 found: YES 1.0.27
gst-plugins-bad| Has header "linux/uvcvideo.h" : YES
gst-plugins-bad| Dependency gudev-1.0 found: YES 238 (cached)
gst-plugins-bad| Has header "linux/videodev2.h" : YES (cached)
gst-plugins-bad| Header "sys/mkdev.h" has symbol "makedev" : NO
gst-plugins-bad| Header "sys/sysmacros.h" has symbol "makedev" : YES
gst-plugins-bad| Header "sys/types.h" has symbol "makedev" : NO
gst-plugins-bad| Dependency gudev-1.0 found: YES 238 (cached)
gst-plugins-bad| Has header "linux/videodev2.h" : YES (cached)
gst-plugins-bad| Header "sys/mkdev.h" has symbol "makedev" : NO (cached)
gst-plugins-bad| Header "sys/sysmacros.h" has symbol "makedev" : YES (cached)
gst-plugins-bad| Header "sys/types.h" has symbol "makedev" : NO (cached)
gst-plugins-bad| Dependency gudev-1.0 found: YES 238 (cached)
gst-plugins-bad| Run-time dependency openssl found: YES 3.2.1
gst-plugins-bad| Dependency pangocairo found: YES 1.52.1 (cached)
gst-plugins-bad| Run-time dependency libass found: YES 0.17.1
gst-plugins-bad| Run-time dependency aom found: YES 3.6.1
gst-plugins-bad| Dependency aom found: YES 3.6.1 (cached)
gst-plugins-bad| Dependency aom found: YES 3.6.1 (cached)
gst-plugins-bad| Checking for type "struct sock_txtime" : YES
gst-plugins-bad| Run-time dependency avtp found: YES 0.2.0
gst-plugins-bad| Run-time dependency libbs2b found: YES 3.1.0
gst-plugins-bad| Library bz2 found: YES
gst-plugins-bad| Header "bzlib.h" has symbol "BZ2_bzlibVersion" : YES
gst-plugins-bad| Dependency libchromaprint skipped: feature chromaprint disabled
gst-plugins-bad| Dependency pangocairo found: YES 1.52.1 (cached)
gst-plugins-bad| Run-time dependency json-glib-1.0 found: YES 1.8.0
gst-plugins-bad| Run-time dependency lcms2 found: YES 2.16
gst-plugins-bad| Run-time dependency libcurl found: YES 8.6.0
gst-plugins-bad| Run-time dependency libssh2 found: YES 1.11.0
gst-plugins-bad| Dependency libxml-2.0 found: YES 2.12.6 (cached)
gst-plugins-bad| Run-time dependency libdc1394-2 found: YES 2.2.7
gst-plugins-bad| Dependency directfb skipped: feature directfb disabled
gst-plugins-bad| Dependency openssl found: YES 3.2.1 (cached)
gst-plugins-bad| Run-time dependency libcrypto found: YES 3.2.1
gst-plugins-bad| Run-time dependency libdca found: YES 0.0.7
gst-plugins-bad| Library faac found: YES
gst-plugins-bad| Header "faac.h" has symbol "faacEncOpen" : YES
gst-plugins-bad| Header "neaacdec.h" has symbol "NeAACDecOpen" : YES
gst-plugins-bad| Header "neaacdec.h" has symbol "LATM" : YES
gst-plugins-bad| Library faad found: YES
gst-plugins-bad| Run-time dependency fdk-aac found: YES 2.0.2
gst-plugins-bad| Run-time dependency fluidsynth found: YES 2.3.4
gst-plugins-bad| Has header "gme/gme.h" : YES
gst-plugins-bad| Library gme found: YES
gst-plugins-bad| Checking for function "gme_enable_accuracy" with dependency -lgme: YES
gst-plugins-bad| Dependency google_cloud_cpp_storage skipped: feature gs disabled
gst-plugins-bad| Dependency gtk+-3.0 found: YES 3.24.41 (cached)
gst-plugins-bad| Dependency gtk+-wayland-3.0 found: YES 3.24.41 (cached)
gst-plugins-bad| Dependency nettle found: YES 3.9.1 (cached)
gst-plugins-bad| Dependency dssim skipped: feature iqa disabled
gst-plugins-bad| Dependency webrtc-audio-coding-1 skipped: feature isac disabled
gst-plugins-bad| Has header "ladspa.h" : YES
gst-plugins-bad| Run-time dependency lrdf found: YES 0.5.0
gst-plugins-bad| Dependency lc3 skipped: feature lc3 disabled
gst-plugins-bad| Dependency ldacBT-enc skipped: feature ldac disabled
gst-plugins-bad| Run-time dependency libde265 found: YES 1.0.11
gst-plugins-bad| Run-time dependency lilv-0 found: YES 0.24.20
gst-plugins-bad| Dependency microdns skipped: feature microdns disabled
gst-plugins-bad| Run-time dependency libmodplug found: YES 0.8.9.0
gst-plugins-bad| Dependency mjpegtools skipped: feature mpeg2enc disabled
gst-plugins-bad| Library mpeg2encpp skipped: feature mpeg2enc disabled
gst-plugins-bad| Dependency mjpegtools skipped: feature mplex disabled
gst-plugins-bad| Library mplex2 skipped: feature mplex disabled
gst-plugins-bad| Library mpcdec found: YES
gst-plugins-bad| Header "mpc/mpcdec.h" has symbol "mpc_demux_init" with dependency -lmpcdec: YES
gst-plugins-bad| Run-time dependency neon found: YES 0.32.5
gst-plugins-bad| Run-time dependency openal found: YES 1.23.1
gst-plugins-bad| Dependency OpenEXR (modules: OpenEXR::IlmImf) skipped: feature openexr disabled
gst-plugins-bad| Dependency openh264 skipped: feature openh264 disabled
gst-plugins-bad| Dependency libopenjp2 skipped: feature openjpeg disabled
gst-plugins-bad| Dependency libopenmpt skipped: feature openmpt disabled
gst-plugins-bad| Compiler for language cpp skipped: feature openni2 disabled
gst-plugins-bad| Dependency opus found: YES 1.5.1 (cached)
gst-plugins-bad| Dependency libqrencode skipped: feature qroverlay disabled
gst-plugins-bad| Run-time dependency dvdnav found: YES 6.1.1
gst-plugins-bad| Run-time dependency dvdread found: YES 6.1.3
gst-plugins-bad| Run-time dependency cairo found: YES 1.18.0
gst-plugins-bad| Run-time dependency librsvg-2.0 found: YES 2.57.3
gst-plugins-bad| Run-time dependency librtmp found: YES v2.4
gst-plugins-bad| Run-time dependency sbc found: YES 2.0
gst-plugins-bad| Message: Using internal libusrsctp
gst-plugins-bad| Compiler for C supports arguments -Wfloat-equal: YES
gst-plugins-bad| Compiler for C supports arguments -Wshadow: YES
gst-plugins-bad| Compiler for C supports arguments -Wpointer-arith: YES (cached)
gst-plugins-bad| Compiler for C supports arguments -Winit-self: YES (cached)
gst-plugins-bad| Compiler for C supports arguments -Wno-unused-function: YES
gst-plugins-bad| Compiler for C supports arguments -Wno-unused-parameter: YES
gst-plugins-bad| Compiler for C supports arguments -Wno-unreachable-code: YES
gst-plugins-bad| Compiler for C supports arguments -Wstrict-prototypes: YES
gst-plugins-bad| Compiler for C supports arguments -Wno-missing-prototypes: YES (cached)
gst-plugins-bad| Compiler for C supports arguments -Wno-incompatible-pointer-types-discards-qualifiers: NO (cached)
gst-plugins-bad| Compiler for C supports arguments -Wno-address-of-packed-member: YES
gst-plugins-bad| Compiler for C supports arguments -Wno-discarded-qualifiers: YES (cached)
gst-plugins-bad| Compiler for C supports arguments -Wno-missing-declarations: YES (cached)
gst-plugins-bad| Compiler for C supports arguments -Wno-old-style-definition: YES (cached)
gst-plugins-bad| Compiler for C supports arguments -Wno-redundant-decls: YES (cached)
gst-plugins-bad| Dependency threads found: YES unknown (cached)
gst-plugins-bad| Has header "sys/queue.h" : YES
gst-plugins-bad| Has header "sys/socket.h" : YES (cached)
gst-plugins-bad| Has header "linux/if_addr.h" : YES
gst-plugins-bad| Has header "linux/rtnetlink.h" : YES
gst-plugins-bad| Has header "sys/types.h" : YES (cached)
gst-plugins-bad| Has header "netinet/in.h" : YES (cached)
gst-plugins-bad| Has header "netinet/ip.h" : YES (cached)
gst-plugins-bad| Has header "netinet/ip_icmp.h" : YES
gst-plugins-bad| Has header "stdatomic.h" : YES
gst-plugins-bad| Checking whether type "struct sockaddr" has member "sa_len" : NO
gst-plugins-bad| Checking whether type "struct sockaddr_in" has member "sin_len" : NO
gst-plugins-bad| Checking whether type "struct sockaddr_in6" has member "sin6_len" : NO
gst-plugins-bad| Checking whether type "struct sockaddr_conn" has member "sconn_len" : NO
gst-plugins-bad| Dependency libxml-2.0 found: YES 2.12.6 (cached)
gst-plugins-bad| Run-time dependency sndfile found: YES 1.2.2
gst-plugins-bad| Run-time dependency soundtouch found: YES 2.3.2
gst-plugins-bad| Dependency spandsp skipped: feature spandsp disabled
gst-plugins-bad| Run-time dependency srt found: YES 1.5.1
gst-plugins-bad| Dependency glib-2.0 found: YES 2.78.4 (cached)
gst-plugins-bad| Program /usr/bin/glib-mkenums found: YES (/usr/bin/glib-mkenums)
gst-plugins-bad| Dependency glib-2.0 found: YES 2.78.4 (cached)
gst-plugins-bad| Program /usr/bin/glib-mkenums found: YES (/usr/bin/glib-mkenums)
gst-plugins-bad| Run-time dependency libsrtp2 found: YES 2.5.0
gst-plugins-bad| Dependency glib-2.0 found: YES 2.78.4 (cached)
gst-plugins-bad| Program /usr/bin/glib-mkenums found: YES (/usr/bin/glib-mkenums)
gst-plugins-bad| Dependency glib-2.0 found: YES 2.78.4 (cached)
gst-plugins-bad| Program /usr/bin/glib-mkenums found: YES (/usr/bin/glib-mkenums)
gst-plugins-bad| Dependency SvtAv1Enc skipped: feature svtav1 disabled
gst-plugins-bad| Dependency SvtHevcEnc skipped: feature svthevcenc disabled
gst-plugins-bad| Run-time dependency zvbi-0.2 found: YES 0.2.42
gst-plugins-bad| Dependency libxml-2.0 found: YES 2.12.6 (cached)
gst-plugins-bad| Run-time dependency pango found: YES 1.52.1
gst-plugins-bad| Dependency cairo found: YES 1.18.0 (cached)
gst-plugins-bad| Dependency pangocairo found: YES 1.52.1 (cached)
gst-plugins-bad| Dependency vo-aacenc skipped: feature voaacenc disabled
gst-plugins-bad| Dependency vo-amrwbenc skipped: feature voamrwbenc disabled
gst-plugins-bad| Program bin2array.py found: YES (/home/helder/.cache/paru/clone/lib32-gstreamer-git/src/gstreamer/subprojects/gst-plugins-bad/ext/vulkan/shaders/bin2array.py)
gst-plugins-bad| Dependency glib-2.0 found: YES 2.78.4 (cached)
gst-plugins-bad| Program /usr/bin/glib-mkenums found: YES (/usr/bin/glib-mkenums)
gst-plugins-bad| Dependency glib-2.0 found: YES 2.78.4 (cached)
gst-plugins-bad| Program /usr/bin/glib-mkenums found: YES (/usr/bin/glib-mkenums)
gst-plugins-bad| Dependency webrtc-audio-processing-1 skipped: feature webrtcdsp disabled
gst-plugins-bad| Run-time dependency libwebp found: YES 1.3.2
gst-plugins-bad| Run-time dependency libwebpmux found: YES 1.3.2
gst-plugins-bad| Run-time dependency wildmidi found: YES 0.4.5
gst-plugins-bad| Run-time dependency x265 found: YES 3.5
gst-plugins-bad| Dependency zxing skipped: feature zxing disabled
gst-plugins-bad| Dependency zbar skipped: feature zbar disabled
gst-plugins-bad| Run-time dependency libexif found: NO (tried pkgconfig and cmake)
gst-plugins-bad| Run-time dependency libsoup-2.4 found: NO (tried pkgconfig and cmake)
gst-plugins-bad| Looking for a fallback subproject for the dependency libsoup-2.4
gst-plugins-bad| Automatic wrap-based subproject downloading is disabled
gst-plugins-bad| Subproject  libsoup is buildable: NO (disabling)
gst-plugins-bad| Dependency libsoup-2.4 from subproject libsoup found: NO (subproject failed to configure)
gst-plugins-bad| Header "faac.h" has symbol "faacEncOpen" : YES (cached)
gst-plugins-bad| Library orc-test-0.4 found: YES
gst-plugins-bad| Program gst-tester-1.0 found: YES (overridden)
gst-plugins-bad| Program scripts/update-orc-dist-files.py found: YES (/home/helder/.cache/paru/clone/lib32-gstreamer-git/src/gstreamer/subprojects/gst-plugins-bad/scripts/update-orc-dist-files.py)
gst-plugins-bad| Program xgettext found: YES (/usr/bin/xgettext)
gst-plugins-bad| Configuring config.h using configuration
gst-plugins-bad| Message: Introspection not built, won't build documentation requiring it
gst-plugins-bad| Program hotdoc skipped: feature doc disabled
gst-plugins-bad| Message: Hotdoc not found, not building the documentation
gst-plugins-bad| Build targets in project: 1126
gst-plugins-bad| Subproject gst-plugins-bad finished.

btd1337 commented on 2024-03-19 04:00 (UTC) (edited on 2024-03-19 04:12 (UTC) by btd1337)

gst-plugins-bad| Run-time dependency nice found: NO (tried pkgconfig and cmake)

gst-plugins-bad| Looking for a fallback subproject for the dependency nice

gstreamer/subprojects/gst-plugins-bad/gst-libs/gst/webrtc/nice/meson.build:16:14: 

ERROR: Subproject "subprojects/libnice" required but not found.

SKV commented on 2023-12-14 18:11 (UTC)

@heyrict Thanks for your advice. the build script is update now.

@MarsSeed It seems we don't need this as makedepends, so I remove it. If there is any problem, please let me know.

MarsSeed commented on 2023-12-02 08:55 (UTC)

Please kindly remove the unneeded (and currently broken) makedepend lib32-shaderc, and instead add makedepends=shaderc.

heyrict commented on 2023-11-19 05:06 (UTC) (edited on 2023-11-19 05:06 (UTC) by heyrict)

Please add the following packages as make dependencies:

  • (build dependencies) flex, bison
  • (required for stripping .so files) debugedit

In addition, I've also encountered the "ERROR: Automatic wrap-based subproject downloading is disabled" error in aja. This is one workaround.

--- OLD_PKGBUILD    2023-11-19 13:03:42.108494808 +0800
+++ PKGBUILD    2023-11-19 13:03:43.308486521 +0800
@@ -114,6 +114,7 @@
     -D gst-plugins-good:package-name="Arch Linux gst-plugins-good $pkgver-$pkgrel"
     -D gst-plugins-good:package-origin="https://www.archlinux.org/"

+    -D gst-plugins-bad:aja=disabled
     -D gst-plugins-bad:amfcodec=disabled
     -D gst-plugins-bad:chromaprint=disabled
     -D gst-plugins-bad:directfb=disabled
@@ -536,7 +537,7 @@
     usr/lib32/gstreamer-1.0/libgstfluidsynthmidi.so
     usr/lib32/gstreamer-1.0/libgstgme.so
     usr/lib32/gstreamer-1.0/libgsthls.so
-    usr/lib32/gstreamer-1.0/libgstkate.so
+    #usr/lib32/gstreamer-1.0/libgstkate.so
     usr/lib32/gstreamer-1.0/libgstladspa.so
     usr/lib32/gstreamer-1.0/libgstlv2.so
     usr/lib32/gstreamer-1.0/libgstmodplug.so

SKV commented on 2023-07-23 07:52 (UTC)

@RAMChYLD Thanks, I've changed this in the latest commit, you can rebuild again.