Package Details: lib32-gtk-engines 2.21.0-3

Git Clone URL: (read-only)
Package Base: lib32-gtk-engines
Description: Theme engines for GTK+ 2 (32 bit)
Upstream URL:
Licenses: LGPL
Submitter: None
Maintainer: grimi
Last Packager: grimi
Votes: 211
Popularity: 0.770750
First Submitted: 2008-07-26 10:20
Last Updated: 2015-06-08 16:54

Dependencies (4)

Required by (6)

Sources (1)

Latest Comments

patrakov commented on 2016-03-01 22:15

Thanks for the PKGBUILD. It makes Skype look native in MATE.

stuart commented on 2015-12-06 23:57

I had the same requirement for gcc-multilib and gcc-libs-multilib as Chrissss and then install went through just fine.

rafaelff commented on 2015-12-03 12:03

That's strange, Chrissss. The PKGBUILD correctly set gcc-multilib as makedepends, which is always installed before the main package. Something bugged went on your side, I suppose... Anyway, I suggest having gcc-multilib installed if you plan to have lib32 packages from AUR.

Chrissss commented on 2015-12-03 11:11

I had the problem, that the installation failed because of unresolvable package conflicts...

$ pacaur -S lib32-gtk-engines
:: Package(s) lib32-gtk-engines not found in repositories, trying AUR...
:: resolving dependencies...
:: looking for inter-conflicts...
:: gcc-multilib and gcc are in conflict (gcc). Remove gcc? [y/N] y
:: gcc-libs-multilib and gcc-libs are in conflict (gcc-libs). Remove gcc-libs? [y/N] y

AUR Packages (1): lib32-gtk-engines-2.21.0-3
Repo Packages (2): gcc-libs-multilib-5.2.0-2 gcc-multilib-5.2.0-2

Repo Download Size: 32.93 MiB
Repo Installed Size: 144.46 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving package(s)...
Already up-to-date.
:: View lib32-gtk-engines PKGBUILD? [Y/n] y
:: lib32-gtk-engines PKGBUILD viewed
:: Checking lib32-gtk-engines integrity...
==> Making package: lib32-gtk-engines 2.21.0-3 (Do 3. Dez 12:00:21 CET 2015)
==> Retrieving sources...
-> Found gtk-engines-2.21.0.tar.gz
==> Validating source files with md5sums...
gtk-engines-2.21.0.tar.gz ... Passed
:: Building lib32-gtk-engines package(s)...
==> Making package: lib32-gtk-engines 2.21.0-3 (Do 3. Dez 12:00:21 CET 2015)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Installing missing dependencies...
resolving dependencies...
looking for conflicting packages...
:: gcc-multilib and gcc are in conflict. Remove gcc? [y/N]
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: gcc-multilib and gcc are in conflict
==> ERROR: 'pacman' failed to install missing dependencies.

I had to install gcc-multilib first (sudo pacman -S gcc-multilib) after that i could install lib32-gtk-engines just fine.

killermoehre commented on 2015-02-11 22:58

The source needs an update from to Sie the PKGBUILD of gtk-engines for more informations.

rafaelff commented on 2013-05-17 07:39

pkgrel updated. lib32-gtk2 already depends on lib32-libpng, so I don't need to add it and therefore didn't add it.

SirWuffleton commented on 2013-05-17 07:31

Could you bump the PKGREL so that this package recompiles against libpng16?

After having Skype's GTK styles look ugly and spitting errors about something still looking for libpng15, I was able to isolate this package as being the culprit. A recompile against the new library fixed the issues.

Additionally, lib32-libpng should be a dependency.

rafaelff commented on 2012-07-18 22:31

@willianholtz, can you please post output of 'pacman -Q lib32-glibc' ?

Anonymous comment on 2012-07-18 21:50

i have problem here..

==> Iniciando build()...
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for gcc... gcc -m32
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... configure: error: in `/tmp/yaourt-tmp-willian/aur-lib32-gtk-engines/src/gtk-engines-2.21.0':
configure: error: cannot run C compiled programs.
If you meant to cross compile, use `--host'.
See `config.log' for more details

What's wrong?

rafaelff commented on 2012-04-27 16:26

@zonyitoo: It was a change of requirement of glib 2.32. Thanks for reporting. Patched and fixed in 2.20.2-4.

zonyitoo commented on 2012-04-27 14:50

Some error while making:
In file included from ./src/animation.c:31:0:
/usr/include/glib-2.0/glib/gtimer.h:28:2: error: #error "Only <glib.h> can be included directly."
What's the problem?

zonyitoo commented on 2012-04-27 14:45

Some error while making:
In file included from ./src/animation.c:31:0:
/usr/include/glib-2.0/glib/gtimer.h:28:2: error: #error "Only <glib.h> can be included directly."
What's the problem?

rafaelff commented on 2011-04-22 03:57

It is normally safe to replace <package> with <package>-multilib. I never had a single problem with it.

Anonymous comment on 2011-04-21 20:33

binutils and binutils-multilib conflict... can I remove binutils?
the same with gcc and gcc-libs

rafaelff commented on 2011-02-20 17:58

True, 'intltool' added to makedepends. I guess I should've double-checked before replying ;)
Thanks for your contribution!

backfist commented on 2011-02-20 16:35

base-devel autoconf
base-devel automake
base-devel bison
base-devel fakeroot
base-devel flex
base-devel gcc
base-devel libtool
base-devel m4
base-devel make
base-devel patch
base-devel pkg-config

im on x64 and its not part of base-devel. maybe it was sometime ago.

rafaelff commented on 2011-02-20 01:11

Nope, intltool is part of "base-devel" group and "Members of "base-devel" should not be included in makedepends arrays.", according to the page 'PKGBUILD' at ArchWiki.

Please install it with "pacman -S base-devel" and you'll be fine.

backfist commented on 2011-02-20 01:04

checking for intltool >= 0.31.0... ./configure: line 11055: intltool-update: command not found
I think theres an dep missing. initltool

rafaelff commented on 2011-01-25 06:36

My PKGBUILD suggestion:

rafaelff commented on 2011-01-25 06:22

My PKGBUILD suggestion:

rafaelff commented on 2011-01-25 06:02

My PKGBUILD suggestion:

trya commented on 2011-01-06 13:06

Installing lib32 libraries in /opt/lib32 is deprecated. If you don't want to comply with [multilib] (as every lib32 package should though), at least install your libraries in /usr/lib32, since the dynamic linker in multilib systems looks into that directory and not /opt/lib32 anymore.

Anonymous comment on 2011-01-05 23:35

you should really use multilib

Anonymous comment on 2010-12-06 07:43

I am a robot. AUR guidelines suggest to not include binaries. Examples:
Compressed files detected. This robot will not bother you again.

Anonymous comment on 2010-10-12 09:37

Update the PKGBUILD for version 2.20.2

The install dir change to /usr/lib32/gtk-2.0/2.10.0/engines
The Acrobat Reader bug is still there because it seems that the path is hard-coded to /usr/lib/gtk-2.0/2.10.0/engines which containt x86_64 version

Anonymous comment on 2010-09-18 09:12

Maybe it should be installed in /usr/lib32/gtk-2.0/2.10.0/engines. Acrobat Reader couldn't use this engines if they located in /opt directory

tom5760 commented on 2010-08-31 14:40

Updated PKGBUILD to use new multilib stuff:

Anonymous comment on 2010-04-20 17:42

404 errors on the current source, - changing the source in the pkgbuild and everything works fine

anpieber commented on 2010-04-06 21:23

2.20.0, e30193f018f0e179bc994f7496d3284f, tar.gz to tar.xz