Package Details: lib32-gtkglext 1.2.0-9

Git Clone URL: (read-only)
Package Base: lib32-gtkglext
Description: OpenGL extensions for GTK+ (32-bit)
Upstream URL:
Licenses: LGPL
Submitter: None
Maintainer: jnbek
Last Packager: jnbek
Votes: 70
Popularity: 0.003177
First Submitted: 2008-08-31 16:49
Last Updated: 2015-06-16 19:58

Latest Comments

rafaelgomes commented on 2014-07-01 21:00

Thanks for the tip @jnbek, I`ll wait for the update.

jnbek commented on 2014-07-01 20:16

@rafealgomes the critical dependency; multilib package is out of date. Once this is updated, this package should build again.

rafaelgomes commented on 2014-07-01 16:03

I've got the following error:

checking for GTK+ - version >= 2.0.0... *** GTK+ header files (version 2.24.24) do not match
*** library (version 2.24.23)
configure: error: GTK+ 2.0 not found

rafaelff commented on 2013-06-06 01:11

@aphirst: Now I'm getting the md5sum as correct. Can you please confirm your problem with checksum?

Btw, package adopted

diffycat commented on 2013-06-05 16:32


rafaelff commented on 2013-06-02 18:52

md5sum could be incorrect. Here is the checksum I got for this source: 5c3240bfc1b21becd33ce35c5abe6f8d

aphirst commented on 2013-06-02 18:35

I don't know quite what the problem is, but I get this error if I try to build this package:
gtkglext-1.2.0.tar.bz2 ... FAILED
==> ERROR: One or more files did not pass the validity check!
==> ERROR: Makepkg was unable to build .

smudge commented on 2012-11-18 04:04

@josephgbr: Yes, that's what I thought. Many thanks for making the lib32-pangox-compat PKGBUILD.

rafaelff commented on 2012-11-17 16:50

@smudge: This message means that the compilation requires a library (i.e. libpangox-1.0), pkg-config said it is installed, but only a 64 bit (incompatible) library was found.

It means that 'lib32-pangox-compat' must be added as dependency of this package, instead of 'pangox-compat'

smudge commented on 2012-11-17 06:56

Fails to build for me with the below error. I assume the "skipping incompatible" bit is because /usr/lib/ (from pangox-compat) is 64bit. Any thoughts?

/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-unknown-linux-gnu/4.7.2/../../../ when searching for -lpangox-1.0
/usr/bin/ld: skipping incompatible /usr/lib/ when searching for -lpangox-1.0
/usr/bin/ld: cannot find -lpangox-1.0
collect2: error: ld returned 1 exit status
make[4]: *** [] Error 1
make[4]: Leaving directory `/tmp/packerbuild-1000/lib32-gtkglext/lib32-gtkglext/src/gtkglext-1.2.0/gdk'

diffycat commented on 2012-11-01 18:36

Updated: new dependencies.

Anonymous comment on 2012-10-31 13:58

I think there is a dependency missing: lib32-glu.
It failed to build. After adding lib32-glu, it worked.

Anonymous comment on 2012-09-17 17:55

lib32-gtk2 updated yesterday- the package now successfully builds and installs!

Anonymous comment on 2012-09-13 09:23

@josephgbr: Ah, I see- It's the same problem you pointed out about a year ago. Thanks for repeating the explanation and flagging the appropriate package- Much appreciated.

How long was the package flagged before getting an update, when it was flagged a year ago?

rafaelff commented on 2012-09-13 08:35

@CharBar: I flagged lib32-gtk2 as out-of-date. Once it gets updated, the headers (from 'gtk2') will match the libraries (from 'lib32-gtk2') again.

Anonymous comment on 2012-09-13 08:29

I'm also getting the header and library mismatch problem. My build fails with these last few lines:

checking for GTK+ - version >= 2.0.0... *** GTK+ header files (version 2.24.12) do not match
*** library (version 2.24.11)
configure: error: GTK+ 2.0 not found
==> ERROR: A failure occurred in build().
The build failed.

Any chance of getting an updated PKGBUILD? Or an idea of how to solve the problem on our own?

Anonymous comment on 2012-05-13 01:42

Someone can help me?

Anonymous comment on 2012-05-04 17:27

ldd /usr/lib32/ | grep pcre => /usr/lib32/ (0xf764a000)

Maybe i can fix it with a symbolic link?.

After try a sudo ln -s /usr/lib32/ /usr/lib32/ still don't fixed :(

rafaelff commented on 2012-05-04 05:59


Run 'ldd /usr/lib32/ | grep pcre' e see if it finds ''. Case not, install lib32-pcre, as lib32-glib2 needs it.

Anonymous comment on 2012-05-04 04:41

Here is it

rafaelff commented on 2012-05-04 03:15

@Cory: hmm, please provide us the 'config.log' generated. Put it in a paste site (e.g.

Anonymous comment on 2012-05-04 00:23


pacman -Qs lib32-glib2

local/lib32-glib2 2.32.1-2
Common C routines used by GTK+ 2.4 and other libs (32-bit)

rafaelff commented on 2012-05-03 21:00

@Cory: do you have lib32-glib2 installed?

Anonymous comment on 2012-05-03 20:33

I have problems to compile

rafaelff commented on 2011-09-02 05:08

This package depends on 'lib32-gtk2', while headers (/usr/include) are in 'gtk2'. Right now lib32-gtk2 is '2.24.5', while gtk2 is '2.24.6'. Therefore, as the error message tell us, version of headers do not match version of libraries.
lib32-gtk2 needs to be updated and is already flagged as out-of-date.

tlheitz commented on 2011-09-02 03:59

Error on makepkg:

checking for GTK+ - version >= 2.0.0... *** GTK+ header files (version 2.24.6) do not match
*** library (version 2.24.5)
configure: error: GTK+ 2.0 not found
==> ERROR: A failure occurred in build().

Seems like the header files version is taken from gtk2 package out of Extra and library version from lib32-gtk2 package out of Multilib.
Downgraded gtk2 to gtk2-2.24.5-3 and build ran fine.
No idea what this means, just thought I'd mention it.

rafaelff commented on 2011-06-08 20:23

Hm It's all right, false alarm. lib32-nvidia-utils is not a dependency, but lib32-libgl which, indeed, is already provided. :)

diffycat commented on 2011-06-08 20:10

So, is everything ok with current pkgbuild? (because I don't see any problems here)

diffycat commented on 2011-06-08 20:07

So, is everything ok with current pkgbuild? (because I don't see any problems here)

rafaelff commented on 2011-06-08 19:47

Just to complement your comment, I always run "namcap -i package.tar.xz". This will throw to the output a lot of information, including what should be inserted in depends=() in namcap's point of view. This is normally right, except for not mentioning the non-lib32 package (Ex: gtkglext) for header files in "include" folder.

diffycat commented on 2011-06-08 19:39

With 'lib32-libgl':
checking GL/glx.h usability... yes
checking GL/glx.h presence... yes
checking for GL/glx.h... yes
checking GL/gl.h usability... yes
checking GL/gl.h presence... yes
checking for GL/gl.h... yes
checking GL/glu.h usability... yes
checking GL/glu.h presence... yes
checking for GL/glu.h... yes
checking for glVertex3d in -lGLcore... no
checking for glVertex3d in -lGL... yes
checking for gluSphere in -lGLU... yes
checking for gluBeginCurve in -lGLU... yes
checking whether libGLU needs to be linked with the std C++ library... no
checking for GLXFBConfigSGIX... yes
checking for GLXFBConfigIDSGIX... yes
checking for GLXPbufferSGIX... yes
checking for GLXVideoSourceSGIX... yes
checking for __GLXextFuncPtr... yes
checking for GLhalfNV... yes

And 'lib32-nvidia-utils' provides 'lib32-libgl' which is already in dependency array.

rafaelff commented on 2011-06-08 01:33

Dependency missing: lib32-nvidia-utils

See my error output:
checking for GL/glu.h... yes
checking for glVertex3d in -lGLcore... no
checking for glVertex3d in -lGL... no
checking for glVertex3f in -lGL... no
checking for glVertex3i in -lGL... no
checking for glVertex3s in -lGL... no
checking for glVertex3d in -lMesaGL... no
configure: error: Cannot find GL library

diffycat commented on 2011-06-07 19:36


Can't reproduce - works fine for me.

checking whether we are cross compiling... no

Anonymous comment on 2011-06-07 18:55

checking whether we are cross compiling... configure: error: in `/home/edgar/lib32-gtkglext/src/gtkglext-1.2.0':
configure: error: cannot run C compiled programs.
If you meant to cross compile, use `--host'.
See `config.log' for more details

diffycat commented on 2010-12-06 15:58

Adopted and fixed.

trya commented on 2010-10-22 20:32

Please, update to comply with [multilib] :

grimi commented on 2010-09-24 07:00

multilib version of this package:

Kosava commented on 2010-04-30 14:23

this packege not work for me

-> Downloading gtkglext-1.2.0-2-i686.pkg.tar.gz...
--2010-04-30 16:23:50--
Resolving,,, ...
Connecting to||:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2010-04-30 16:23:51 ERROR 404: Not Found.