Package Details: lib32-libass 0.13.2-1

Git Clone URL: https://aur.archlinux.org/lib32-libass.git (read-only)
Package Base: lib32-libass
Description: A portable library for SSA/ASS subtitles rendering (32 bit)
Upstream URL: https://github.com/libass/libass/
Licenses: BSD
Provides: libass.so
Submitter: rafaelff
Maintainer: JonnyJD
Last Packager: JonnyJD
Votes: 12
Popularity: 0.111553
First Submitted: 2012-01-26 02:13
Last Updated: 2016-05-08 14:03

Latest Comments

JonnyJD commented on 2016-05-08 14:07

I fixed the build problem and updated the package.

For reference:
The error message was:
/usr/include/glib-2.0/glib/gtypes.h: In function '_GLIB_CHECKED_ADD_U64':
/usr/include/glib-2.0/glib/gmacros.h:217:53: error: size of array '_GStaticAssertCompileTimeAssertion_0' is negative
The solution was to force
export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
as suggested here were the problem started with glib 2.48:
https://github.com/i-rinat/apulse/issues/37

disastro commented on 2016-05-08 10:26

In addition to being outdated, it also doesn't build without change.
http://pastebin.ca/3594613 happens on both 0.12.2 and 0.13.2

JonnyJD commented on 2015-06-25 12:33

@GordonGR:
libass introduced some assembler code for optimizations, processed with yasm.
The configure.ac tested $host for 64 bit so yasm produced 64 bit objects, leading to the error message. I explicitely set --host=i686-linux-gnu for configure to fix that.

Other tools also use yasm, but the configure script of ffmpeg and such are a bit more intelligent in that regard, I guess.
An easier option would be --disable-asm, but that also disables the performance optimizations.

GordonGR commented on 2015-06-25 12:09

I'm not completely sure what you did, but thank you, it's been driving me insane. I've been trying to build this package since its update in [extra].

FadeMind commented on 2015-06-24 16:35

lib32-libass 0.12.2-2 built fine. Thanks.

JonnyJD commented on 2015-06-24 16:15

@FadeMind:
Try again, I just removed a workaround where I patched configure.ac

@GordonGR and others:
I fixed the YASM problem mentioned below and updated to 0.12.2

FadeMind commented on 2015-06-24 16:11

Unable to build. Missing aclocal-1.14.

full log: https://pastebin.com/YhmzaXcT

GordonGR commented on 2014-10-29 13:20

Joseph: I do, yes.
JDaff: Thank you.

JDaff commented on 2014-10-28 22:05

OK for the moment I took it back to its original package because when I made the change i did not have an issue with it. I will be working on it so that it will be ready for the 0.12.0 version. Sorry about the brokeness.

coldBug commented on 2014-10-28 18:48

Hi josephgbr, i get exactly the same error message and have all three multilib-devel packages installed!

All comments