Package Details: lib32-libbluray 1.0.2-1

Git Clone URL: https://aur.archlinux.org/lib32-libbluray.git (read-only)
Package Base: lib32-libbluray
Description: Library to access Blu-Ray disks for video playback (32 bit)
Upstream URL: http://www.videolan.org/developers/libbluray.html
Licenses: LGPL2.1
Provides: libbluray.so
Submitter: rafaelff
Maintainer: makikatze
Last Packager: makikatze
Votes: 15
Popularity: 0.444443
First Submitted: 2012-11-02 16:50
Last Updated: 2018-01-30 18:32

Required by (10)

Sources (1)

Latest Comments

unknown78 commented on 2018-02-19 20:01

javac -version javac 1.8.0_144

javac32 -version javac 1.8.0_162

archlinux-java status Available Java environments: java-7-openjdk java-8-openjdk (default)

archlinux-java32 status Available 32-bit Java environments: java32-7-jdk java32-8-jdk (default)

all is set correctly as far as i know.

makikatze commented on 2018-02-17 11:13

@unknown78 Are you sure you are using JDK8 to compile the package? It seems like you are still using JDK7 and that does not work.

I don't know why "java-environment=8" does not work correctly (it should forbid JDK7 and JDK9 for this package, but it apparently doesn't). For now, you need JDK8 to build this.

You can use "javac -version" to see what version of the JDK you have.

unknown78 commented on 2018-02-17 10:51

Currently this package doesn't build neither with jdk7 or jdk8

http://termbin.com/et6n

gbs commented on 2015-02-04 14:24

Updated for new source url.

asagor commented on 2015-01-22 11:13

sha512sums are incorrect, please repack it

JDaff commented on 2014-10-28 08:03

changed protocol from ftp to http

JDaff commented on 2014-10-28 07:49

Updated to 0.6.0

JDaff commented on 2014-10-28 07:34

Changed the protocol to http instead of ftp because ftp was broken.

rafaelff commented on 2013-06-06 02:13

Updated to 0.3.0-1. Java support removed, just like in official repository.

rafaelff commented on 2012-11-06 20:38

@Chinoisfurax: Done, but be advised that 1) Arch Linux developers don't build 'libbluray' using oracle jdk, but keep it as optdepends, and 2) I don't use oracle jdk and therefore I cannot be sure it will work. Having that said, good luck.

mrozanc commented on 2012-11-06 19:49

The makedepends should include "java-environment" and not "jdk7-openjdk" for compatibility with oracle jdk.