Package Details: lib32-libbsd 0.8.3-1

Git Clone URL: https://aur.archlinux.org/lib32-libbsd.git (read-only)
Package Base: lib32-libbsd
Description: Provides useful functions commonly found on BSD systems like strlcpy()
Upstream URL: http://libbsd.freedesktop.org
Licenses: custom
Submitter: rafaelff
Maintainer: alucryd
Last Packager: alucryd
Votes: 30
Popularity: 1.176684
First Submitted: 2013-04-12 14:06
Last Updated: 2016-09-04 10:27

Latest Comments

bobi commented on 2015-12-14 10:00

As keeping this package out-of-date prevents extra/libbsd being updated for more than a week now, please update PKGBUILD to this: http://paste.pound-python.org/show/OyKyDJKFo9VTw8fEhoAw/

Thank you.

rafaelff commented on 2013-09-29 22:09

Ops. Fixed in 0.6.0-2.

arcanis commented on 2013-09-29 22:05

please add 'gcc-multilib' to makedeps

rafaelff commented on 2013-04-22 19:49

Do you have 'gcc-multilib' installed?

timofonic commented on 2013-04-22 19:14

Edit lib32-libbsd PKGBUILD with $EDITOR? [Y/n] n
==> Making package: lib32-libbsd 0.4.2-1 (Mon Apr 22 21:11:14 CEST 2013)
==> Checking runtime dependencies...
warning: config file /etc/pacman.conf, line 19: directive 'SyncFirst' in section 'options' not recognized.
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Found libbsd-0.4.2.tar.gz
==> Validating source files with md5sums...
libbsd-0.4.2.tar.gz ... Passed
==> Extracting sources...
-> Extracting libbsd-0.4.2.tar.gz with bsdtar
bsdtar: Failed to set default locale
==> Removing existing pkg/ directory...
==> Starting build()...
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /usr/bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking for style of include used by make... GNU
checking for gcc... gcc -m32
checking whether the C compiler works... no
configure: error: in `/tmp/packerbuild-0/lib32-libbsd/lib32-libbsd/src/libbsd-0.4.2':
configure: error: C compiler cannot create executables
See `config.log' for more details
==> ERROR: A failure occurred in build().
Aborting...
The build failed.
Dependencies for `lib32-libwbclient' are not met, not building...