Package Details: lib32-libjpeg6-turbo 1.5.0-1

Git Clone URL: https://aur.archlinux.org/lib32-libjpeg6-turbo.git (read-only)
Package Base: lib32-libjpeg6-turbo
Description: libjpeg derivative with accelerated baseline JPEG compression and decompression
Upstream URL: http://libjpeg-turbo.virtualgl.org/
Licenses: BSD
Conflicts: lib32-libjpeg6
Provides: lib32-libjpeg6
Submitter: BertiBoeller
Maintainer: alucryd
Last Packager: alucryd
Votes: 398
Popularity: 36.849702
First Submitted: 2011-12-04 00:50
Last Updated: 2016-07-23 11:12

Latest Comments

alex.theoto commented on 2016-07-27 10:19

With this update, you have the same version as the arch repositories has.
I don't know if you want to keep the 4.2 version for dependency of other programs, or to remove this package.

b52 commented on 2016-07-13 16:20

Here is a PKGBUILD for 1.5.0:
https://paste.xinu.at/dsXe/

@Cysioland: This is probably due to sourceforge having issues to deliver the binaries. If you download them manually it works most of the time, by going through the web interface.

Cysioland commented on 2016-07-13 09:52

sha256 checksum for libjpeg-turbo-1.4.2.tar.gz doesn't match.

alucryd commented on 2016-06-06 08:46

@roadev: Comment deleted, the AUR is not your personal pastebin. Also, RTFM: https://wiki.archlinux.org/index.php/Arch_User_Repository#Getting_started

alucryd commented on 2016-05-30 15:15

I can't, you're supposed to provide logs in English, with the meaningful part of the log, if in doubt the whole log, and use an external paste service, please keep the comment section clean.

comgunner commented on 2016-05-13 20:28

Could you help me?

Makefile:1987: fallo en las instrucciones para el objetivo 'install-recursive'
make: *** [install-recursive] Error 1
==> ERROR: Se produjo un fallo en package().

alucryd commented on 2015-06-14 07:07

Oh my bad, I had this package confused with another one. Thanks, bumped to 1.4.1.

Det commented on 2015-06-13 22:59

True, they do, but from the configure script:

 --with-jpeg7     Emulate libjpeg v7 API/ABI (this makes libjpeg-turbo
              backward incompatible with libjpeg v6b.)
 --with-jpeg8     Emulate libjpeg v8 API/ABI (this makes libjpeg-turbo
              backward incompatible with libjpeg v6b.)

The file sizes are also different (lib32-libjpeg6-turbo v1.3.1):

└┌(%:~/Desktop/lib32-libjpeg6-turbo)┌- du -b /usr/lib32/libjpeg.so.62.1.0
289424 /usr/lib/libjpeg.so.62.1.0

vs. (lib32-libjpeg6-turbo v1.4.1):

└┌(%:~/Desktop/lib32-libjpeg6-turbo)┌- du -b /usr/lib32/libjpeg.so.62.1.0
313004 /usr/lib32/libjpeg.so.62.1.0

So I'm thinking there are some new features and/or improvements included, but the core ABI itself is compatible with v6. Would you agree with this?

alucryd commented on 2015-06-13 21:07

The libjpeg6-turbo package shouldn't have been bumped to 1.4.x. 1.4.x releases provide libjpeg8.

Det commented on 2015-06-13 20:43

I missed that (though your comment made me lol), however, libjpeg6-turbo has been updated to 1.4.1, so is that because of the main binaries (which are not included in this one) or something like that?: https://aur4.archlinux.org/packages/libjpeg6-turbo/

All comments