Package Details: lib32-libusb-compat 0.1.5-3

Git Clone URL: https://aur.archlinux.org/lib32-libusb-compat.git (read-only)
Package Base: lib32-libusb-compat
Description: Library to enable user space application programs to communicate with USB devices (32 bit)
Upstream URL: http://libusb.sourceforge.net/
Licenses: LGPL
Submitter: lordheavy
Maintainer: twa022
Last Packager: twa022
Votes: 88
Popularity: 0.649060
First Submitted: 2012-02-08 20:35
Last Updated: 2016-05-23 20:56

Latest Comments

« First ‹ Previous 1 2

jtts commented on 2012-10-11 04:39

Since libusbx commit 7ec94a45ed8155e7a1d4d5d75575099b09c7883 usbi_log_level no longer conflicts with libusb.h. And since both core repository and AUR have moved to libusbx and lib32-libusbx versions >= 1.0.13 the patch "fix-core.patch" is no longer needed.

source:
https://github.com/libusbx/libusbx/commit/7ec94a45ed8155e7a1d4d5d75575099b09c78834

jtts commented on 2012-10-11 04:38

Since libusbx commit 7ec94a45ed8155e7a1d4d5d75575099b09c7883 usbi_log_level no longer conflicts with libusb.h. And since both core repository and AUR have moved to libusbx and lib32-libusbx versions >= 1.0.13, the patch "fix-core.patch" is no longer needed.

source:
https://github.com/libusbx/libusbx/commit/7ec94a45ed8155e7a1d4d5d75575099b09c78834


rafaelff commented on 2012-06-26 22:51

@tanuva: Probably related to the change of libusb to libusbx... Thanks, fixed in 0.1.4-2

tanuva commented on 2012-06-26 18:21

Doesn't build here with this error:
http://pastebin.com/m6ngU56Z
Removing the enum from core.c and building manually works.

lordheavy commented on 2012-02-08 20:35

Moved from multilib to unsupported