Package Details: lib32-libwbclient 4.7.1-2

Git Clone URL: https://aur.archlinux.org/lib32-smbclient.git (read-only)
Package Base: lib32-smbclient
Description: Samba winbind client library
Upstream URL: http://www.samba.org
Licenses: GPL3
Submitter: rafaelff
Maintainer: rafaelff
Last Packager: rafaelff
Votes: 20
Popularity: 2.038895
First Submitted: 2015-06-11 14:22
Last Updated: 2017-11-21 12:41

Latest Comments

yannleretaille commented on 2017-11-21 11:35

@rafaelff, @matoro: As I wrote before, you have to add lib32-jansson as additional dependency! (example of PKGBUILD: https://gist.github.com/yannleretaille/093c4b8bc6037eeaaacf3a8bf765b53b )

matoro commented on 2017-11-20 19:16

Yup, I'm seeing the same issue now. Issue seems linking-related and everything seems to be from this json stuff. Probably going to have to dive into source. Have you compared against x86_64 smbclient PKGBUILD?

rafaelff commented on 2017-11-20 17:09

I updated to 4.7.1, but I'm unable to build it (see log: https://ptpb.pw/Zoa5). Can you guys please check if the same happens to you?

aristaeus commented on 2017-11-20 06:10

FYI, lib32-tdb just got an update. I spent an hour yesterday compiling AUR packages just to realise this one is broken. Hope you can fix it soon!

rafaelff commented on 2017-11-18 11:05

@sylvr: At the moment, the versions you mentioned aren't even the official repository yet. Chill out :)

I maintain lib32-(ldb,tevent,smbclient), which depend on lib32-tdb. The biggest problem now is the outdated version of lib32-tdb, which is in a official repository so I can't request disown.

I emailed the maintainer some time ago, but got no reply. I just don't like bother much TUs and Developers with update request to avoid receiving replies like "Package updates will be released when they are ready." (https://wiki.archlinux.org/index.php/Frequently_asked_questions#Upstream_project_X_has_released_a_new_version._How_long_will_it_take_for_the_Arch_package_to_update_to_that_new_version.3F)

sylvr commented on 2017-11-17 09:29

Had to build it myself along with (in dependency order) :
- lib32-tdb 1.3.15
- lib32-ldb 1.3.0
- lib32-tevent 0.9.34
- lib32-smbclient 4.7.2

Shouldn't we do something for outdated packages ? What's about taking over the maintainer or at least add a deputy ?

EDIT: I mean, not you rafaelff, but the other outdated packages with inactive/unresponsive maintainers.

yannleretaille commented on 2017-11-16 02:21

just built version 2.7.1 of this (and all dependencies) manually to get it working and it seems that lib32-jansson is a required dependency

rafaelff commented on 2017-11-06 14:18

I don't know a workaround for this issue. This software relies on specific version to compile, not allowing dependencies with previous version. I even emailed the maintainer, but got no reply.

digibucc commented on 2017-11-04 23:39

so is there a way around this? I tried downgrading samba but it doesn't seem to recognize that as i still get the 4.7 error.

locallycompact commented on 2017-10-18 09:22

Why not? Clearly if it's blocking a fix there should be a way to do this?

All comments