Package Details: lib32-mesa-git 21.0.0_devel.133382.735b808639b-1

Git Clone URL: https://aur.archlinux.org/lib32-mesa-git.git (read-only, click to copy)
Package Base: lib32-mesa-git
Description: an open-source implementation of the OpenGL specification, git version
Upstream URL: https://www.mesa3d.org
Licenses: custom
Conflicts: lib32-libva-mesa-driver, lib32-mesa, lib32-mesa-vdpau, lib32-vulkan-intel, lib32-vulkan-radeon
Provides: lib32-libva-mesa-driver, lib32-mesa, lib32-mesa-vdpau, lib32-opengl-driver, lib32-vulkan-driver, lib32-vulkan-intel, lib32-vulkan-radeon
Submitter: None
Maintainer: Lone_Wolf
Last Packager: Lone_Wolf
Votes: 39
Popularity: 0.088747
First Submitted: 2009-12-18 18:42
Last Updated: 2021-01-13 12:19

Required by (89)

Sources (3)

Pinned Comments

Lone_Wolf commented on 2019-05-09 13:30

This package now uses an environment variable to determine which llvm package it will be built against. Check PKGBUILD for details.

Latest Comments

« First ‹ Previous ... 3 4 5 6 7 8 9 10 11 12 13 ... Next › Last »

ibrokemypie commented on 2018-08-04 12:27

Seems to conflict with mesa-git error: failed to commit transaction (conflicting files) lib32-mesa-git: /usr/bin/intel_dump_gpu exists in filesystem (owned by mesa-git) lib32-mesa-git: /usr/bin/intel_sanitize_gpu exists in filesystem (owned by mesa-git)

C0rn3j commented on 2018-05-27 08:33

Thanks for a quick fix, removing the packages wasn't needed, keep up being an awesome maintainer ^^

Lone_Wolf commented on 2018-05-26 13:43

It's been updated with those changes, C0rn3j .

Incase you're not building in a clean chroot, you may have to remove installed lib32-mesa or lib32-mesa-git with -Rdd .

C0rn3j commented on 2018-05-26 11:01

https://git.archlinux.org/svntogit/community.git/commit/trunk?h=packages/lib32-mesa&id=b8ca1f1154b4d669c0830f89a00e74fbdff32303

https://bugs.archlinux.org/task/58725

Can't do a -Syu because this package needs a patch ^^

aufkrawall commented on 2018-03-09 16:42

Thanks, works now (after radv got fixed).

Lone_Wolf commented on 2018-03-08 23:05

added valgrind as new makedepend

Lone_Wolf commented on 2018-03-08 22:26

confirmed, looks like mesa-git now needs valgrind installed to correctly detect libdrm version. Investigating

aufkrawall commented on 2018-03-08 11:02

Build fails with "configure: error: Direct rendering requires libdrm >= 2.4.75" despite 2.4.91 installed (also lib32).

Lone_Wolf commented on 2017-09-11 12:52

@gnanini :

./.libs/libEGL_common.a(platform_drm.o): In function `swrast_put_image2':
platform_drm.c:(.text+0xa89): undefined reference to `gbm_bo_get_bpp'

see my comments from 2017-08-06 .

If all 3 workarounds fail, *including* building in a clean chroot, post full logs.

gnanini commented on 2017-09-10 16:53

I still have the same error, and the alternative method didn't worked!

https://pastebin.com/YCdDqHnq