Package Details: lib32-ncurses5-compat-libs 6.1-2

Git Clone URL: https://aur.archlinux.org/lib32-ncurses5-compat-libs.git (read-only, click to copy)
Package Base: lib32-ncurses5-compat-libs
Description: System V Release 4.0 curses emulation library (32-bit), ABI 5
Upstream URL: https://www.gnu.org/software/ncurses/
Licenses: MIT
Submitter: lpapp
Maintainer: Corax
Last Packager: Corax
Votes: 95
Popularity: 1.64
First Submitted: 2015-09-22 11:38
Last Updated: 2019-03-07 22:49

Pinned Comments

Corax commented on 2019-06-10 18:11

Make sure you have the multilib-devel group installed before reporting issues while building the package. I will not add it as a makedepends because it is not a makedepends for lib32-ncurses5 either. See https://wiki.archlinux.org/index.php/Makepkg#Build_32-bit_packages_on_a_64-bit_system

Corax commented on 2016-08-19 23:33

If anyone is still having trouble getting used to PGP signing, make sure to add the key mentioned in the PKGBUILD:
$ gpg --keyserver pool.sks-keyservers.net --recv-keys 702353E0F7E48EDB

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 Next › Last »

binaryshadow commented on 2016-08-18 06:07

no, i delete .asc file and edit pkgbuild =)

Corax commented on 2016-08-17 21:25

Not sure what the problem is, did you try adding the key at all?...
$ gpg --recv-keys 702353E0F7E48EDB

binaryshadow commented on 2016-08-17 10:57

Will need to correct ncurses-6.0.tar.gz.asc and signature

binaryshadow commented on 2016-08-17 10:15

need add pgp key?

ncurses-6.0.tar.gz... FAILURE (unknown open key 702353E0F7E48EDB)
==> ERROR: One or more PGP signatures can't be checked!
==> ERROR: Makepkg couldn't collect lib32-ncurses5-compat-libs.

Corax commented on 2016-08-04 21:06

@mky: indeed, this is consistent with the other ncurses packages. Hopefully by now people have got used to adding keys!

mky commented on 2016-08-04 02:55

To add the corresponding key, still need to receieve the keys:
gpg --recv-keys F7E48EDB

After that, it works fine!

Corax commented on 2016-07-07 23:37

@tinxy: done in the latest rel (-4), thanks for pointing that out.

-4 also provides a libtinfo symlink, like ncurses5-compat-libs. This was a good move, having a separate package for a symlink is kind of overkill.

tinxy commented on 2016-07-06 18:49

Please add pgp verification as seen in:

https://aur.archlinux.org/packages/ncurses5-compat-libs/

Corax commented on 2016-02-19 09:41

Just adopted the package. I fixed outstanding issues and cleaned up the PKGBUILD, take a look at the last commit for more info.

alexzk commented on 2016-01-13 11:18

This one function works (must be ncurse 6 installed already), at least android-sdk goes:

#conflicts=("lib32-ncurses")
#provides=("lib32-ncurses")

........

package() {
cd ${srcdir}/ncursesw-build
make install
install -dm755 ${pkgdir}/usr/lib32

# non-widec compatibility libraries
cd ${srcdir}/ncurses-build
for lib in ncurses form panel menu; do
install -Dm755 lib/lib${lib}.so.${_compatpkgver} ${pkgdir}/usr/lib32/lib${lib}.so.${_compatpkgver}
ln -s lib${lib}.so.${_compatpkgver} ${pkgdir}/usr/lib32/lib${lib}.so.5
done

rm -rf "${pkgdir}"/usr/{include,share,bin}
mkdir -p "$pkgdir/usr/share/licenses"
ln -s $_pkgbasename "$pkgdir/usr/share/licenses/$pkgname"
cd $pkgdir/usr/lib32/
find . -iname "*.so" -delete && find . -iname "*.a" -delete
}