Package Details: lib32-nvidia-utils-full-beta-all 390.42-1

Git Clone URL: (read-only)
Package Base: nvidia-full-beta-all
Description: NVIDIA driver utilities and libraries for 'nvidia-full-beta-all' (32-bit)
Upstream URL:
Keywords: lib32-opencl-driver lib32-vulkan-driver libglvnd nvidia-settings opencl-driver vulkan-driver
Licenses: custom:NVIDIA
Conflicts: lib32-libglvnd, lib32-nvidia-utils
Provides: lib32-libglvnd, lib32-nvidia-utils=390.42, lib32-vulkan-driver
Submitter: Det
Maintainer: Det
Last Packager: Det
Votes: 24
Popularity: 0.839599
First Submitted: 2013-06-27 12:48
Last Updated: 2018-03-13 08:25

Latest Comments

Det commented on 2018-03-13 08:25

Huh. So that happened.

ronoverdrive commented on 2018-03-13 03:38

Getting this error.

==> Starting package_lib32-nvidia-utils-full-beta-all()... install: cannot stat '32/': No such file or directory ==> ERROR: A failure occurred in package_lib32-nvidia-utils-full-beta-all(). Aborting... :: Unable to build nvidia-utils-full-beta-all - makepkg exited with code: 2

kerjava commented on 2018-02-27 17:47

@det i had that in the past though with the base line current nvidia driver this one fixed it for me

edit: also the specific package im talking about is lib32-opencl-nvidia-full-beta-all

Det commented on 2018-02-27 00:40



kerjava commented on 2018-02-26 23:04

for me this package seem to have an interesting endless cleaning issue it gets though the build then after goes to clean up but never seems to stop cleaning and move on (<-is newbie) any thoughts on how to get past this ?

is what i think the interesting output is but idk for sure

Det commented on 2018-02-04 20:07

That's semi self-explanatory an error? 4.4.15 ( was compiled with 7.2.x, but GCC was updated to 7.3.0 two days ago (

Didn't know that would lead to "subtle bugs that are difficult to diagnose", but either downgrade GCC, or upgrade to testing/linux:

E: Btw, generally maybe a bit unusual to be using a non-testing kernel and a yes-testing driver, but maybe that's just me.

D-Worak commented on 2018-02-04 18:42

make[1]: Entering directory '/usr/lib/modules/4.14.15-1-ARCH/build'

Compiler version check failed:

The major and minor number of the compiler used to <br> compile the kernel:

gcc version 7.2.1 20180116 (GCC)

does not match the compiler used here:

cc (GCC) 7.3.0 <br> Copyright (C) 2017 Free Software Foundation, Inc. <br> This is free software; see the source for copying conditions. There is NO <br> warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

It is recommended to set the CC environment variable <br> to the compiler that was used to compile the kernel.

The compiler version check can be disabled by setting <br> the IGNORE_CC_MISMATCH environment variable to "1". <br> However, mixing compiler versions between the kernel <br> and kernel modules can result in subtle bugs that are <br> difficult to diagnose.

Failed CC version check. Bailing out!

make[2]: [/tmp/yaourt-tmp-denis/aur-nvidia-full-beta/src/NVIDIA-Linux-x86_64-390.25-no-compat32/kernel/Kbuild:180: cc_version_check] Error 1 <br> make[1]: [Makefile:1507: module/tmp/yaourt-tmp-denis/aur-nvidia-full-beta/src/NVIDIA-Linux-x86_64-390.25-no-compat32/kernel] Error 2 <br> make[1]: Leaving directory '/usr/lib/modules/4.14.15-1-ARCH/build' <br> make: *** [Makefile:79: modules] Error 2

Det commented on 2018-01-07 21:44

It's the same PKGBUILD for the whole thing, no you can't change it for an individual one, nor do you really want to install the lib32-* ones directly.

Just change the 0 to 1, and it'll update all the packages in the future until you remove them.

cadence commented on 2018-01-07 21:42


The PKGBUILD for this package has the _lib32 flag on line 7 set to zero by default. This results in only the non-32bit nvidia packages being installed.

Since this is the lib32 package, this should changed to : "_lib32=1" by default.

Once this flag is set to 1 the lib32 package installs perfectly.

Thank you!

Det commented on 2017-12-08 14:18

Well, my automation takes patches in the form of linux-[kernel version].patch, e.g. linux-4.15.patch

All comments