Package Details: lib32-python2 2.7.18-3

Git Clone URL: https://aur.archlinux.org/lib32-python2.git (read-only, click to copy)
Package Base: lib32-python2
Description: A high-level scripting language (32 bit)
Upstream URL: https://www.python.org/
Keywords: python2
Licenses: PSF
Conflicts: lib32-python
Submitter: ImNtReal
Maintainer: libele
Last Packager: libele
Votes: 38
Popularity: 0.000000
First Submitted: 2012-12-14 19:36 (UTC)
Last Updated: 2022-07-22 02:52 (UTC)

Latest Comments

rafaelff commented on 2019-01-12 12:44 (UTC)

I'm disowning this package because I maintained due to lib32-smbclient, which I just disowned.

rafaelff commented on 2018-08-15 23:05 (UTC)

I updated to 2.7.15. I notice a few error messages, although I don't know how it affects the use of this package. Feedbacks are welcome.

whynothugo commented on 2016-12-25 12:25 (UTC) (edited on 2016-12-25 12:26 (UTC) by whynothugo)

I've made python2 an optional dependency, since it's not even required all the time. First-time users that don't use [testing] but use AUR AND need to build something that depends on its sources will have to manually build an older version. This should make the PKGBUILD work for almost every case out there. Other will have to hand edit it. Note that AUR is even less supported that [testing], so there's really no reason to use the former but avoide the latter.

GordonGR commented on 2016-12-25 11:55 (UTC)

And what if they are installing it now for the first time? I say people with [testing] could maintain a local copy themselves. Anyway, I'm not pursuing a flame here, just stating my opinion.

whynothugo commented on 2016-12-23 15:23 (UTC)

That should be a non-issue, actually. Users that don't have [testing] enabled won't get the update for this package until python 2.7.13 hits stable. In the meantime, the previously installed version will work for them.

GordonGR commented on 2016-12-23 14:19 (UTC)

I agree with Rafael. Since only a small percentage of people use [testing], I don't think it is a good idea to assume everyone does. If I were you, hobarrera, I would simply downgrade.

whynothugo commented on 2016-12-23 14:01 (UTC)

I'm thinking the best compromise might be to unpin the required python2 version (we can revert it if there are any objections).

rafaelff commented on 2016-12-23 13:48 (UTC)

@hobarrera: well, the non-lib32 may provide some files that are needed for some depedencies. For example, I experienced some packages that would build only if its depedencies' headers (files in /usr/include) are available; therefore, both lib32 and non-lib32 dependencies had to be installed. I don't know if that's the case of lib32-python2.

whynothugo commented on 2016-12-23 13:17 (UTC)

@rafaelff: Oh, thanks, I'll keep that in mind. I'm wondering though, why *does* this package depend on python2?

rafaelff commented on 2016-12-23 13:12 (UTC) (edited on 2016-12-23 13:44 (UTC) by rafaelff)

@hobarrera: You updated this package requiring python2 version equal or higher than 2.7.13, which is currently version of python in [testing] repository. Since some users don't use such repository, please consider avoid updating to the version available only in there. Because of that, all packages that depend on this package will be put on hold.. anyway, thanks for adopting and maintaining it.

aviallon commented on 2016-11-11 11:26 (UTC)

You just have to change sqlite3 in PKGBUILD to sqlite, and then it'll compile without any errors.

aaronp commented on 2016-10-25 02:50 (UTC)

Looks like lib32-sqlite no longer provides lib32-sqlite3, so this package should just depend on the former.

FadeMind commented on 2016-05-14 19:37 (UTC)

Package was build fine on my setup. @marcio Rebuild first all depends: lib32-tcl lib32-tk lib32-gdbm and lib32-python2 at the end.

marcio commented on 2016-05-14 18:32 (UTC)

Problem compiling it... Modules/posixmodule.o: In function `posix_tempnam': /tmp/yaourt-tmp-marcio/aur-lib32-python2/src/Python-2.7.11/./Modules/posixmodule.c:7578: warning: the use of `tempnam' is dangerous, better use `mkstemp' gcc -m32 -m32 -Xlinker -export-dynamic -o python-32 \ Modules/python.o \ -L. -lpython2.7 -ldl -lutil -lm ./libpython2.7.so: undefined reference to `pthread_detach' ./libpython2.7.so: undefined reference to `sem_post' ./libpython2.7.so: undefined reference to `pthread_attr_setstacksize' ./libpython2.7.so: undefined reference to `sem_trywait' ./libpython2.7.so: undefined reference to `sem_wait' ./libpython2.7.so: undefined reference to `sem_init' ./libpython2.7.so: undefined reference to `pthread_create' ./libpython2.7.so: undefined reference to `sem_destroy' collect2: error: ld returned 1 exit status Makefile:485: recipe for target 'python-32' failed make: *** [python-32] Error 1 ==> ERRO: Uma falha ocorreu em build(). Abortando... ==> ERRO: Makepkg não conseguiu compilar lib32-python2. Does anyone know how to solve this?

rafaelff commented on 2016-01-26 00:28 (UTC)

Perfect. Thanks!

FadeMind commented on 2016-01-25 15:48 (UTC)

@josephgbr You have right. Fixed in rev 3.

rafaelff commented on 2016-01-25 14:47 (UTC)

hmm.. wouldn't it be better python2.7-32-config instead of python2.7-32.config (difference: dash "-")? With ".config" it looks like a configuration file.

FadeMind commented on 2016-01-22 17:39 (UTC) (edited on 2016-01-22 17:48 (UTC) by FadeMind)

@josephgbr Done. la /usr/bin/|grep python2-32 lrwxrwxrwx 1 root root 12 22.01.2016 18:31 python2-32 -> python2.7-32* lrwxrwxrwx 1 root root 19 22.01.2016 18:31 python2-32.config -> python2.7-32-config*

rafaelff commented on 2016-01-22 17:05 (UTC)

Can you please add to your PKGBUILD the creation of the symlinks below? /usr/bin/python2-32 -> python2.7-32 /usr/bin/python2-32.config -> python2.7-32.config

davepb commented on 2015-12-10 19:00 (UTC)

I had forgotten about the testing repositories. Thank you for the quick response FadeMind.

FadeMind commented on 2015-12-10 18:26 (UTC)

python2 2.7.11 is already in testing: https://www.archlinux.org/packages/testing/x86_64/python2/ You can download tarball with older 2.7.10: https://aur.archlinux.org/cgit/aur.git/snapshot/aur-21b405ae8e57ee147192c91ea29a72681b498519.tar.gz

davepb commented on 2015-12-10 18:22 (UTC)

Can't build yet. "target not found: python2>=2.7.11" Highest version of python2 I could find was 2.7.10-2 I'm new to Arch so maybe missing something obvious?

FadeMind commented on 2015-04-23 13:22 (UTC)

Package need lastest version of lib32-tcl 8.6.4 PKGBUILD CODE: https://pastebin.com/wjjnkKjL lib32-tk 8.6.4 PKGBUILD CODE: https://pastebin.com/UeZ3VsTf for proper build.

ImNtReal commented on 2015-01-29 18:37 (UTC)

I'm not actually using this as it turns out. Feel free to take it over.

sl1pkn07 commented on 2015-01-29 17:30 (UTC)

please use this pkgbuild https://github.com/quequotion/mmug-qq/blob/master/lib32-python2/PKGBUILD this adds some changes, include preserve the binaries greetings