Package Details: lib32-sdl2-hg 2.0.4.r3.d91a2c45825e-1

Git Clone URL: https://aur.archlinux.org/lib32-sdl2-hg.git (read-only)
Package Base: lib32-sdl2-hg
Description: A library for portable low-level access to video, audio and input (Version 2, 32 bit, development version)
Upstream URL: http://www.libsdl.org
Licenses: zlib
Conflicts: lib32-sdl2
Provides: lib32-sdl2
Submitter: J0k3r
Maintainer: carstene1ns
Last Packager: carstene1ns
Votes: 6
Popularity: 0.000000
First Submitted: 2013-03-05 13:54
Last Updated: 2016-01-03 19:02

Required by (28)

Sources (1)

Latest Comments

gablink commented on 2017-08-16 21:28

Needs lib32-tslib and lib32-libibus in makedepends but the last one isn't on aur

shoober420 commented on 2017-04-24 21:29

Error during compile.

/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-pc-linux-gnu/6.3.1/../../../libibus-1.0.so when searching for -libus-1.0
/usr/bin/ld: skipping incompatible /usr/lib/libibus-1.0.so when searching for -libus-1.0
/usr/bin/ld: cannot find -libus-1.0
collect2: error: ld returned 1 exit status
make[2]: *** [CMakeFiles/SDL2.dir/build.make:3605: libSDL2-2.0.so.0.4.1] Error 1
make[1]: *** [CMakeFiles/Makefile2:105: CMakeFiles/SDL2.dir/all] Error 2
make: *** [Makefile:128: all] Error 2
==> ERROR: A failure occurred in build().
Aborting...

carstene1ns commented on 2015-12-21 22:58

zaps166: Sorry for the inconvenience. It should be fixed now, but I really think this worked before.
Maybe some update to the build configuration caused this.

zaps166 commented on 2015-12-21 14:35

32bit libraries should be in /usr/lib32, but in this package SDL2 installs to /usr/lib

carstene1ns commented on 2014-10-11 08:34

Package adopted and reworked dependencies.

carstene1ns commented on 2014-09-26 22:20

I can take it over, if you want. I already have some related packages...

J0k3r commented on 2014-07-10 19:43

Is anyone willing to take over this package? I no longer want to maintain it ( not that I ever really did :P )

steeno commented on 2014-01-01 01:26

if you dont have wayland isntalled you need to add --disable-video-wayland to configure because it is auto enabled otherwise

J0k3r commented on 2013-08-14 19:57

some cleanup

J0k3r commented on 2013-07-27 23:15

fixed, would have been nice if someone notified me about the existence of this package before :/

All comments