Package Details: lib32-vulkan-amdgpu-pro 23.40_1718238-1

Git Clone URL: https://aur.archlinux.org/amdgpu-pro-installer.git (read-only, click to copy)
Package Base: amdgpu-pro-installer
Description: AMDGPU Pro Vulkan driver (32-bit)
Upstream URL: https://www.amd.com/en/support/kb/release-notes/rn-amdgpu-unified-linux-22-40
Licenses: custom: AMDGPU-PRO EULA
Groups: Radeon_Software_for_Linux
Provides: lib32-vulkan-driver
Submitter: LEW21
Maintainer: Ashark (mesmer)
Last Packager: mesmer
Votes: 123
Popularity: 2.52
First Submitted: 2016-03-28 22:44 (UTC)
Last Updated: 2024-02-12 13:57 (UTC)

Dependencies (4)

Required by (3)

Sources (18)

Pinned Comments

mesmer commented on 2022-12-23 04:31 (UTC) (edited on 2023-05-28 19:28 (UTC) by mesmer)

IF PROBLEM HAPPEN

this package is our try to put amdgpu in ARCH, but this could break or have problems as amd update and change their packages for ubuntu

if anything happens you can always download a older tag in https://github.com/Ashark/archlinux-amdgpu-pro/releases and get the PKGBUILD there, and use makepkg with that build while we update or try to fix :)

ALWAYS USE LINUX-FIRMWARE-GIT IF LATEST DRIVER FAIL BEFORE ISSUE SOME ERROR

https://aur.archlinux.org/packages/linux-firmware-git

Ashark commented on 2019-12-09 20:52 (UTC) (edited on 2022-12-06 08:45 (UTC) by Ashark)

PKGBUILD generator is located here: https://github.com/Ashark/archlinux-amdgpu-pro

AMDGPU PRO wiki page: https://wiki.archlinux.org/index.php/AMDGPU_PRO

New versions will appear here: https://repo.radeon.com/amdgpu/.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 .. 57 Next › Last »

rokero commented on 2023-07-30 21:17 (UTC)

progl glxinfo /usr/bin/progl: línea 30: 24808 Violación de segmento (`core' generado) "$@" I have this error every time I try to start

hydrocryo01 commented on 2023-07-09 21:03 (UTC)

@mesmer I can confirm everything's working except the av1 encoder. linux-firmware-git is not required. The problem of the av1 encoder is that the system freezes as soon as I start recording, and it happens on both wlroots(Hyprland) and kwin. Last version has this problem too.

mesmer commented on 2023-07-09 01:22 (UTC)

In 7/6/2023 a version 23.10-1610704.22.04 is out, any 7000 series that can test i think this version? it fixed the need for linux-firmware-git (at least for me)

also: version 5.6 is being worked https://repo.radeon.com/amdgpu/5.6/ but i cannot add that here yet because the package file is empty for now https://repo.radeon.com/amdgpu/5.6/ubuntu/dists/jammy/proprietary/binary-amd64/Packages but keep int ouch i think next week a minor will be released

mesmer commented on 2023-05-28 19:22 (UTC)

new version released, seems that it needs the linux-firmware-git for now, but tested only in 6900 card

and fixed openssl dependency

mesmer commented on 2023-05-22 00:31 (UTC)

@joaoMachado i get this download done ok https://repo.radeon.com/amdgpu/5.4.5/ubuntu/pool/proprietary/o/oglp-amdgpu-pro/libegl1-amdgpu-pro-oglp_22.40-1577631.22.04_i386.deb try to download that in your browser

JoaoMachado commented on 2023-05-21 19:08 (UTC)

Can't seem to install, keep getting the following error:


Preparing...
Checking amf-amdgpu-pro dependencies...
Checking vulkan-amdgpu-pro dependencies...
Resolving dependencies...
Checking inter-conflicts...

Building amdgpu-pro-installer...
==> Making package: amdgpu-pro-installer 22.40_1577631-1 (Sun 21 May 2023 11:59:29 AM PDT)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found progl
  -> Found progl.bash-completion
  -> Found amf-amdgpu-pro_1.4.29-1577631.22.04_amd64.deb
  -> Found libamdenc-amdgpu-pro_1.0-1577631.22.04_amd64.deb
  -> Downloading libegl1-amdgpu-pro-oglp_22.40-1577631.22.04_i386.deb...
** Resuming transfer from byte position 13700
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0   222    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
curl: (22) The requested URL returned error: 416
==> ERROR: Failure while downloading https://repo.radeon.com/amdgpu/5.4.5/ubuntu/pool/proprietary/o/oglp-amdgpu-pro/libegl1-amdgpu-pro-oglp_22.40-1577631.22.04_i386.deb
    Aborting...
Failed to build amdgpu-pro-installer

PlaidCat commented on 2023-04-29 19:23 (UTC) (edited on 2023-04-29 19:26 (UTC) by PlaidCat)

@mesmer

Yup forgot to regenerate the mkinitcpio, the kernel update today regenerated it and its back to not working. :\

I will check in to the GitHub

mesmer commented on 2023-04-29 04:41 (UTC) (edited on 2023-04-29 04:51 (UTC) by mesmer)

@plaidcat idk if you gonna read these, but if you read can you go to GitHub and help with debug this? Another user with 7900 is having trouble, did you mkinitcpio the firmware?

If another 7000 user could help to get it will be great

PlaidCat commented on 2023-04-28 01:51 (UTC) (edited on 2023-04-29 19:34 (UTC) by PlaidCat)

@mesmer -Can confirm working- Edit: Not working

redacted because I was wrong

mesmer commented on 2023-04-27 20:28 (UTC)

22.40_1577631-1 version 5.4.5 is updated, anyone with 7000 series can test if this fixes the firmware issue?