Package Details: lib32-wxgtk3 3.0.5.1-2

Git Clone URL: https://aur.archlinux.org/lib32-wxgtk3.git (read-only, click to copy)
Package Base: lib32-wxgtk3
Description: GTK+ implementation of wxWidgets API for GUI
Upstream URL: https://wxwidgets.org
Licenses: custom:wxWindows
Conflicts: lib32-wxgtk
Provides: lib32-wxgtk
Replaces: lib32-wxgtk
Submitter: heavysink
Maintainer: heavysink
Last Packager: heavysink
Votes: 1
Popularity: 0.015510
First Submitted: 2020-09-25 01:22
Last Updated: 2020-09-25 01:22

Latest Comments

rafaelff commented on 2021-05-03 00:01

@Yue_Kuze: No need for commands. Just look in the PKGBUILD for the contents of lines starting with - in my diff, and replace with the contents of lines starting with +

Yue_Kuze commented on 2021-05-01 07:24

@rafaelff

Hello, im kinda newbie to commands, but i try to run your PKGBUILD and got the following

[xxx@xxx trunk]$ makepkg

diff: unrecognized option '--git'

diff: Try 'diff --help' for more information.

/lib32-wxgtk3/trunk/PKGBUILD: line 3: index: command not found

/lib32-wxgtk3/trunk/PKGBUILD: line 4: ---: command not found

/lib32-wxgtk3/trunk/PKGBUILD: line 5: +++: command not found

/lib32-wxgtk3/trunk/PKGBUILD: line 6: @@: command not found

/lib32-wxgtk3/trunk/PKGBUILD: line 10: -pkgver=3.24.27: command not found

/lib32-wxgtk3/trunk/PKGBUILD: line 11: -pkgrel=2: command not found

/lib32-wxgtk3/trunk/PKGBUILD: line 12: +pkgver=3.24.29: command not found

/lib32-wxgtk3/trunk/PKGBUILD: line 13: +pkgrel=1: command not found

/lib32-wxgtk3/trunk/PKGBUILD: line 17: syntax error near unexpected token `('

/lib32-wxgtk3/trunk/PKGBUILD: line 17: `@@ -40,7 +40,7 @@ makedepends=('

==> ERROR: Failed to source /lib32-wxgtk3/trunk/PKGBUILD

rafaelff commented on 2021-04-28 00:30

@Frogboy: The reason for failed build is: The versions of gtk3 and lib32-gtk3 must match, however currently gtk3 is 3.24.29 and lib32-gtk3 is 3.24.27.

lib32-gtk3 is already flagged as out of date, so there is not much to do besides updating the PKGBUILD locally and then building and installing the package. By updating your lib32-gtk3, lib32-wxgtk3 should build fine.

To fix it:
Use asp to clone the source repository for lib32-gtk3 (see ABS#Usage), then apply the changes specified by my diff below to your local lib32-gtk3 PKGBUILD, build lib32-gtk3 with those changes and use the newly built lib32-gtk3 to build lib32-wxgtk3.

Here is my lib32-gtk3 update:

diff --git a/trunk/PKGBUILD b/trunk/PKGBUILD
index 284ddded3..e665bdaac 100644
--- a/trunk/PKGBUILD
+++ b/trunk/PKGBUILD
@@ -3,8 +3,8 @@
 # Contributor: GordonGR <ntheo1979@gmail.com>

 pkgname=lib32-gtk3
-pkgver=3.24.27
-pkgrel=2
+pkgver=3.24.29
+pkgrel=1
 pkgdesc='GObject-based multi-platform GUI toolkit'
 arch=(x86_64)
 license=(LGPL)
@@ -40,7 +40,7 @@ makedepends=(
   sassc
 )
 install=lib32-gtk3.install
-_tag=c7df3b9e9790012e6c5fbad6a4f4519bcf75561f
+_tag=77f32a69c0a35ffd3a1a542a6057c1c6d13c793d
 source=(
   git+https://gitlab.gnome.org/GNOME/gtk.git#tag=${_tag}
   gtk-query-immodules-3.0-32.hook
@@ -63,6 +63,7 @@ build() {
     --libdir=/usr/lib32 \
     -Dbroadway_backend=true \
     -Dcloudproviders=false \
+    -Dtracker3=false \
     -Dcolord=yes \
     -Dgtk_doc=false \
     -Dintrospection=false \

Frogboy commented on 2021-04-14 05:07

It fails building:

configure: error: 
The development files for GTK+ were not found. For GTK+ 2, please
ensure that pkg-config is in the path and that gtk+-2.0.pc is
installed. For GTK+ 1.2 please check that gtk-config is in the path,
and that the version is 1.2.3 or above. Also check that the
libraries returned by 'pkg-config gtk+-2.0 --libs' or 'gtk-config
--libs' are in the LD_LIBRARY_PATH or equivalent.

==> ERROR: A failure occurred in build().
    Aborting...
error making: lib32-wxgtk3