Package Details: libappindicator-gtk2-ubuntu 12.10.1.18.04.20180322.1-1

Git Clone URL: https://aur.archlinux.org/libappindicator-ubuntu.git (read-only)
Package Base: libappindicator-ubuntu
Description: A library to allow applications to export a menu into the Unity Menu bar (GTK+ 2 library)
Upstream URL: https://launchpad.net/libappindicator
Licenses: LGPL
Groups: unity
Conflicts: libappindicator-gtk2
Provides: libappindicator-gtk2
Submitter: horsemanoffaith
Maintainer: horsemanoffaith
Last Packager: horsemanoffaith
Votes: 0
Popularity: 0.000000
First Submitted: 2016-02-07 04:03
Last Updated: 2018-05-05 03:42

Required by (71)

Sources (3)

Latest Comments

horsemanoffaith commented on 2018-03-13 04:51

I just discovered this tonight- you can issue the command TERM=xterm, then build the package in gnome-terminal. It then builds correctly.

horsemanoffaith commented on 2018-03-11 06:51

Due to an incompatibility issue between Mono and NCurses 6.1, this package cannot be built using gnome-terminal, and possibly other terminal emulators. It does build properly on xterm. The previous two comments have been addressed and rectified.

Anonymous comment on 2017-03-25 09:49

You should use
provides=('libappindicator-gtk2')
provides=('libappindicator-gtk3')
Since many of the packages dependencies cannot be satisfied with this package.

ragreener1 commented on 2017-03-03 13:25

Should this not be marked as a conflict with libappindicator-gtk2?

wenLiangcan commented on 2016-12-27 11:49

I'm using KDE and openbox.

horsemanoffaith commented on 2016-12-27 04:38

@WenLiangcan- I, so far, cannot replicate this issue. I will build this off a fresh install to see if I can get it to replicate. What WM/DE are you using?

wenLiangcan commented on 2016-12-18 09:38

No, I did not edited the PKGBUILD.

horsemanoffaith commented on 2016-12-17 16:56

Did you build these with the existing dependencies or did you edit the PKGBUILD to use the vanilla gtk2 and gtk3? I just updated my system and rebuilt- package builds correctly.

wenLiangcan commented on 2016-12-17 07:14

Failed to build:

Building gen-notification-item.xml.c from ../../src/notification-item.xml
Building gen-notification-item.xml.h from ../../src/notification-item.xml
Building gen-notification-watcher.xml.c from ../../src/notification-watcher.xml
Building gen-notification-watcher.xml.h from ../../src/notification-watcher.xml
CC libappindicator_la-app-indicator-enum-types.lo
CC libappindicator_la-app-indicator.lo
../../src/app-indicator.c: In function ‘shorty_activated_cb’:
../../src/app-indicator.c:2563:2: error: implicit declaration of function ‘indicator_desktop_shortcuts_nick_exec_with_context’ [-Werror=implicit-function-declaration]
indicator_desktop_shortcuts_nick_exec_with_context(priv->shorties, nick, NULL);
^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
cc1: all warnings being treated as errors
make[2]: *** [Makefile:727: libappindicator_la-app-indicator.lo] Error 1
make[2]: Leaving directory '/tmp/yaourt-tmp/aur-libappindicator-gtk3-ubuntu/src/build-gtk2/src'
make[1]: *** [Makefile:482: all-recursive] Error 1
make[1]: Leaving directory '/tmp/yaourt-tmp/aur-libappindicator-gtk3-ubuntu/src/build-gtk2'
make: *** [Makefile:413: all] Error 2
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build .