Package Details: libayatana-appindicator 0.5.5-1

Git Clone URL: https://aur.archlinux.org/libayatana-appindicator.git (read-only, click to copy)
Package Base: libayatana-appindicator
Description: Ayatana Application Indicators (Shared Library)
Upstream URL: https://github.com/AyatanaIndicators/libayatana-appindicator
Licenses: LGPL3, LGPL2.1
Conflicts: libayatana-appindicator-gtk3
Replaces: libayatana-appindicator-gtk3
Submitter: postblue
Maintainer: tari01
Last Packager: tari01
Votes: 3
Popularity: 0.000018
First Submitted: 2018-07-29 13:38
Last Updated: 2020-08-14 19:08

Latest Comments

1 2 Next › Last »

ckristhoff commented on 2020-07-21 02:30

Hi, I'm getting no 'app-indicator.sources.xml' in manjaro with mate desktop. Stackoverflow thread shorturl.at/oxDMZ

tari01 commented on 2020-07-17 12:06

@postblue

Thanks. I will do some magic as soon as I can.

postblue commented on 2020-07-17 06:36

@tari01 I am not able to do it at the moment, so I added you as a co-maintainer if you want to push an update.

tari01 commented on 2020-07-15 11:25

@postblue - this what I did: I removed the unnecessary build dependencies, but left python2 (It's safe - python2 will still be in the repos for a long time), then I deleted all the extra build recipes, except for the default Gtk3.

I would also like propose something: Now that we have only one version, could you please make the package simply provide "libayatana-appindicator". I think it's easier and cleaner if we go by the original name. Nothing will break for users, since I'm maintaining all the other Ayatana components in the AUR.

postblue commented on 2020-07-15 05:48

I am trying to write a PKGBUILD but I can't build for GTK+-3 only without having python-2, pygtk, and pygobobject installed at the moment https://github.com/AyatanaIndicators/libayatana-appindicator/issues/5

tari01 commented on 2020-07-14 20:41

The python2 + Gtk2 portion fails to build. I think these can be safely removed from the PKGBUILD. Python2 is EOL, while there are definitely no actively maintained Gtk2 applications with Ayatana support.

What basically needs to be built is only libayatana-appindicator-gtk3.

Jm56Z commented on 2020-06-22 17:16

When Making all in python, ld encouters an error :

/usr/bin/ld: .libs/ayatana_appindicator.o:(.bss+0x8): multiple definition of `_PyGObject_API'; .libs/ayatana_appindicatormodule.o:(.bss+0x0): first defined here

That crashes the compilation. :/

postblue commented on 2019-05-13 22:19

@lizufyr @gaelic perl-xml-libxml added to makedepends since revision 4 (2019-05-01)

lizufyr commented on 2019-05-13 14:29

I can confirm gaelic: Build requires perl-xml-libxml to be installed.

gaelic commented on 2019-04-30 21:35

I needed perl-xml-libxml to build.