Package Details: libcli 1.9.7-2

Git Clone URL: (read-only)
Package Base: libcli
Description: A shared library for including a Cisco-like command-line interface into other software.
Upstream URL:
Licenses: GPL
Submitter: None
Maintainer: dcelasun
Last Packager: rudy.matela
Votes: 12
Popularity: 0.000004
First Submitted: 2010-02-09 23:08
Last Updated: 2015-06-13 17:39

Latest Comments

dcelasun commented on 2016-10-10 11:33

@rudy.matela Thanks for letting me know, instead of just disowning it. I'll try to keep this updated as long I maintain netsniff-ng.

dtzWill commented on 2015-06-06 17:59

No problem, updated PKGBUILD works for me! Thanks!

rudy.matela commented on 2015-06-06 16:58

version 1.9.7-2: update the PKGBUILD with the changes introduced by dtzWill.

Sorry for not doing that before. Thank you dtzWill for providing the changes!

eniac commented on 2015-06-02 05:46

Thanks dtzWill, with your PKGBUILD libcli compiles fine.

dtzWill commented on 2015-05-31 19:00

Build breaks due to -Werror and -pedantic, should have -Werror removed.
This has been causing problems elsewhere, and has been solved similarly:

The following modified PKGBUILD fixes this for me:

# Maintainer: Rudy Matela <>
# Contributor: Mike Roberts <>
pkgdesc="A shared library for including a Cisco-like command-line interface into other software."
arch=('i686' 'x86_64')

prepare() {
sed -i 's/-Werror//' "$srcdir/$pkgname-$pkgver"/Makefile

build() {
cd "$srcdir/$pkgname-$pkgver"

package() {
cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir/" PREFIX='/usr' install

moonug commented on 2013-01-10 08:10


Anonymous comment on 2011-09-22 19:18

I no longer use Linux. Feel free to adopt this package.