Package Details: libdart 6.7.3-1

Git Clone URL: https://aur.archlinux.org/libdart.git (read-only)
Package Base: libdart
Description: Dynamic Animation and Robotics Toolkit
Upstream URL: https://dartsim.github.io
Keywords: dart dartsim gazebosim robotics
Licenses: BSD
Submitter: bchretien
Maintainer: midgard
Last Packager: midgard
Votes: 4
Popularity: 0.708720
First Submitted: 2014-06-19 11:19
Last Updated: 2019-03-01 15:08

Pinned Comments

midgard commented on 2019-03-01 15:25

If you're interested in some of the optional dependencies, they should be installed before building this package. If you install them later, you have to rebuild this package to use them with DART.

Latest Comments

1 2 Next › Last »

midgard commented on 2019-03-01 15:25

If you're interested in some of the optional dependencies, they should be installed before building this package. If you install them later, you have to rebuild this package to use them with DART.

midgard commented on 2019-03-01 15:23

I updated to the latest version, fixed the tests and added more optional dependencies.

I also added octomap as a dependency, it's necessary to successfully compile (won't link without it). However the build still says “Octomap 1.9.0 is found, but Octomap 1.9.0 or greater is not supported yet. Please see 'https://github.com/dartsim/dart/issues/1078' for the details”. Tests pass now, but I see that the Voxel test described in that issue is disabled if Octomap isn't found, so I'm not sure if that test ran.

@FlyingJay1: renaming AUR packages is not possible, it would have to be deleted and recreated. I don't think it's worth the hassle.

lasagnaphil commented on 2019-02-20 05:35

It seems like the octomap dependency is missing... And you need to install an older version of it (less than 1.9.0), because of the following issue: https://github.com/dartsim/dart/issues/1078

FlyingJay1 commented on 2018-11-20 04:39

This project is called 'dartsim', not 'libdart'. You may want to rename it.

GPereira commented on 2018-05-27 11:48

For now I've updated the package to 6.5 and disabled checking. Do you have any idea how to fix it?

wdna commented on 2018-05-09 09:37

Btw, for me all the tests are failing, I still have to run manually with --nocheck flag. What is required (and missing?) for the tests?

GPereira commented on 2018-05-09 09:17

I've update it, please check it :)

GPereira commented on 2018-05-09 09:07

Nah, send me via email please :) it's in my profile

GPereira commented on 2018-05-09 09:04

Thanks, post it here please

wdna commented on 2018-05-09 09:04

@GPereira I sent the file to your email on profile.