Package Details: libdecsync 1.9.0-1

Git Clone URL: https://aur.archlinux.org/libdecsync.git (read-only, click to copy)
Package Base: libdecsync
Description: libdecsync is a multiplatform library for synchronizing using DecSync.
Upstream URL: https://github.com/39aldo39/libdecsync
Keywords: decsync
Licenses: LGPL2
Submitter: twilk
Maintainer: twilk
Last Packager: twilk
Votes: 4
Popularity: 0.45
First Submitted: 2020-05-02 16:25
Last Updated: 2021-05-03 10:06

Latest Comments

sotitrox commented on 2021-07-15 03:35

with the default java env don't compile, give this in the first steps of build:

General error during semantic analysis: Unsupported class file major version 60

to compile needs to switch the java env https://wiki.archlinux.org/title/Java#Switching_between_JVM, I used java-8-openjdk.

I think it's better to set the makedepends to the specific version of the java runtime, this will install the correct version of java for the build, and also set the JAVA_HOME in the pkgbuild. sorry my bad english

tlvince commented on 2021-06-16 16:39

This doesn't use Java/ncurses at runtime - those deps should be moved to makedepends: https://github.com/tlvince/pkgbuild/commit/9b0e896de7b57363d1e27433980fee9a018c3117

twilk commented on 2020-12-17 21:29

@flortsch, seems to work for me with jdk-openjdk installed and set as the default. Could you retry with the latest PKGBUILD? If you can get it building for you with some JAVA_HOME, let me know and I can add it to the PKGBUILD!

flortsch commented on 2020-10-06 11:58

Does not build when default system Java version is set to latest. Maybe we can provide JAVA_HOME with a path to JDK8, if gradle picks this up.

vanadain commented on 2020-09-13 22:12

Nice! Everything works.

twilk commented on 2020-09-13 15:43

I've updated the package to the latest version, 1.6.1. That is the same as the latest commit on master -- it'd be the exact same thing you'd get from a -git package, so I won't make a separate -git package for now.

twilk commented on 2020-09-12 18:15

Hi everyone, sorry I haven't been keeping up with releases! I'll push an update when I'm back home on Monday. I've flagged the package as out of date so I remember.

vanadain commented on 2020-09-12 16:10

Please update this program. Decsync-evolution plugin from aur requires at least version 1.4 :/

vanadain commented on 2020-09-12 08:47

Build fails everytime due to instability of gradle servers (downloads more or less half of gradle 6.0.1 zip file and errors out). Same thing happens when I download gradle from official site using browser (it cannot download whole file, at least not at once). I tried to manually add gradle 6.0.1 to download folder and trick your script to use it, but no luck. Is there any solution to my problem? I cannot manually install libdecsync from source either, for same reason. Make fails to download gradle. At least on my connection. I have a slow but generally stable connection. I only have problem with gradle servers.

EDIT: Nevermind, I manually downloaded gradle zip and pasted in .gradle folder structure. And changed java_home to dk8-openjdk-dcevm (and uninstalled official java 8 from repo). It works, but this is old. Please, create git version of this program. I created working PKGBUILD for git version, tho I'm a noob. I can send you mine git PKGBUILD, if you would send it to aur.