Package Details: libdigidocpp 3.17.1.1453-1

Git Clone URL: https://aur.archlinux.org/libdigidocpp.git (read-only, click to copy)
Package Base: libdigidocpp
Description: Library for creating, signing and verification of digitally signed documents, according to XAdES and XML-DSIG standards
Upstream URL: https://www.id.ee/
Keywords: esteid
Licenses: LGPL-2.1-or-later
Submitter: kevku
Maintainer: kevku
Last Packager: kevku
Votes: 18
Popularity: 0.47
First Submitted: 2012-12-12 12:15 (UTC)
Last Updated: 2024-04-19 06:56 (UTC)

Latest Comments

1 2 3 4 5 6 Next › Last »

kevku commented on 2023-10-22 08:16 (UTC)

libxsd was missing in makedepends for xsd 4.2

<deleted-account> commented on 2023-10-06 18:54 (UTC)

Note: To install libdigidocpp YOU NEED TO DOWNGRADE XSD TO v4.0! https://archive.archlinux.org/packages/x/xsd/xsd-4.0.0-4-x86_64.pkg.tar.zst Edit: fixed (see comment above)

<deleted-account> commented on 2023-10-06 18:54 (UTC)

Note: To install libdigidocpp YOU NEED TO DOWNGRADE XSD TO VERSION 4.0! sudo pacman -S wget wget https://archive.archlinux.org/packages/x/xsd/xsd-4.0.0-4-x86_64.pkg.tar.zst sudo pacman -U xsd-4.0.0-4-x86_64.pkg.tar.zst

<deleted-account> commented on 2023-10-06 18:04 (UTC)

CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:230 (message): Could NOT find XSD (missing: XSD_INCLUDE_DIR) (found suitable version "4.2.0", minimum required is "4.0") Call Stack (most recent call first): /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:600 (_FPHSA_FAILURE_MESSAGE) cmake/modules/FindXSD.cmake:28 (FIND_PACKAGE_HANDLE_STANDARD_ARGS) CMakeLists.txt:46 (find_package)

yupi commented on 2023-08-28 00:51 (UTC) (edited on 2023-08-28 00:52 (UTC) by yupi)

@zeroconf, I think you need to rebuild all the packages that depend on openssl: xml-security-c, qdigidoc4, libdigidocpp.

zeroconf commented on 2023-08-28 00:14 (UTC) (edited on 2023-08-28 00:16 (UTC) by zeroconf)

@kevku, you said: this package does not need openssl-1.1, fix your broken system.

well, I removed: yay -Rns openssl-1.1 and DigiDoc didn't start anymore with following error message:

qdigidoc4: error while loading shared libraries: libcrypto.so.1.1: cannot open shared object file: No such file or directory

When upgraded, I always choose cleanbuild. This will delete old files and download all from scratch. It would be useful to describe, how to fix if there is anything, what we can fix in order to be free from openssl-1.1 dependency.

yupi commented on 2023-08-21 08:04 (UTC) (edited on 2023-08-21 08:05 (UTC) by yupi)

Oh, I see, xml-security-c needs a rebuild because of openssl's major upgrade. So one way to automatically solve it for most people, would be to increment xml-security-c's pkgrel, forcing a rebuild.

kevku commented on 2023-08-21 04:42 (UTC)

this package does not need openssl-1.1, fix your broken system.

yupi commented on 2023-08-20 07:48 (UTC)

@kevku could you please add a dependency on openssl-1.1 for this package?

idabmat commented on 2023-01-26 00:57 (UTC)

@demiluxmed you need to install openssl-1.1 for this package to build.