Package Details: libdispatch-git 2021.03.05.a.r0.g34f383d-1

Git Clone URL: https://aur.archlinux.org/libdispatch-git.git (read-only, click to copy)
Package Base: libdispatch-git
Description: Support for concurrent code execution on multicore hardware, includes libblocksruntime
Upstream URL: https://apple.github.io/swift-corelibs-libdispatch/
Licenses: Apache
Conflicts: libdispatch, swift, swift-development
Provides: libdispatch
Submitter: omor1
Maintainer: soloturn (FabioLolix, EndlessEden)
Last Packager: soloturn
Votes: 1
Popularity: 0.170200
First Submitted: 2017-06-20 00:34 (UTC)
Last Updated: 2021-03-07 09:25 (UTC)

Dependencies (3)

Required by (20)

Sources (2)

Latest Comments

soloturn commented on 2023-01-02 11:14 (UTC) (edited on 2023-01-02 11:16 (UTC) by soloturn)

@EndlessEden, @FabioLolix added you as maintainer.

apple changed the version of a release now to something like: swift-5.5-RElEASE

EndlessEden commented on 2022-02-04 11:14 (UTC)

2 issues.

  1. Missing conflicts & replaces with libblocksruntime [conflicts=($_basename swift swift-development libblocksruntime) replaces=(libblocksruntime)]

  2. Version string is a absolute mess "swift.5.6.DEVELOPMENT.SNAPSHOT.2022.01.11.a.r0.g880bf65-1" is not a valid/reasonable string. (5.6.r0.g880bf65-1 would be perfect) [git describe --long | sed 's/swift-//g;s/DEVELOPMENT-//g;s/SNAPSHOT-//g;s/-[0-9][0-9][0-9][0-9]-[0-9][0-9]-[0-9][0-9]-a//g;s/([^-]*-g)/r\1/;s/-/./g' ]

FabioLolix commented on 2021-08-19 09:49 (UTC)

Hello,

  • you are skipping intergrity check on the patch
  • using -j $(nproc) is prohibited