Package Details: libffi7 3.3-2

Git Clone URL: https://aur.archlinux.org/libffi7.git (read-only, click to copy)
Package Base: libffi7
Description: Portable foreign function interface library (ABI version 7)
Upstream URL: http://sourceware.org/libffi
Licenses: MIT
Submitter: jwty
Maintainer: jwty
Last Packager: jwty
Votes: 14
Popularity: 1.86
First Submitted: 2021-10-20 04:26 (UTC)
Last Updated: 2021-10-24 15:00 (UTC)

Pinned Comments

jwty commented on 2022-03-31 22:51 (UTC)

Please do not flag this package as out of date -- version 3.3 is the only version with soname 7, and this package is intended to provide just that version. Newest version is always available in official repositories.

Latest Comments

jwty commented on 2022-03-31 22:51 (UTC)

Please do not flag this package as out of date -- version 3.3 is the only version with soname 7, and this package is intended to provide just that version. Newest version is always available in official repositories.

tallero commented on 2021-12-24 10:16 (UTC)

At this moment this package is needed to build a working archlinux for i686.

sonance2071 commented on 2021-10-25 17:23 (UTC)

Fixed my issue with Pycharm

jwty commented on 2021-10-24 14:57 (UTC)

@gmy Strange, I tested the PKGBUILD once again in a clear install and check step finished just fine. It does take quite a long time to complete, and I honestly don't think it's necessary for a legacy package – only left it in because most other libffi packages did as well. I've removed it.

gmy commented on 2021-10-22 11:50 (UTC)

Check step fails for me with:

FAIL: libffi.complex/cls_align_complex_float.c (test for excess errors)
Running ../../testsuite/libffi.go/go.exp ...

        === libffi Summary ===

# of expected passes        776
# of unexpected failures    1

Full check log: https://gist.github.com/gmykhailiuta/3a1564a101ffa47b9d49ed2f40b153c6

The package itself builds just fine. Would you mind to disable the check step? I've noticed that libffi-git does that already.

Thank you for the efforts of creating this package!