Package Details: libfm-qt-git

Git Clone URL: (read-only, click to copy)
Package Base: libfm-qt-git
Description: Qt port of libfm, a library providing components to build desktop file managers
Upstream URL:
Licenses: LGPL
Conflicts: libfm-qt, pcmanfm-qt
Provides: libfm-qt
Submitter: pmattern
Maintainer: yan12125
Last Packager: yan12125
Votes: 4
Popularity: 0.54
First Submitted: 2015-12-01 10:55 (UTC)
Last Updated: 2023-05-17 16:15 (UTC)

Latest Comments

1 2 Next › Last »

yan12125 commented on 2024-03-15 05:22 (UTC)

Hi txtsd, thanks for the help. The Qt 6 migration requires coordination among all LXQt-related packages, and I feel the AUR interface kind of inconvenient for such discussions. Mind to move to for further discussions?

txtsd commented on 2024-03-13 06:12 (UTC)

Can I have co-maintainer on this? I'd like to bring it up to speed with the qt6 changes, and I'd also like to keep it updated as and when dependencies change. Same as for the pcmanfm-qt-git package.

yan12125 commented on 2018-06-10 13:43 (UTC)

Also, could you add gvfs as an optional dependency? That packages enables support for the trash bin and network devices.

yan12125 commented on 2018-06-07 07:22 (UTC) (edited on 2018-06-07 07:22 (UTC) by yan12125)

Hi, with recent changes [1], libfm is no longer a dependency. Could you drop that? Here's a working PKGBUILD at [2]. If you're too busy with that, I'm willing to maintain this package, too.



pmattern commented on 2017-01-22 14:32 (UTC)

This is still the problem that was already discussed with user ozky 2015/12. To sum it up: libfm-qt needs libfm ≥ 1.2.0. When package libfm-qt-git was established this requirement was already met by libfm from the official repositories but there were still some too old versions in the AUR, hence I've set depends=([...] 'libfm>=1.2.0'). Package libfm-git states among other provides=libfm (via variable _pkgbase), but packages "provided" are not assigned the same version as the underlying package itself, here libfm-git, see This is causing the problem you're facing. A possible solution would have been to make package libfm-git state something like provides=("$_pkgbase=$pkgver" [...]), but the corresponding request remained unanswered. Anyway there are no longer any outdated versions of libfm in the AUR by now so I've simply dropped that version dependency which should get you started. Notes It's not the AUR helpers which are to blame, rather, you'll make the same findings running 'makepkg -s' in a checkout of libfm-qt-git. The error message could be considered a bit misleading. It's dealing with the package names only while it's in fact an issue with that version dependency. Recent versions of libfm from community do no longer depend on GTK either.

excalibur1234 commented on 2016-12-11 13:45 (UTC)

when i install this package with pacaur or yaourt, "libfm" is still still required as a hard dependency. i have to change the PKGBUILD in order to be able to compile it with "libfm-git" instead of "libfm". is it possible to change something (i do not know what) to make it possible to compile and install this package with "libfm-git" preinstalled? ("libm-git" has multiple advantages over "libfm", e.g. it does not depend on "gtk2")

yan12125 commented on 2016-08-03 17:11 (UTC)

Please add git to makedepends.

g360 commented on 2016-07-10 22:00 (UTC)

It seems this package should conflict with pcmanfm-qt <= 0.10 as it prevents the installation of libfm-qt{-git} when this older version of pcmanfm-qt is installed.

ozky commented on 2015-12-04 15:44 (UTC)

This is because i have used only libfm-git without whole lxqt git and pcmanfm-qt git.

pmattern commented on 2015-12-04 15:28 (UTC)

@ozky Tweaking variable provides in package libfm-git is meant to satisfy the need for a distinct version by libfm-qt. It does not influence the dependencies themselves. So libfm-git will still provide both libfm and libfm-extras which hence have to get removed in order to install package libfm-git. All expected behaviour. You may want to have another look into the wiki link provided in my first post. Those conflicts have nothing to do with libfm-git either. Rather, you have an old version of PCManFM-Qt installed that still provides libfm-qt itself. See "The only problem..." in note to contadino earlier. Before submitting package libfm-qt-git I first considered having a hint displayed but actually found the situation clear enough later, tbh.