Package Details: libfm-qt-git

Git Clone URL: (read-only, click to copy)
Package Base: libfm-qt-git
Description: Qt port of libfm, a library providing components to build desktop file managers
Upstream URL:
Licenses: LGPL
Conflicts: libfm-qt, pcmanfm-qt<=0.10.0
Provides: libfm-qt=
Submitter: pmattern
Maintainer: yan12125
Last Packager: yan12125
Votes: 4
Popularity: 0.000000
First Submitted: 2015-12-01 10:55
Last Updated: 2018-08-30 11:02

Latest Comments

« First ‹ Previous 1 2

pmattern commented on 2015-12-04 10:44

Not sure what's the purpose of your last comment.
Your initial concern is absolutely valid and an attempt to solve it was already made, see my first reply. For the time being you may download the AUR archive of libfm-git, change the provides variable in PKGBUILD to provides=("$_pkgbase=$pkgver" "$_pkgbase-extra") and build / install the package manually. Package libfm-qt-git and all packages depending on it can then be installed as usual.

Package libfm can be replaced with libfm-git without issues here. Packages libfm and libfm-extra have to get replaced by libfm-git which is providing both and there's the version issue discussed with ozky. But that aside no problems. You are aware that using libfm-git isn't mandatory at all and that libfm will do? Also, what's the reason to remove libfm-git? Just installing the package (libfm or libfm-git) that shall be used is OK.
The only possible problem I'm seeing is that former pcmanfm-qt-git packages still comprising libfm-qt conflict with package libfm-qt-git. But this is a normal consequence of the transition and can be solved easily by removing package pcmanfm-qt-git (and possibly lximage-qt-git) while no session is running and then installing packages implementing the outsourcing of libfm-qt.
On a side note it would be good if you posted shell output in English. Can be achieved either by invoking distinct commands with an appropriate LANG variable set, e. g. 'LANG=C yaourt -R foo bar', or by running 'export LANG=C' which will affect the current shell session as a whole until an other value is set.

stefonarch commented on 2015-12-04 08:07

I get a cicle and will end up removing and reinstalling a lot of stuff....

libfm e libfm-git conflicts

$ yaourt --noconfirm -R libfm-git
controllo delle dipendenze in corso...
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: menu-cache: richiede libfm-extra
:: pcmanfm: richiede libfm
:: pcmanfm-qt-git: richiede libfm
$ yaourt --noconfirm -R libfm-git pcmanfm
controllo delle dipendenze in corso...
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: menu-cache: richiede libfm-extra
:: pcmanfm-qt-git: richiede libfm
stef@arch:~$ yaourt --noconfirm -R libfm-git pcmanfm menu-cache pcmanfm-qt-git
controllo delle dipendenze in corso...
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: lximage-qt-git: richiede pcmanfm-qt
:: lxqt-panel-git: richiede menu-cache
:: lxqt-runner-git: richiede menu-cache

ozky commented on 2015-12-03 18:21

I have installed libfm-git because i can remove that gtk2 dep from libfm and use my totally gtk free lxqt. This will break lxqt git as pacmanfm-qt git use libfm-git.

pmattern commented on 2015-12-03 17:31

Demanding distinct minimum package versions is hardly ever needed in packages of the official repositories given that the most recent releases should be running on an up to date system anyway. But as for the AUR outdated versions can persist quite a long time as the maintenance isn't as strict as in the official repositories and as VCS packages don't get updated automatically as long as the version determined by pkgver() at build time is more recent than the one stated by variable pkgver in PKGBUILD.
The latter was the reason to have variable depends state the version of libfm that's asked for in CMakeLists.txt of libfm-qt. But again, if it should turn out this didn't make sense I won't hesitate to remove this condition.

Alister.Hood commented on 2015-12-03 04:16

Interesting. When I first started using arch I filed a ticket on an official package that said it required a version which actually wasn't new enough - but I was told that because Arch policy is that people should always run the latest version they don't bother keeping version dependencies correct.

pmattern commented on 2015-12-03 00:48

So far I had been assuming any package stated by variable 'provides' would get the same version assigned as the underlying 'pkgname' and wasn't aware of what's written on So indeed libfm-qt-git can't get built against libfm-git right now besides the latter sure provides a suitable version.
But I think it makes more sense to have libfm-git provide a suitable version of libfm than dropping the minimum version of libfm which libfm-qt-git depends on. I've filed a respective comment on

ozky commented on 2015-12-02 20:21

Should this require libfm instead of libfm 1.2.0 as it will break compile with libfm-git.